Der Status des Inhaltsindex bleibt bei der Durchforstung in einer Exchange Server 2010-Datenbank hängen

Ursprüngliche KB-Nummer: 2820817

Symptome

In einer Microsoft Exchange Server 2010-Datenbank wird der Inhaltsindexstatus als "Durchforstung" angezeigt, und es scheint nie den Status "fehlerfrei" zu erreichen. Auch wenn der Leistungsindikator Anzahl der erfolgreich indizierten Dokumente einen progressiven Anstieg der Anzahl der indizierten Dokumente anzeigt, verringert sich der Wert im Leistungsindikator Anzahl von Postfächern, die noch nicht durchforstet werden, nicht wie erwartet.

In diesem Fall werden die folgenden Ereignisse im Anwendungsprotokoll protokolliert:

Time:
ID: 102
Level: Error
Source: MSExchange Search Indexer
Machine: Mailboxserver.contoso.com
Message: Exchange Search Indexer has failed to crawl the mailbox (8832ee80-47b8-4b0e-a98f-c4a239794707) in database (Database1) due to error: (Microsoft.Exchange.Search.MailboxCrawlFailedException: Failed to logon to mailbox). This mailbox will be retried later.
Time:
ID: 5617
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: CI troubleshooter exchange search service restart attempt 81.

Ursache

Dieses Problem tritt auf, wenn System Center Operations Manager das Toubleshoot-CI.ps1 Skript ausführt. Dies führt dazu, dass die Exchange-Suchdienst neu gestartet wird, bevor der Indizierungsprozess abgeschlossen ist.

Lösung

Um dieses Problem zu beheben, verhindern Sie, dass der System Center Operations Manager-Server das Troubleshoot-CI.ps1 Skript wie folgt ausführt:

  1. Öffnen Sie System Center Operations Manager.
  2. Klicken Sie auf Management Pack-Objektmonitor>.
  3. Geben Sie im Feld Suchen nachproblembehandlung ein, und klicken Sie dann auf Jetzt suchen.
  4. Suchen Sie das Element, das Troubleshoot-CI.ps1 Skripts entspricht, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Eigenschaften.
  5. Klicken Sie auf der Registerkarte Außerkraftsetzung auf Außerkraftsetzung.
  6. Aktivieren Sie das Kontrollkästchen Aktiviert , legen Sie die Option Wert außer Kraft setzen auf False fest, und klicken Sie dann auf OK.

Weitere Informationen

In der Regel führt System Center Operations Manager das Troubleshoot-CI.ps1 Skript alle zwei Stunden aus. Wenn das Troubleshoot-CI.ps1-Skript jedoch eines der folgenden Symptome erkennt, löst es einen Neustart des Exchange-Suchdiensts aus:

  • Deadlock: Deadlocks der Exchange-Suche beim Warten auf Threads aus MSSearch.
  • Beschädigung: Mindestens ein Suchindex ist beschädigt.
  • Stagnieren: Ähnelt einem Deadlock, da die Indizes nicht aktualisiert werden.
  • Backlog: Der Suchkatalog ist im Rückstand, sodass geplante Indexsuchen nicht wie erwartet ausgeführt werden.

Im Folgenden finden Sie ein Beispiel für ein Ereignis, das protokolliert wird, wenn das Troubleshoot-CI.ps1 Skripts ausgeführt wird:

Time:
ID: 5611
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: Indexing backlog reached a critical limit of 48 hours or the number of items in the retry queue is greater than 10000 for one or more databases: Database1 (0, 12572, 0)Database1 (0, 31859, 0)

Wenn die Datenbanken über große Postfächer oder Postfächer mit einer hohen Elementanzahl verfügen, dauert es in der Regel länger als zwei Stunden, bis der Indizierungsprozess abgeschlossen ist. Und wenn der Exchange-Suchdienst neu gestartet wird, werden die Postfächer zur erneuten Indizierung wieder in die Liste eingefügt. In dieser Situation hat der Durchforstungsprozess möglicherweise nie die Chance, den Vorgang abzuschließen.