L’état de l’index de contenu reste bloqué dans l’analyse dans une base de données Exchange Server 2010

Numéro de la base de connaissances d’origine : 2820817

Symptômes

Dans une base de données Microsoft Exchange Server 2010, l’état d’index de contenu est affiché sous la forme « analyse », et il ne semble jamais atteindre un état « sain ». En outre, même si le compteur de performances Nombre de documents correctement indexés indique une augmentation progressive du nombre de documents indexés, la valeur du compteur Nombre de boîtes aux lettres restantes à analyser ne diminue pas comme prévu.

Dans ce cas, les événements suivants sont enregistrés dans le journal des applications :

Time:
ID: 102
Level: Error
Source: MSExchange Search Indexer
Machine: Mailboxserver.contoso.com
Message: Exchange Search Indexer has failed to crawl the mailbox (8832ee80-47b8-4b0e-a98f-c4a239794707) in database (Database1) due to error: (Microsoft.Exchange.Search.MailboxCrawlFailedException: Failed to logon to mailbox). This mailbox will be retried later.
Time:
ID: 5617
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: CI troubleshooter exchange search service restart attempt 81.

Cause

Ce problème se produit lorsque System Center Operations Manager exécute le script Toubleshoot-CI.ps1. Cela entraîne le redémarrage de l’service Search Exchange avant la fin du processus d’indexation.

Résolution

Pour résoudre ce problème, empêchez le serveur System Center Operations Manager d’exécuter le script Troubleshoot-CI.ps1 comme suit :

  1. Ouvrez System Center Operations Manager.
  2. Cliquez surMoniteurd’objets du pack d’administration>.
  3. Dans la zone Rechercher , tapez résoudre les problèmes, puis cliquez sur Rechercher maintenant.
  4. Recherchez l’élément qui correspond à Troubleshoot-CI.ps1 script, cliquez dessus avec le bouton droit, puis cliquez sur Propriétés.
  5. Sous l’onglet Remplacer , cliquez sur Remplacer.
  6. Sélectionnez la zone Case activée activé, définissez l’option Remplacer la valeur sur False, puis cliquez sur OK.

Informations supplémentaires

En règle générale, System Center Operations Manager exécute le script Troubleshoot-CI.ps1 toutes les deux heures. Toutefois, si le script Troubleshoot-CI.ps1 détecte l’un des symptômes suivants, il déclenche un redémarrage du service de recherche Exchange :

  • Interblocage : blocages de recherche Exchange en attendant des threads de MSSearch.
  • Corruption : un ou plusieurs index de recherche sont endommagés.
  • Décrochage : ressemble à un interblocage dans le sens où les index ne sont pas mis à jour.
  • Backlog : le catalogue de recherche étant en backlog, les recherches d’index planifiées ne s’exécutent pas comme prévu.

Voici un exemple d’événement enregistré lors de l’exécution du script Troubleshoot-CI.ps1 :

Time:
ID: 5611
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: Indexing backlog reached a critical limit of 48 hours or the number of items in the retry queue is greater than 10000 for one or more databases: Database1 (0, 12572, 0)Database1 (0, 31859, 0)

Si les bases de données ont des boîtes aux lettres volumineuses ou des boîtes aux lettres avec un nombre élevé d’éléments, le processus d’indexation prend généralement plus de deux heures. Lorsque le service de recherche Exchange redémarre, les boîtes aux lettres sont de nouveau placées dans la liste pour la réindexation. Dans ce cas, le processus d’analyse peut ne jamais avoir la chance de se terminer.