Error al instalar WID en Windows Server 2012: el servicio MSSQL$MICROSOFT##WID no pudo iniciar sesión como NT SERVICE\MSSQL$MICROSOFT##WID

En este artículo se soluciona un problema por el que no se puede instalar Windows Internal Database (WID) en un equipo que ejecuta Windows Server 2012.

Se aplica a: Windows Server 2012 R2
Número de KB original: 2832204

Síntomas

Al instalar Servicios de federación de Active Directory (AD FS) (AD FS) mediante el Asistente para agregar roles y características en Windows Server 2012, se produce un error en la instalación de WID. Y recibe el siguiente mensaje de error:

El servicio MSSQL$MICROSOFT##WID no pudo iniciar sesión como NT SERVICE\MSSQL$MICROSOFT##WID con la contraseña configurada actualmente debido al siguiente error:
Error de inicio de sesión: no se ha concedido al usuario el tipo de inicio de sesión solicitado en este equipo.
Servicio: MSSQL$MICROSOFT##WID

Dominio y cuenta: NT SERVICE\MSSQL$MICROSOFT##WID

Esta cuenta de servicio no tiene el derecho de usuario necesario "Iniciar sesión como servicio".

Acción del usuario

Asigne "Iniciar sesión como servicio" a la cuenta de servicio de este equipo. Puede usar configuración de seguridad local (Secpol.msc) para hacerlo. Si este equipo es un nodo de un clúster, compruebe que este derecho de usuario está asignado a la cuenta de servicio de clúster en todos los nodos del clúster. Si ya ha asignado este derecho de usuario a la cuenta de servicio y el derecho de usuario parece quitarse, consulte con el administrador de dominio para averiguar si un objeto directiva de grupo asociado a este nodo podría estar quitando el derecho.

Causa

Cuando se instala WID, se crea la NT SERVICE\MSSQL$MICROSOFT##WID cuenta virtual local. A esta cuenta se le concede el derecho de usuario mediante directiva de grupo Log on as a service locales. Si un objeto de directiva de grupo (GPO) vinculado a un sitio, dominio o unidad organizativa sobrescribe la configuración de directiva de grupo local, la cuenta NT SERVICE\MSSQL$MICROSOFT##WID no tiene los derechos de usuario necesarios. Por lo tanto, WID no se puede instalar.

Solución alternativa

Para solucionar el problema, use uno de los métodos siguientes:

  • Asigne el derecho de Log on as a service usuario a NT SERVICE\ALL SERVICES en el GPO que define el derecho de usuario.
  • Excluya el equipo del GPO que define el derecho de usuario.

Más información

También puede experimentar otros síntomas en esta situación. Por ejemplo, es posible que el servicio WID parezca estar instalado, pero no se inicia. Además, el Asistente para agregar roles y características indica que hay un reinicio pendiente.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.