Lync ne peut pas vérifier que le serveur est approuvé pour votre adresse de connexion » message lors de la connexion du client

Symptômes

Cet article décrit deux scénarios qui se produisent lorsque le client Microsoft Lync ne peut pas établir une relation d’approbation avec des ressources qui nécessitent une connexion TLS sécurisée.

Scénario 1

Lorsque les utilisateurs essaient de se connecter à Microsoft Lync dans un environnement Lync Server 2013 pour la première fois, ils reçoivent le message suivant dans une boîte de dialogue :

Lync is attempting to connect to:
<Fully qualified domain name (FQDN) of a server>
Lync cannot verify that the server is trusted for your sign-in address. Connect anyway? 

Par exemple, la boîte de dialogue modèle d’approbation suivante s’affiche :

Capture d’écran montrant la boîte de dialogue Modèle d’approbation.

Scénario 2

La boîte de dialogue Lync – Connexion qui s’affiche dans la capture d’écran du scénario 1 affiche le nom de domaine complet (FQDN) de l’interface du serveur d’accès au client Exchange (CAS) du organization. Cette interface est utilisée par le client Lync pour accéder aux informations de boîte aux lettres utilisateur via les services Web Exchange (EWS). Ce comportement se produit si l’URI SIP de l’utilisateur Lync contient un suffixe de domaine qui ne correspond pas au suffixe de domaine de l’interface CAS Exchange. Si l’utilisateur choisit de ne pas approuver la connexion à l’interface DE cas Exchange, le client Lync n’aura pas accès aux services de boîte aux lettres Exchange approvisionnés par EWS.

Pour vérifier ce comportement, procédez comme suit :

  1. Assurez-vous que le client Lync est connecté à sur le bureau du client Windows.
  2. Maintenez la touche Ctrl enfoncée et cliquez avec le bouton droit sur l’icône Lync dans la zone de notification du client Windows.
  3. Dans le menu contextuel, cliquez sur Informations de configuration.
  4. Recherchez la ligne « EWS Information ».
  5. Si cette ligne contient « EWS n’est pas entièrement initialisé », vous rencontrez le comportement scénario 2.

Cause

Ce problème se produit parce que le nom de domaine SIP de l’utilisateur ne correspond pas aux noms de domaine dans les propriétés suivantes dans le certificat des services Web Lync et des services web Exchange :

  • Nom de l’objet
  • Nom commun

Résolution

Pour empêcher l’affichage de la boîte de dialogue Modèle d’approbation, utilisez la liste de domaines approuvés (TrustModelData) stratégie de groupe. Une fois cette stratégie définie, Lync approuve exclusivement les domaines spécifiés dans la stratégie. Valeurs prises en charge :

  • Non configuré (par défaut)/Désactivé

    Grâce à ce paramètre, les domaines suivants sont approuvés par défaut :

    • lync.com
    • outlook.com
    • lync.glbdns.microsoft.com
    • microsoftonline.com
  • Activé

    Ce paramètre spécifie la liste des domaines à faire confiance, par exemple : contoso.com, contoso.co.in.

Pour plus d’informations sur le paramètre de stratégie de groupe liste de domaines approuvés Lync 2013 (TrustModelData), consultez Configuration des stratégies de démarrage du client.

Pour plus d’informations sur les modèles d’administration Lync 2013.admx (ADMX) et .adml (ADML), voir Fichiers de modèles d’administration Office 2013 (ADMX/ADML) et Outil de personnalisation Office.

Informations supplémentaires

Scénario 1

Le client de bureau Lync 2013 utilise le nouveau mécanisme de découverte automatique pour localiser le service Web Lync interne ou externe, en fonction de l’emplacement réseau de l’utilisateur.

Le processus suivant se produit lorsque le client de bureau Lync 2013 tente de localiser le service Web Lync :

  1. Le client de bureau Lync 2013 envoie une paire de requêtes HTTP et HTTPS pour localiser le service de découverte automatique Lync. Les requêtes HTTP et HTTPS se composent d’un ensemble par défaut de valeurs de nom d’hôte interne ou externe et du nom de domaine SIP de l’utilisateur.

    Par exemple, le client de bureau Lync 2013 envoie les requêtes suivantes :

    http://LyncdiscoverInternal.contoso.com et https://LyncdiscoverInternal.contoso.com

    Remarque

    LyncdiscoverInternal.contoso.com est résolu en nom de domaine complet ou adresse IP du service web Lync interne.

    http://Lyncdiscover.contoso.com et https://Lyncdiscover.contoso.com

    Remarque

    Lyncdiscover.contoso.com est résolu en nom de domaine complet ou adresse IP de l’interface externe du proxy inverse.

  2. Le client de bureau Lync 2013 reçoit une réponse qui contient les URL internes et externes sécurisées du service de découverte automatique à partir des services web.

  3. Le client de bureau Lync 2013 tente de contacter le service de découverte automatique à l’aide d’une connexion HTTPS. Si le nom de domaine SIP de l’utilisateur ne correspond pas au nom de domaine dans la propriété Nom de l’objet ou Nom commun du certificat affecté au service Web Lync, la boîte de dialogue Modèle d’approbation s’affiche.

Scénario 2

Le client Lync effectue des requêtes HTTPS à l’interface DE cas Exchange dans le cadre de son processus de post-connexion. Ces demandes incluent l’accès au service de découverte automatique Exchange via des URL qui incluent le nom de domaine complet de l’interface CAS Exchange. Par exemple :

  • https://<smtpdomain>/autodiscover/autodiscover.xml
  • https://autodiscover.<smtpdomain>/autodiscover/autodiscover.xml

Si le nom de domaine complet du domaine SMTP ne correspond pas au nom de domaine complet du domaine SIP auquel le client Lync est connecté, le problème du scénario 2 se produit.

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