Se produce un error en la secuencia de tareas en Configuration Manager si las actualizaciones de software requieren varios reinicios
En este artículo se proporciona la información para resolver el problema por el que se produce el error no encontrado en el entorno de secuencia de tareas al usar una secuencia de tareas Configuration Manager.
Versión original del producto: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager, Configuration Manager (rama actual)
Número de KB original: 2894518
Resumen
El problema se ha corregido en la actualización acumulativa 3 para System Center 2012 Configuration Manager Service Pack 2 y System Center 2012 R2 Configuration Manager Service Pack 1 y en Configuration Manager rama actual, versión 1602.
Una nueva variable de secuencia de tareas opcional, SMSTSWaitForSecondReboot
, está disponible para controlar mejor el comportamiento del cliente cuando una instalación de actualización de software requiere dos reinicios.
Para obtener más información, consulte la sección Administración de actualizaciones de software o implementación del sistema operativo en Descripción de la actualización acumulativa 3 para Configuration Manager.
Para obtener Configuration Manager rama actual, consulte Variables de secuencia de tareas.
Síntomas
Supongamos que una secuencia de tareas Configuration Manager que usa el paso Instalar software Novedades instala una actualización de software que desencadena varios reinicios después de que la secuencia de tareas ejecute correctamente la tarea Instalar software Novedades. En esta situación, la secuencia de tareas puede producir un error y generar el siguiente mensaje de error:
Entorno de secuencia de tareas no encontrado
Nota:
Para evitar este problema en Configuration Manager, use la nueva opción Reintentar en el paso de secuencia de tareas Instalar software Novedades.
Causa
La secuencia de tareas controla el primer reinicio iniciado por la actualización de software. Sin embargo, la segunda solicitud de reinicio la inicia un componente de Windows (normalmente, Component-Based mantenimiento) y no se controla mediante la secuencia de tareas. Por lo tanto, el estado de ejecución de la secuencia de tareas no se guarda antes del reinicio porque la secuencia de tareas no controla el segundo reinicio. Cuando la secuencia de tareas se reanuda después del segundo reinicio, no hay ningún estado disponible para continuar correctamente.
Solución
Para resolver este problema, se recomienda aplicar las actualizaciones que requieran reinicios duales mediante la característica de actualizaciones de software habituales de Configuration Manager en lugar de usar secuencias de tareas. Se informó de que las siguientes actualizaciones de software requieren varios reinicios.
- 3126446 MS16-017: Descripción de la actualización de seguridad para el controlador de pantalla de Escritorio remoto: 9 de febrero de 2016
- 3096053 actualización de la pila de mantenimiento de septiembre de 2015 para Windows 8 y Windows Server 2012
- 3075222 MS15-082: Descripción de la actualización de seguridad de RDP en Windows: 11 de agosto de 2015
- 3067904 MS15-082: Descripción de la actualización de seguridad para Windows RDP: 14 de julio de 2015
- 3069762 MS15-067: Descripción de la actualización de seguridad para Windows RDP: 14 de julio de 2015
- 3003729 actualización de pila de mantenimiento de abril de 2015 para Windows 8 y Windows Server 2012
- 3035017 MS15-030: Descripción de la actualización de seguridad del protocolo de Escritorio remoto: 10 de marzo de 2015
- 3039976 MS15-030: Vulnerabilidad en el protocolo de Escritorio remoto podría permitir la denegación de servicio: 10 de marzo de 2015
- 3036493 MS15-030: Descripción de la actualización de seguridad del protocolo de Escritorio remoto: 10 de marzo de 2015
- 3003743 MS14-074: Vulnerabilidad en el protocolo de Escritorio remoto podría permitir la omisión de características de seguridad: 11 de noviembre de 2014
- 2984976 actualización rdp 8.0 para la administración restringida en Windows 7 o Windows Server 2008 R2
- 2981685 las actualizaciones de seguridad no se pueden instalar si BitLocker no está instalado en el equipo
- 2966034 Descripción de la actualización de seguridad de la versión de seguridad de Escritorio remoto para sistemas Windows 8.1 que no tienen instalada la actualización de 2919355: 10 de junio de 2014
- 2965788 MS14-030: Descripción de la actualización de seguridad de la versión de seguridad de Escritorio remoto para Windows: 10 de junio de 2014
- 2920189 Descripción del paquete acumulativo de actualizaciones de módulos UEFI no conformes revocados: 13 de mayo de 2014
- 2862330 MS13-081: Descripción de la actualización de seguridad de los controladores USB: 8 de octubre de 2013
- 2871777 Hay disponible una actualización de pila de mantenimiento para Windows RT, Windows 8 y Windows Server 2012: septiembre de 2013
- 2871690 aviso de seguridad de Microsoft: actualización para revocar módulos de cargador de arranque UEFI no compatibles
- 2821895 Hay disponible una actualización de pila de mantenimiento para Windows RT y Windows 8: junio de 2013
- 2771431 Hay disponible una actualización de pila de mantenimiento para Windows 8 y Windows Server 2012
- 2545698 texto en algunas fuentes principales aparece borroso en Internet Explorer 9 en un equipo que ejecuta Windows Vista, Windows Server 2008, Windows 7 o Windows Server 2008 R2
- 2529073 archivos binarios de algunos controladores USB no se actualizan después de instalar Windows 7 SP1 o Windows Server 2008 R2 SP1
Más información
Dado que la secuencia de tareas no controla este segundo reinicio, no se guarda ningún estado de ejecución antes del reinicio. Cuando la secuencia de tareas se reanuda después del reinicio, no hay ningún estado disponible para continuar correctamente. Además, es posible que el siguiente mensaje se registre en el archivo Smsts.log cuando experimente este problema:
!sVolumeID.empty(), HRESULT=80004005
!sTSMDataPath.empty(), HRESULT=80070002
TS::Utility::GetTSMDataPath( sDataDir ), HRESULT=80070002
No se pudo establecer el directorio de registro. Es posible que se pierda algún historial de ejecución.
El sistema no puede encontrar el archivo especificado. (Error: 80070002; Origen: Windows)
Ejecución de la secuencia de tareas
!sVolumeID.empty(), HRESULT=80004005
!sTSMDataPath.empty(), HRESULT=80070002
Entorno de secuencia de tareas no encontrado
Además, los clientes que ejecutan versiones de versión anteriores a Microsoft System Center 2012 Configuration Manager Service Pack 1 pueden contener la siguiente entrada de registro:
Secuencia de tareas completada en Windows PE.
El equipo cliente también puede estar bloqueado en modo de aprovisionamiento después de que se produzca un error en la secuencia de tareas. Para determinar si el equipo está en modo de aprovisionamiento, compruebe la HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\CcmExec
subclave del Registro.
ProvisioningMode
debe establecerse en false. Si se establece en true, use uno de los métodos siguientes para sacar al cliente del modo de aprovisionamiento:
Use el método
SetClientProvisioningMode
Instrumental de administración de Windows (WMI) para sacar al cliente del modo de aprovisionamiento correctamente. La manera más fácil de hacerlo es ejecutar el siguiente comando Windows PowerShell:Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
O bien, ejecute el siguiente comando en un símbolo del sistema con privilegios elevados:
powershell Invoke-WmiMethod -Namespace root\CCM -Class SMS_Client -Name SetClientProvisioningMode -ArgumentList $false
Vuelva a instalar el cliente.
Importante
No intente corregir el cliente cambiando el valor de ProvisioningMode
a false. Esta acción no sacará completamente al cliente del modo de aprovisionamiento.
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