Gli ID evento 32402, 61045 vengono registrati nei server Front End di Lync Server 2013 installati in Windows Server 2012 R2

Sintomi

Gli ID evento 32402, 61045 vengono registrati nei server Front End di Microsoft Lync Server 2013 installati nei computer che eseguono Windows Server 2012 R2.

Inoltre, si verificano i sintomi seguenti:

  • I client di Microsoft Lync 2013, Microsoft Lync 2010 o Microsoft Office Communicator 2007 R2 non possono partecipare alle conferenze usando le modalità di conferenza di Lync Server 2013 o Lync Server 2010.
  • I client Lync 2013, Lync 2010 o Office Communicator 2007 R2 non abilitati per Microsoft Exchange 2013 Unified Contact Store (UCS) non visualizzano le informazioni di contatto.
    Quando si verifica questo problema, nel registro eventi di Lync Server 2013 vengono registrati gli eventi seguenti:

ID evento 32042

Log Name: Lync Server
Source: LS User Services
Date: 10/15/2013 4:02:05 AM
Event ID: 32042
Task Category: (1006)
Level: Error
Keywords: Classic
User: N/A
Computer: LyncFE01.contoso.local
Description:
Invalid incoming HTTPS certificate.
Subject Name: LyncFE01.contoso.local Issuer: Contoso-CA

Cause: This can happen if the HTTPS certificate has expired, or is untrusted. The certificate serial number is attached for reference.

Resolution: Please check the remote server and ensure that the certificate is valid. Also ensure that the full certificate chain of the Issuer is present in the local machine.

Evento 61045

Log Name: Lync Server
Source: LS MCU Infrastructure
Date: 10/15/2013 4:02:20 AM
Event ID: 61045
Task Category: (1022)
Level: Error
Keywords: Classic
User: N/A
Computer: LyncFE01.contoso.local
Description: The DATAMCU was not able to stay connected to the Front End over the C3P channel (HTTPS Connection).
The Web Conferencing Server failed to send C3P notifications to the focus at https:// LyncFE01.contoso.local:444/LiveServer/Focus. 

Cause: The Front End may not be running correctly or may be unreachable over the network (broken HTTPS connection) from the MCU. Unavailability of The C3P channel affects conference controls, and can also prevent users from joining, starting conferences.

Resolution: Verify that the Front End server is running correctly and that network connectivity and an HTTPS Connection can be established between the MCU and the Front End server.

Causa

Questo problema può verificarsi quando i server Front End di Lync Server 2013 vengono installati in Windows Server 2012 R2 a causa delle modifiche apportate alla modalità di memorizzazione nella cache delle sessioni TLS in Windows Server 2012 R2. Queste modifiche causano l'esito negativo di alcuni server Lync Server 2013 che comportano comunicazioni tra server o tra server sulla porta TCP 444.

Soluzione alternativa

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema.

Per risolvere questo problema, impostare la chiave del Registro di sistema Schannel su un valore di 0x0002 in tutti i computer che ospitano server Front End di Lync Server 2013. Questa modifica disabilita l'ottimizzazione TLS del ticket di sessione nel sistema.

Nota

  • È possibile disabilitare questo valore senza compromettere la sicurezza del sistema. Il sistema tornerà a gestire le sessioni TLS esattamente come le sessioni sono state negoziate nei sistemi operativi Windows Server precedenti.
  • Lync Server 2013 è supportato da Windows Server 2012 R2 quando viene eseguita questa soluzione alternativa al Registro di sistema.
  1. Fare clic su Start, digitare regedit nella casella di ricerca Avvia e quindi fare clic su regedit.exe nell'elenco dei risultati.

  2. Individuare la seguente sottochiave del Registro di sistema:

    HKLM\System\CurrentControlSet\Control\SecurityProviders\Schannel

  3. Fare clic con il pulsante destro del mouse su Schannel e quindi scegliere Nuovo valore DWORD (32 bit).

  4. Digitare EnableSessionTicket, quindi premere INVIO.

  5. Fare clic con il pulsante destro del mouse su EnableSessionTicket e quindi scegliere Modifica.

  6. Modificare il valore esistente in 2 e quindi premere INVIO.

  7. Uscire dall'editor del Registro di sistema.

  8. Aprire Lync Server Management Shell.

  9. Eseguire i comandi di PowerShell di Lync Server seguenti nell'ordine specificato:

    Stop-CsWindowsService
    
    Start-CsWindowsService    
    

Ulteriori informazioni

Per ulteriori informazioni sull'esecuzione del backup e del ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows XP

Per altre informazioni su come disabilitare l'ottimizzazione dei ticket di sessione TLS in Server 2012 R2, vedere l'argomento Microsoft TechNet seguente:

Note sulla versione: problemi importanti in anteprima Windows Server 2012 R2

Ulteriore assistenza Visitare la community Microsoft.