Errore 3266 o 3013 quando si esegue un backup del database su disco o nastro o un ripristino del database da disco o nastro

Questo articolo fornisce informazioni utili per risolvere l'errore 3266 o 3013 che si verifica quando si esegue un backup del database su disco o nastro o un ripristino del database da disco o nastro.

Si applica a: Windows Server 2012 R2
Numero KB originale: 290787

Sintomi

Quando si esegue un backup del database su disco o nastro o un ripristino da disco o nastro, può verificarsi il messaggio di errore seguente:

SQL Server 7.0 Server:

Msg 3266, Livello 16, Stato 1, Riga 1
Il database soft filemark MTF (Microsoft Tape Format) nel dispositivo di backup 'devicename' non può essere letto, inibendo l'accesso casuale.
Server: Msg 3013, Livello 16, Stato 1, Riga 1
Operazione di backup o ripristino terminata in modo anomalo.

SQL Server 2000 Server:

Msg 3266, Livello 16, Stato 1, Riga 1
I dati di backup in 'devicename' non sono formattati correttamente. I backup non possono essere aggiunti, ma i set di backup esistenti possono comunque essere utilizzabili.
Server: Msg 3013, Livello 16, Stato 1, Riga 1
BACKUP DATABASE termina in modo anomalo.

SQL Server 2005 Server:

Msg 3013, Livello 16, Stato 1, Riga 1
I dati di backup alla fine di 'devicename' non sono formattati correttamente. I set di backup nel supporto potrebbero essere danneggiati e inutilizzabili. Per determinare i set di backup sul supporto, usare RESTORE HEADERONLY. Per determinare l'usabilità dei set di backup, eseguire RESTORE VERIFYONLY. Se tutti i set di backup sono incompleti, riformattare il supporto usando BACKUP WITH FORMAT, che elimina tutti i set di backup.
Server: Msg 3013, Livello 16, Stato 1, Riga 1

BACKUP DATABASE termina in modo anomalo.

Causa

Impossibile leggere un filemark nel dispositivo di backup. Esistono molti motivi per cui è possibile che si verifichi un errore di contrassegno file. Alcuni dei motivi includono quanto segue:

  • È possibile che si verifichi un errore multimediale nel dispositivo in cui si trova il backup.

  • Durante la creazione del backup può verificarsi un errore di scrittura.

    Ad esempio, è possibile che si verifichi una perdita di connettività durante un backup di rete. In alternativa, potrebbe verificarsi un errore del percorso di I/O per scaricare la scrittura su disco dopo che la scrittura su disco è stata segnalata come corretta.

Soluzione alternativa

Per consentire a SQL Server di eseguire nuovi backup nel dispositivo di backup, è necessario eliminare o cancellare manualmente il dispositivo usando il comando seguente:

BACKUP DATABASE mydatabase TO DISK='C:\MyDatabase.bak' with FORMAT

Se il messaggio di errore si verifica durante un'operazione di ripristino, potrebbe essere possibile recuperare altri set di backup dal dispositivo specificando il numero di file. Ad esempio, se tre (3) backup si trovava in un (1) dispositivo di backup, i set di backup 1 e 2 potrebbero essere utilizzabili. Per determinare se più set di backup si trovano in un dispositivo, eseguire il codice seguente da Query Analyzer:

RESTORE HEADERONLY FROM DISK='C:\MyDatabase.bak'

Ogni set di backup include una voce nell'output. Per indicare un set di backup specifico, usare questo codice:

RESTORE DATABASE mydatabase FROM DISK='C:\MyDatabase.bak' WITH FILE = FileNumber

Nota

FileNumber è il numero del set di backup da ripristinare.

Ulteriori informazioni

L'elenco seguente contiene note importanti relative ai backup e alle SQL Server.

  • Dopo SQL Server rileva un errore di contrassegno di file in un dispositivo, SQL Server non scrive informazioni aggiuntive nel dispositivo.

  • SQL Server archivia tutti i backup nel formato nastro Microsoft, indipendentemente dal fatto che il backup venga eseguito su disco o su nastro. Microsoft Tape Format usa i filemark per contenere informazioni quali le dimensioni del blocco e il numero di blocchi in un backup, oltre ad altre informazioni sul backup. Il formato nastro Microsoft usa anche i segni di file per delimitare i backup in un dispositivo di backup. Il fatto che un filemark sia mancante o danneggiato, suggerisce che almeno un backup nel dispositivo non è valido.

  • Sebbene sia possibile ripristinare alcuni set di backup dal dispositivo danneggiato, è necessario verificare l'integrità del database ripristinato.

  • SQL Server registra i dettagli dell'esito positivo o negativo durante un'operazione di backup o di ripristino nel log degli errori SQL Server e nelle tabelle della cronologia dei backup nel database di sistema msdb.

  • Se si verifica un errore 3266 durante il ripristino di un log delle transazioni o di un backup del database, esaminare i log seguenti per altre informazioni:

    • SQL Server log degli errori
    • Tabelle della cronologia di backup e ripristino
    • Registro eventi dell'applicazione
    • Registro eventi di sistema

Se non sono presenti dettagli sull'errore in questi log, è possibile che si sia verificato un errore non segnalato. Per assistenza, contattare il Servizio Supporto Tecnico Clienti Microsoft.