O Outlook não consegue ligar-se através de uma firewall ou de um servidor proxy que está a efetuar a Tradução de Endereços de Rede (NAT) entre redes públicas e privadas

Número original da BDC: 291615

Sintomas

Os clientes do Outlook não conseguem ligar-se através de uma firewall ou servidor proxy que esteja a executar NAT entre redes públicas e privadas.

Causa

Quando os pacotes IP que contêm as informações de chamada de procedimento remoto (RPC) são editados durante a tradução, os pacotes IP perdem as informações de conectividade RPC. Isto faz com que o cliente não se ligue ao servidor. Além disso, o Outlook pode ter problemas ao resolver o nome do Microsoft Exchange Server computador atrás da firewall ou do servidor proxy.

Solução

Uma solução alternativa para firewalls ou servidores proxy que não se baseiam no Microsoft Windows NT é efetuar uma tradução um-para-um entre as duas redes. Isto também é denominado abrir um tubo ou túnel entre as redes públicas e privadas. Esta ação aceita todos os pedidos de um endereço específico na rede pública e transmite-os diretamente para a rede privada. Para obter informações adicionais sobre como configurar uma tradução um-para-um, consulte a documentação do fabricante.

Uma tradução ou pipe um-para-um não funciona para firewalls e servidores proxy baseados no Windows NT porque o cliente do Outlook tenta vincular-se à porta mapeador de ponto final (EPM), porta 135, na firewall. Este servidor não devolve as informações de conectividade Exchange Server corretas ao cliente do Outlook.

Outra solução possível é utilizar Outlook Web App. Isto só requer permitir tráfego HTTP através da firewall ou do servidor proxy.

Mais informações

Para obter mais informações, veja os seguintes Pedidos de Comentários (RFCs):

  • RFC 1631 – Tradutor de Endereços de Rede IP (NAT)
  • RFC 1918 - Alocação de Endereços para a Internet Privada

Estes RFCs podem ser encontrados aqui.