Se produce un error en la instalación de DPM y genera el error 4323: No se pudo agregar un miembro

Este artículo le ayuda a corregir un problema en el que se produce un error en el programa de instalación de DPM al agregar un usuario al mensaje de error del grupo local al instalar System Center Data Protection Manager.

Versión original del producto: System Center Data Protection Manager
Número de KB original: 2930276

Síntomas

Al intentar instalar System Center Data Protection Manager, ya sea por primera vez o como actualización, se produce un error en la instalación y recibe el siguiente mensaje de error:

Error: el programa de instalación de DPM no pudo agregar un usuario al grupo local. Revise los detalles del error, realice la acción adecuada y vuelva a ejecutar el programa de instalación de DPM.
Identificador: 4323. Detalles: no se pudo agregar o quitar un miembro del grupo local porque el miembro no existe

También puede ver entradas similares a las siguientes en el archivo Setup.log:

[10/23/2013 11:07:42 AM] Información: Iniciar configuración.
[10/23/2013 11:07:42 AM] Información: Inicio del servicio:MSSQL$MSDPM<versión> en la máquina:DPMServerName marca restart:False
[10/23/2013 11:07:42 AM] Información: Inicio del servicio:SQLAgent$MSDPM<versión> en el equipo:DPMServerName marca restart:False
[10/23/2013 11:07:42 AM] Información: Inicio del servicio:ReportServer$MSDPM<versión> en el equipo:DPMServerName marca restart:False
[10/23/2013 11:07:42 AM] Información: Creación de un registro que contenga información de la cuenta del agente SQL
[10/23/2013 11:07:42 AM] Información : Consulta del espacio de nombres WMI: \\DPMServerName\root\cimv2 para la consulta: SELECT * FROM Win32_Service WHERE Name='SQLAgent$MSDPM<version>'
[10/23/2013 11:07:42 AM] Información: Nombre de la cuenta del Agente Sql = contoso-old\DPMServerName$
[10/23/2013 11:07:42 AM] Información: Creación de un registro que contenga la información de la ruta de acceso del trabajo del desencadenador
[10/23/2013 11:07:42 AM] Datos : TriggerJobPath = D:\Microsoft System Center <version>\DPM\DPM\bin\
[10/23/2013 11:07:42 AM] Información: Agregar usuario: contoso-old\DPMServerName$ al grupo local: Usuarios COM distribuidos en el servidor: DPMServerName
[23/10/2013 11:07:42 AM] * Excepción : => El programa de instalación de DPM no pudo agregar un usuario al grupo local. Revise los detalles del error, realice la acción adecuada y vuelva a ejecutar el programa de instalación de DPM. Microsoft.Internal.EnterpriseStorage.Dls.Setup.Exceptions.BackEndErrorException: se produjo la excepción del tipo "Microsoft.Internal.EnterpriseStorage.Dls.Setup.Exceptions.BackEndErrorException".
at Microsoft.Internal.EnterpriseStorage.Dls.Setup.NativeConfigHelper.AddAccountToLocalGroup(String accountName, String localGroupName, String machineName)
at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.RemoteDatabaseConfiguration.AddSqlAgentAccountToLocalGroups(String sqlAgentAccountName)
at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.BackEnd.MachineSpecificConfiguration(Boolean existingDB, Boolean upgradeing, Boolean isRemoteDb, String sqlServerMachineName, String sqlInstanceName, Boolean isRemoteReporting, String reportingMachineName, String reportingInstanceName)
at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.BackEnd.Configure(Boolean existingDB, Boolean upgradeing, String databaseLocation, String sqlServerMachineName, String sqlInstanceName, String reportingMachineName, String reportingInstanceName, Boolean oemSetup)
at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.DpmInstaller.ConfigurePostMsiUpgrade() at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.ProgressPage.UpgradeDpm()
at Microsoft.Internal.EnterpriseStorage.Dls.Setup.Wizard.ProgressPage.InstallerThreadEntry() *** Mojito error was: AddUserToLocalGroupFailed; 1387; WindowsAPI
[10/23/2013 11:07:44 AM] *** Error: El programa de instalación de DPM no pudo agregar un usuario al grupo local. Revise los detalles del error, realice la acción adecuada y vuelva a ejecutar el programa de instalación de DPM.
Identificador: 4323. Detalles: no se pudo agregar o quitar un miembro del grupo local porque el miembro no existe
[10/23/2013 11:07:44 AM] Información: Error en la actualización de DPM.
Para obtener más información, haga clic en la pestaña Error.
Para solucionar este problema, consulte http://go.microsoft.com/fwlink/?LinkID=164487.

Causa

Este problema puede producirse si el entorno tiene un espacio de nombres separado (es decir, el dominio tiene nombres NetBIOS y DNS diferentes). Por ejemplo, suponga que el dominio tiene un nombre NetBIOS de contoso.com y un nombre DNS de contoso-old.com. Cuando se agregan usuarios en la interfaz de usuario de Windows, se muestran en el formato contoso\ComputerName. Sin embargo, observa en el registro de errores que se ha intentado agregar una cuenta de equipo con el formato contoso-old\ComputerName.

Solución alternativa: Actualización

  1. Cree una nueva cuenta de usuario de dominio denominada MICROSOFT$DPM$Acct. Si no puede crear una nueva cuenta de dominio, puede usar una cuenta de usuario estándar.

  2. Busque los archivos de base de datos DPMDB y asegúrese de que la nueva cuenta que identificó o creó en el paso 1 tiene permisos completos para ese directorio.

  3. Cambie los servicios de versión> MSSQL$MSDPM< y SQLAgent$MSDPM<> para que, cuando empiecen, usen la nueva cuenta de usuario de dominio del paso 1.

Nota:

Se recomienda usar Microsoft Administrador de configuración de SQL Server, ya que proporciona la manera más sencilla de realizar este cambio.

La instalación de actualización debería finalizar correctamente.

Una vez completada la actualización, revierta los dos servicios que se mencionan en el paso 3 para que empiecen a usar la designación de cuenta local (MICROSOFT$DPM$Acct).

Solución alternativa: Instalación nueva

  1. Cree una nueva cuenta de usuario de dominio denominada MICROSOFT$DPM$Acct.

  2. Cree una nueva cuenta de usuario local en el servidor DPM que tenga el mismo nombre MICROSOFT$DPM$Acct. Las contraseñas no tienen que coincidir entre cuentas.

  3. Cambie los servicios de versión> MSSQL$MSDPM< y SQLAgent$MSDPM<> para que, cuando empiecen, usen la nueva cuenta de usuario de dominio del paso 1.

La instalación debería completarse correctamente. Para una instalación nueva, no es necesario revertir los dos servicios, como se mencionó en la sección Actualización , ya que el registro ya tendrá la información correcta para los servicios.

Comprobación de la funcionalidad después de una actualización

Nota:

Siga estos pasos solo si ha realizado una actualización. La instalación nueva no requiere esto.

Para asegurarse de que los trabajos continúan ejecutándose según lo programado, siga estos pasos en el servidor DPM:

  1. Abra el Editor del Registro y busque la siguiente subclave del Registro:

    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Setup

  2. Asegúrese de que los valores siguientes reflejan la %MachineName%\Microosft$DPM$Acct cuenta local:

    • SqlAgentAccountName
    • SchedulerJobOwnerName

    Nota:

    Esta cuenta también debe tener permisos completos para la carpeta DPM\Bin en el servidor DPM y en el servidor que ejecuta Microsoft SQL Server, si SQL Server se hospeda de forma remota.

  3. Inicie DCOMCNFG.exey, a continuación, busque la carpeta siguiente:

    Component Services\Computers\My Computer\DCOM Config\Microsoft System Center Data Protection Manager <version> Service

  4. Haga clic con el botón derecho en el nombre del servicio y, a continuación, seleccione Propiedades.

  5. Seleccione la ficha Seguridad.

  6. En el área Permisos de inicio y activación , seleccione Editar y, a continuación, compruebe que la cuenta existe y tiene todos los permisos asignados.

  7. Inicie SQL Server Management Studio para la instancia de DPM y compruebe que la cuenta tiene el rol Sysadmin.

Pasos adicionales si se produce un error en la instalación de actualización

Si se produce un error en la instalación de la actualización y el programa no se revierte, debe restaurar una versión funcional de DPM para poder intentar instalar la actualización de nuevo. Para ello, siga estos pasos:

  1. Busque la copia de seguridad del archivo DPMDB que creó antes de iniciar el proceso de actualización.

  2. Si DPM está instalado, desinstálelo.

    Importante

    Asegúrese de mantener los datos. Para ello, seleccione Conservar puntos de recuperación basados en disco en la página Opciones de desinstalación .

  3. Instale DPM. Si tenía instaladas actualizaciones, reinstálelas en la misma secuencia que las había instalado anteriormente.

    Nota:

    Se recomienda montar la base de datos desde el paso 1 y, a continuación, ejecutar la siguiente consulta en la base de datos DPM en modo de administrador para buscar la secuencia en la que se aplicaron originalmente las actualizaciones:

    Select distinct MajorVersionNumber,MinorVersionNumber ,BuildNumber, FileName FROM [DPMDB].[dbo].[tbl_AM_AgentPatch] where MajorVersionNumber = 4 and MinorVersionNumber =1 order by BuildNumber desc
    
  4. Para restaurar la copia de seguridad de la base de datos, ejecute el siguiente comando en un símbolo del sistema con privilegios elevados:

    dpmsync -restoredb (with appropriate switches)
    
  5. Para sincronizar las bases de datos, ejecute el siguiente comando en el Shell de administración de DPM:

    dpmsync -sync
    
  6. Inicie la consola del administrador DPM y, a continuación, asegúrese de que todos los agentes tengan el mismo número de versión que el servidor DPM.

Después de seguir estos pasos, el estado de la instalación de DPM debe restaurarse a su estado original. Ahora, inténtelo de nuevo para realizar los pasos de solución alternativa y la instalación de la actualización.