現象
StorSimple ボリュームを ESX Server に接続しようとするときは、たまにしか接続の問題があります。この問題は、IP アドレスを使用して、ESX Server のアクセス ・ コントロール ・ レコード (ACRs) が構成されている場合に発生します。
この資料では、この問題とそれを防ぐためにベスト ・ プラクティスの詳細について説明します。StorSimple v1.2.1、v2.0.1、v2.1.1 をこの資料が適用されます。
原因
ESX サーバーの IP アドレスを使用して、ACR が構成されると、IP アドレスに一致する前に実行 StorSimple ボリュームへのアクセスが有効になっています。これは、特定の IP アドレスに一致する接続のみがボリュームにアクセスできることを意味します。問題のサーバーには複数の IP アドレスが、ネットワークへのすべてのパスが含まれているため、償却が構成されている、ユーザーは接続の問題を発生することがあります。
たとえば、ホスト サーバーが 2 つの IP アドレスを持っている 10.2.43.60 (iSCSI) と 10.2.43.61 (管理)。これらは、それぞれの StorSimple ボリュームへの接続に使用できます。ユーザー、ACR を作成し、これらの IP アドレスのいずれかにのみ関連付けられます-たとえば、10.2.43.60 です。このシナリオでは (10.2.43.61) のネットワーク パスの ACR が定義されていません。サーバーに複数のネットワーク パスがある場合は、それらすべてのパスを含むように、償却を構成しなければなりません。
ユーザーにこの構成がある場合は、彼または彼女は、接続の問題が発生する可能性があります。たとえば、iSCSI IP を使用するユーザーのイニシエーターの接続が停止するのアドレスし、イニシエーターは接続 (仮想マシンのカーネルを有効になっている) で、管理用 IP アドレスを使用して、もう一度、ユーザーはこの時間に接続できます。ただし、StorSimple のボリュームは表示されません。したがって、ボリュームは表示されません。
解決策
この問題を解決するには、修飾名 (IQN) と一致する IP アドレスの代わりに iSCSI を使用する ACR を構成します。これは、ため、VM カーネルの任意のポートから送信される接続は、ボリュームへのアクセスがあることを確認します。
この解決方法には、2 段階の処理が必要です。
IQN ESX サーバ上の手順 1: 検索
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StorSimple ボリュームに格納されているすべての実行中の Vm をシャット ダウンします。
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ESX サーバの iSCSI イニシエーターの IQN を抽出するように ESX サーバーにアクセスします。これを行うには、以下の手順を実行します。
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VSphere にログオンします。
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[ホーム] をクリックして、在庫、ホストおよびクラスター] をクリックします。
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ナビゲーション ・ ペインでは、ESX server を選択します。詳細ペインで、[構成] タブをクリックします。
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ストレージ アダプターを選択します。
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デバイスのiSCSI アダプターのソフトウェアで、[ vmhba #] をクリックします。詳細ウィンドウで、[プロパティ] をクリックします。
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[プロパティ] ウィンドウで、表示される IQN を選択し、コピーします。
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すべての ESX サーバで手順 2 を繰り返します。
Web ユーザー インターフェイス (UI) を構成する必要があります。これを行うには、StorSimple アプライアンスの Web UI にアクセス コントロールのレコードの下、IQN を適用する必要があります。
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StorSimple Web UI にログオンします。
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[構成] をクリックして、セキュリティ設定アクセス ・ コントロール ・ レコードをクリックします。
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ステップ 2 に記載されている ESX server に対して指定されているアクセス コントロールのレコードの"ステップ 1: ESX サーバ上の IQN を検索」セクションで、編集アイコンをクリックします。
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IP アドレス] ボックスで、asterick (*) を含む IP アドレスを削除して貼り付けて、 IQNボックスの IQN の手順 2 f でコピーした、"ステップ 1: ESX サーバ上の IQN を検索」セクション。
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アクセス ・ コントロール ・ レコードを保存するのには緑色のチェック マークをクリックします。
すべての ESX サーバで次の手順を繰り返します。