Síntomas
Imagine el siguiente escenario:
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Habilitar la cookie compartir entre miembros de la matriz en Microsoft Forefront Threat Management Gateway (TMG) 2010.
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Publicar sitios Web a través de Forefront TMG 2010.
En el escenario, los clientes existentes que ya tienen una cookie de autenticación no podrán tener acceso a recursos publicados y pueden recibir el siguiente mensaje de error:
1413 índice no válido.
Nota: Este problema afecta principalmente a los usuarios de Exchange ActiveSync en su dispositivo móvil mantiene la cookie antiguo hasta que el dispositivo se reinicia o se desactiva el servidor.
Causa
Cookie a través de los miembros de la matriz utiliza un nuevo formato de cookie y la cookie de autenticación proporcionado por los clientes existentes no se eliminan correctamente después de que está habilitada la característica de uso compartido de cookie.
Solución
Para resolver este problema, instale el paquete acumulativo de actualizaciones 5 para Forefront Threat Management Gateway (TMG) 2010 Service Pack 2.
Solución alternativa
Para evitar este problema, cambie el nombre de la cookie que se define en la escucha de web. Para ello, siga estos pasos:
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Abra la consola de administración de Forefront TMG y, a continuación, haga clic en Directiva de Firewall.
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En la ficha cuadro de herramientas en el panel de la derecha, expanda Objetos de red.
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Expanda Escuchas de Web, haga clic en el agente de escucha que se utilizó para publicar los sitios Web de problema y, a continuación, haga clic en Propiedades.
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En la ficha formularios , haga clic en Avanzadas.
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En el campo Nombre de la Cookie , escriba un nombre de cookie diferente como cadata2.
Nota: De forma predeterminada, este campo está en blanco, y el nombre de cookie predeterminado que se utiliza es cadata. -
Haga clic en Aceptary, a continuación, haga clic en Aceptar para salir de los cuadros de diálogo.
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Haga clic en Aplicar para guardar los cambios.
Espere a que los cambios se sincronizan con el servicio de Firewall de Forefront TMG. Para ello, haga clic en supervisióny, a continuación, haga clic en configuración. Los clientes deben ser capaces de tener acceso a los sitios publicados cuando todos los servidores muestran un estado de sincronizadas.
O bien, solicite los clientes para reiniciar su dispositivo móvil o cierre todas las instancias de sus exploradores. Esto borra la cookie de la antigua.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Referencias
Obtenga información acerca de la terminología que utiliza Microsoft para describir las actualizaciones de software.