O primeiro logon falha com o erro: não há suporte para o tipo UUID (identificador exclusivo universal)

Este artigo descreve uma situação em que um usuário recebe uma mensagem de erro UUID no primeiro logon de uma imagem Windows 8 ou Windows 8.1. Esse problema ocorre quando a imagem foi implantada usando o System Center 2012 Configuration Manager ou System Center 2012 R2 Configuration Manager.

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Sintomas

Suponha que você use o System Center 2012 Configuration Manager ou System Center 2012 R2 Configuration Manager para implantar uma imagem Windows 8 ou Windows 8.1. Quando um usuário inicia o sistema que tem a imagem (física ou virtual) e tenta entrar pela primeira vez, ele recebe a seguinte mensagem de erro:

O serviço cliente Política de Grupo falhou na entrada.
Não há suporte para o tipo UUID (identificador exclusivo universal).

Não há suporte para captura de tela do tipo UUID na tela de logon.

Essa mensagem de erro é exibida no primeiro logon do usuário após a implantação inicial da imagem. No entanto, em alguns cenários, logons de usuário posteriores também resultam na mensagem de erro.

Depois que a mensagem é exibida e o usuário seleciona OK, a tela de logon é exibida novamente.

Motivo

O Winlogon se comunica com o GPSVC (serviço de Política de Grupo) por meio de uma chamada RPC sobre a inicialização do sistema para política de computador. E ele se comunica com o logon do usuário para a política de usuário. O System Center Configuration Manager instala um CSE (Extensão de Client-Side) na imagem do Windows, que é detectada pelo serviço Política de Grupo na primeira inicialização. Em seguida, o serviço de política de grupo se isola em um processo SVCHOST separado. O serviço estava sendo executado originalmente em um processo compartilhado com outros serviços. Como as comunicações RPC já foram estabelecidas antes do isolamento do serviço, Winlogon não é mais possível entrar em contato com o serviço Política de Grupo. Essa situação resulta na mensagem de erro descrita na seção Sintomas.

Em reinicializações posteriores, o GPSVC está aparecendo em um processo separado desde o início da sessão do sistema operacional. Portanto, o runtime do RPC não tem problemas em encontrar a instância correta do processo do servidor.

Resolução

Importante

Siga as etapas nesta seção com cuidado. Sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Antes de modificá-lo, faça backup do Registro para restauração em caso de problemas.

As soluções alternativas a seguir podem ser usadas para evitar a mensagem de erro. Ambas as soluções alternativas envolvem modificar o build-in de imagem do System Center Configuration Manager em vez de implementá-las na imagem já implantada.

Solução alternativa 1

Adicione uma reinicialização ao final da lista de sequências de tarefas para o build de imagem. Modifique o System Center Configuration Manager sequência de tarefas para a imagem usando SMSTSPostAction shutdown /r /t 0 como a última tarefa antes de concluir o build.

Solução alternativa 2

Separe o serviço Política de Grupo em uma instância SVCHOST separada. Implemente o seguinte comando na sequência de tarefas do System Center Configuration Manager para definir a entrada correspondente do registro:

cmd /c reg add "HKLM\SYSTEM\CurrentControlSet\Services\gpsvc" /v Type /t REG_DWORD /d 0x10 /f

Por padrão, o GPSVC se isola ao detectar um CSE. Essa solução alternativa forçará o GPSVC a iniciar sempre em uma instância isolada do SVCHOST, incluindo a primeira inicialização. Ele impede o registro das comunicações RPC em diferentes processos SVCHOST e permite Winlogon que ele se conecte com êxito ao processo correto.