L'Aggiunta guidata oggetto in Operations Manager visualizza solo 500 oggetti, anche se sono presenti più di 500 oggetti

Questo articolo consente di risolvere un problema che impedisce la visualizzazione di più di 500 oggetti in Microsoft System Center Operations Manager, anche quando sono presenti più di 500 oggetti.

Versione originale del prodotto: System Center 2016 Operations Manager, System Center 2012 R2 Operations Manager, Microsoft System Center 2012 Operations Manager
Numero KB originale: 2976809

Sintomi

Quando si usa il pulsante Aggiungi gruppi o Aggiungi oggetto durante la creazione di un report in System Center Operations Manager, non vengono visualizzati più di 500 oggetti nell'Aggiunta guidata oggetto anche se ne esistono più di 500.

Causa

Questo limite predefinito di 500 oggetti è in base alla progettazione e questa impostazione viene controllata tramite il Registro di sistema.

Soluzione alternativa

Per risolvere questo problema, creare una chiave del Registro di sistema per impostare manualmente il limite massimo di oggetti nell'Aggiunta guidata oggetto.

A tal fine, attenersi alla seguente procedura:

  1. Nel computer che ospita la console di Operations Manager chiudere tutte le istanze in esecuzione della console.

  2. Avviare l'editor del Registro di sistema Assicurarsi di usare lo stesso account utente usato per eseguire la console.

  3. Individuare e selezionare la sottochiave seguente del Registro di sistema:

    HKEY_CURRENT_USER\Software\Microsoft\Microsoft Operations Manager\3.0\Console

  4. Creare una nuova chiave di valore DWORD e salvarla come MaximumSearchItemLimit. Assegnare un valore a questa chiave che riflette il numero massimo di oggetti da visualizzare. Ad esempio, usare un valore pari a 1000 se si vuole limitare il numero massimo di oggetti a 1000 anziché al limite predefinito di 500.

    • Posizione: HKEY_CURRENT_USER\Software\Microsoft\Microsoft Operations Manager\3.0\Console
    • Nome: MaximumSearchItemLimit
    • Tipo: REG_DWORD
    • Valore: da 0 a 65535
  5. Uscire dall'editor del Registro di sistema.

Per verificare la nuova impostazione, avviare la console di Operations Manager e quindi aprire un report che usa il pulsante Aggiungi gruppo o Aggiungi oggetto . Selezionare il pulsante Cerca nella finestra di dialogo Aggiungi oggetto e quindi verificare che il numero massimo di elementi disponibili visualizzati corrisponda al MaximumSearchItemLimit valore.

Nota

Assicurarsi di ripetere i passaggi da 1 a 5 in tutti i computer che ospitano la console di Operations Manager.