Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Assume that you deploy Microsoft Lync servers as fully on-premises without any lyncdiscover DNS records, and that you have Azure Active Directory (AAD) federations set. After you install the December 8, 2015 update for Microsoft Lync 2013 (Microsoft Skype for Business), you discover that you can't sign in to the client by using the domain\username format. In this situation, you receive the following error message:

Error:

The address type is not valid

Valid address use the format username@domain(someone@example.com). Make sure there are no spaces in the address.

Click Back to retype the address.

Cause

This issue occurs because if Lync 2013 (Skype for Business) client fails to detect lyncdiscover and lyncdiscoverinternal services. In this case, the new DNS-less discovery (also known as Cloud-based discovery) redirects you to the Microsoft Lync Online Discovery services in Office 365. Then, you're forced-authenticated through the UPN format when you sign in to Lync 2013 (Skype for Business).

Resolution

To fix this issue, install the January 12, 2016, update for Lync 2013 (Skype for Business).

Note Lync 2013 was upgraded to Skype for Business in April 2015.

More Information

For more information about the latest DNS-less (also known as cloud-based) discovery logic, see Cloud Based Discovery, UPN Enforcement for OrgID, and SIP Autodetection from Azure for Skype for Business Client.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×