O Microsoft Office deixa de responder quando tenta abrir ou guardar um ficheiro

Sintomas

Se efetuar um dos seguintes procedimentos num dos programas do Microsoft Office listados no final deste artigo, o programa poderá deixar de responder (bloquear) durante muito tempo:

  • Clique na lista Guardar em na caixa de diálogo Guardar Como .
  • Clique na lista Procurar em na caixa de diálogo Abrir .

Se clicar em Cancelar ou tentar fechar a caixa de diálogo, o programa continua a não responder.

Causa

Este problema pode ocorrer se uma das seguintes condições for verdadeira:

  • Quando o computador está ligado a uma ou mais partilhas de rede mapeadas que não existem ou que estão atualmente offline.
  • Quando uma ou mais unidades mapeadas são persistentes e a unidade está num domínio que não é fidedigno.
  • Quando a unidade mapeada está localizada num computador lento ou de nível inferior. Um computador de nível inferior é quando o sistema operativo do computador tem uma versão anterior do Microsoft Windows do que o computador que está a utilizar).
  • Quando uma unidade mapeada é ligada através de uma Rede Alargada (WAN).
  • Quando uma unidade é uma unidade amovível inacessível.

Resolução

Para resolver este problema, tem de desligar todas as unidades de rede que tenham qualquer uma das condições indicadas na secção "Causa". Para tal, siga estes passos.

Nota Uma vez que existem várias versões do Microsoft Windows, os passos seguintes podem ser diferentes no seu computador. Se estiverem, veja a documentação do produto para concluir estes passos.

  1. Clique com o botão direito do rato em O Meu Computador e, em seguida, clique em Desligar Unidade de Rede.
  2. Na caixa de diálogo Desligar Unidade de Rede , clique na letra da unidade que pretende desligar e, em seguida, clique em OK.
  3. Repita os passos 1 e 2 até todas as unidades de rede offline estarem desligadas. Se não tiver a certeza sobre uma determinada unidade, siga estes passos:
    1. Clique em Iniciar e, em seguida, clique em Executar.

    2. Na caixa Abrir, escreva o seguinte e, em seguida, prima ENTER\nome do computador\nome da partilha

      Em que nome do computador é o nome do servidor que está a partilhar o recurso e o nome da partilha é o nome do recurso partilhado que pretende utilizar.

      Se o recurso não estiver disponível, receberá uma mensagem de erro semelhante à seguinte:

      Não é possível localizar o nome da rede.

Em alternativa, pode tentar ver os conteúdos da unidade no Explorador do Windows.

Solução

Para contornar este comportamento, utilize um dos seguintes métodos.

Método 1: não utilizar ligações persistentes

Quando ligar uma unidade mapeada, clique para desmarcar a caixa de verificação Restabelecer ligação ao iniciar sessão. Ao desmarcar esta caixa de verificação, a unidade mapeada não será ligada da próxima vez que iniciar sessão no computador. Consulte a secção "Mais Informações" para obter mais informações sobre como mapear uma unidade de rede.

Método 2: Utilizar um script de início de sessão do utilizador

Se puder, utilize um script de início de sessão para ligar um utilizador aos servidores adequados sempre que o utilizador iniciar sessão. Certifique-se de que o script mapeia a unidade num estado não persistente. Se a unidade não estiver disponível à medida que o script de início de sessão é executado, a unidade não é mapeada. Este comportamento impede o problema.

Método 3: Utilizar o espelhamento do servidor

Se a ligação estiver numa Rede Alargada (WAN), considere implementar o espelhamento do servidor. O espelhamento do servidor duplica localmente um servidor distante. Em seguida, mapeie a unidade para o servidor local duplicado. Ao fazê-lo, pode reduzir o tempo de espera ao ligar a um servidor local.

Método 4: Utilizar um atalho para a localização de rede

Utilize um atalho no ambiente de trabalho do Microsoft Windows ou em A Minha Rede Places para ligar à localização de rede pretendida.

Mais Informações

Cada localização numa lista é verificada para se certificar de que está disponível e de que tem permissões de acesso quando efetua ambos os procedimentos seguintes nos programas do Microsoft Office:

  • Tenta abrir ou guardar um ficheiro.
  • Pode aceder à lista Procurar em ou Guardar Em .

Se alguma unidade mapeada estiver num estado documentado na secção "Causa", a condição demora algum tempo a ser detetada e resolvida pelo programa do Office. Para evitar este comportamento, deve desligar essa unidade mapeada. Pode procurar a disponibilidade da unidade em qualquer altura no Explorador do Windows. Se a unidade estiver disponível, mapeie a unidade de rede novamente mais tarde.

Para mapear uma unidade para um recurso online novamente, siga estes passos:

  1. Clique com o botão direito do rato em O Meu Computador e, em seguida, clique em Mapear Unidade de Rede.

  2. Na caixa Unidade, clique na letra de unidade que pretende utilizar para a unidade de rede.

  3. Na caixa Pasta, escreva o seguinte \nome do computador\nome da partilha

    Em que nome do computador é o nome do servidor que está a partilhar o recurso e o nome da partilha é o nome do recurso partilhado que pretende utilizar.

  4. Para tornar a unidade mapeada não persistente, clique para desmarcar a caixa de verificação Restabelecer ligação ao iniciar sessão .

  5. Clique em Concluir.

Se estiver a tentar ligar-se a recursos noutras redes, contacte o administrador de rede. As unidades de rede que já não existem, que já não são partilhadas ou unidades amovíveis inacessíveis devem ser desligadas permanentemente para evitar afetar o desempenho dos produtos do Office.