El equipo no se inicia después de cambiar la partición activa mediante la herramienta Administración de discos

En este artículo se proporciona una solución a un problema en el que el equipo no se inicia después de marcar la partición principal como activa.

Se aplica a: Windows Server 2012 R2
Número de KB original: 315261

Síntomas

Después de usar la herramienta de complemento Administración de discos de Windows para marcar la partición principal como activa, es posible que el equipo no se inicie y que reciba el siguiente mensaje de error:

Falta NTLDR.

Presione Ctrl+Alt+Supr para reiniciar.

Causa

Este comportamiento se produce si la partición marcada como activa no contiene los archivos de arranque de Windows ni los archivos de arranque de otro sistema operativo. En los equipos basados en Intel, la partición del sistema debe ser una partición principal que se haya marcado como activa con fines de inicio. Esta partición debe encontrarse en el disco al que el equipo obtiene acceso durante el inicio. Solo puede haber una partición del sistema activa a la vez. Si desea usar otro sistema operativo, primero debe marcar su partición del sistema como activa antes de reiniciar el equipo.

Solución

Importante

Antes de realizar los pasos que se enumeran a continuación, asegúrese de que tiene una buena copia de seguridad de los archivos de datos críticos.

Para resolver este comportamiento, use uno de los procedimientos siguientes:

  • Pruebe a cambiar la partición activa iniciando en un disquete y, a continuación, usando utilidades de disco para cambiar manualmente la partición activa:

    1. Arranque en un símbolo del sistema mediante un disco de arranque de Microsoft Windows 95, Microsoft Windows 98 o Microsoft Windows Millennium Edition (Me).
    2. En el símbolo del sistema, escriba fdisk y presione ENTRAR.
    3. Cuando se le pida que habilite la compatibilidad con discos grandes, haga clic en .
    4. Haga clic en Establecer partición activa, presione el número de la partición que desea activar y, a continuación, presione ENTRAR.
    5. Presione ESC.
    6. Quite el disco de arranque y reinicie el equipo.
  • Arranque el equipo mediante un disco de arranque de Windows XP. Para obtener más información, consulte Creación de un disco de reparación del sistema.

  • Si la partición que se ha marcado incorrectamente como activa tiene formato en el sistema de archivos FAT, el sistema de archivos FAT32 o el sistema de archivos NTFS, es posible que pueda usar la consola de recuperación de Windows para corregir el comportamiento.

Para obtener más información, vea ¿Cuáles son las opciones de recuperación del sistema en Windows?.

Nota:

La partición del sistema hace referencia al volumen de disco que contiene los archivos necesarios para iniciar Windows (por ejemplo, Ntldr, Boot.ini y Ntdetect.com). En equipos basados en Intel x86, la partición del sistema debe ser una partición principal marcada como activa. En los equipos Intel x86, siempre se trata de la unidad 0, la unidad que busca el BIOS del sistema cuando se inicia el sistema operativo.

Con la consola de recuperación, copie el archivo Ntldr del CD-ROM de Windows XP en el directorio raíz de la partición activa actual. Siga estos pasos:

  1. Inicie el equipo con los disquetes de instalación de Windows XP o con el CD-ROM de Windows XP.

  2. En la pantalla Bienvenido a la configuración , presione F10 o presione R para reparar.

  3. Presione C para iniciar la consola de recuperación.

  4. Copie el archivo Ntldr del CD-ROM de Windows XP en la raíz de la partición del sistema mediante los siguientes comandos y presione ENTRAR después de cada comando:

  5. Escriba cd .. para ir a la raíz de la unidad C.

    Hay un espacio entre d y los dos puntos (..).

  6. Escriba la letra de la unidad de CD-ROM.

  7. Tipo cd i386.

  8. Tipo Copy ntldr c:.

  9. Tipo Copy ntdetect.com c:.

  10. Tipo Bootcfg /add.

  11. Tipo Exit.

Si la partición no se ha formateado mediante Windows, es posible que también tenga que ejecutar el comando fixboot de la consola de recuperación para que la partición activa se pueda arrancar.

Después de arrancar en Windows, se recomienda usar la herramienta de complemento Administración de discos de Windows para restablecer la partición del sistema original como partición activa y, a continuación, reiniciar el equipo.