Voice mail settings are missing from the Options pane in Outlook on the web in Microsoft 365
Original KB number: 3216404
Important
The Unified Messaging service in Exchange Online is out of support as of February 28, 2020, 5 PM Pacific Time. All voicemail accounts have been migrated to Cloud Voicemail service by Microsoft. Any remaining auto attendant traffic won't be monitored and might be disrupted at any time. For more information, see Exchange Unified Messaging Online migration support.
Symptoms
Assume that you assigned a Microsoft 365 plan that includes Unified Messaging (UM) to a user. However, when the user opens the Options pane in Outlook on the web, the Voice mail settings are missing.
Cause
This issue may occur if UM isn't enabled in the mailbox policy that's assigned to the mailbox or the MyTextMessaging and MyVoiceMail settings aren't enabled for the user role that's assigned to the mailbox.
Resolution
To resolve this issue, follow these steps:
Make sure that UM is enabled in the mailbox policy that's assigned to the mailbox. To do this, follow these steps:
Connect to Exchange Online by using the remote PowerShell. For more information, see Connect to Exchange Online PowerShell.
Run the following command to identify the mailbox policy that's assigned to the mailbox:
Get-CASmailbox <mailboxUPN> | FL *OWAMailboxPolicy
Open the Exchange admin center, select permissions, and then select Outlook Web App policies.
Select the mailbox policy that you determined in step 1B, and then select Edit.
Select features, select the Unified Messaging check box, and then select Save.
Make sure that the MyTextMessaging and MyVoiceMail settings are enabled for the user role that's assigned to the mailbox. To do this, follow these steps:
Connect to Exchange Online by using the remote PowerShell. For more information, see Connect to Exchange Online PowerShell.
Run the following command to identify the role assignment policy that's assigned to the mailbox:
Get-mailbox <mailboxUPN> | FL *RoleAssignmentPolicy
Open the Exchange admin center, select permissions, and then select user roles.
Select the role assignment policy that you determined in step 2B, and then select Edit.
Select the MyTextMessaging and MyVoiceMail check boxes, and then select Save.
More information
If you're using the Skype for Business voice mail service with cloud PSTN, the voice mail options are not available. For more information, see Set up your voice mail.
Still need help? Go to Microsoft Community.
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