Při pokusu o otevření dokumentu Office se zobrazí chybová zpráva
Příznaky
Při pokusu o otevření souboru v libovolné aplikaci Microsoft Office, která je uvedena v části "Platí pro", zobrazí se jedna z následujících chybových zpráv:
Název souboru není platný.
K souboru se nepodařilo získat přístup.
Zadaná cesta , názevsouboru, je příliš dlouhá. Zadejte kratší cestu.
název souboru nebyl nalezen. Zkontrolujte pravopis názvu souboru a ověřte, zda je umístění souboru správné.
Došlo k chybě DDE a popis chyby nelze zobrazit, protože je příliš dlouhý. Pokud je název souboru nebo cesta dlouhá, zkuste soubor přejmenovat nebo zkopírovat do jiné složky.
Poznámka
K tomuto problému dochází při otevření souboru z namapované jednotky, cesty UNC nebo adresy URL (webové adresy).
Příčina
K tomuto problému dochází kvůli omezení počtu znaků při vytváření a ukládání souborů v produktech Office. K tomuto problému dochází, pokud cesta k souboru, který otevřete nebo uložíte, splňuje následující podmínku:
Microsoft Word, Microsoft PowerPoint a Microsoft Access: Celková délka cesty a názvu souboru, včetně přípony názvu souboru, přesahuje 259 znaků.
Microsoft Excel: Celková délka cesty a názvu souboru, včetně přípony názvu souboru, přesahuje 218 znaků.
Poznámka
Tento limit zahrnuje tři znaky, které představují jednotku, znaky v názvech složek, znaky zpětného lomítka mezi názvy složek a znaky v samotném názvu souboru.
Řešení
K vyřešení tohoto problému použijte některý z následujících postupů:
Řešení 1: Snížení počtu znaků
- Přejmenujte soubor tak, aby měl kratší název.
- Přejmenujte jednu nebo více složek, které soubor obsahují, aby měly kratší názvy.
- Přesuňte soubor do složky s kratším názvem cesty.
Řešení 2: Ruční přístup, otevření a oprava
Spusťte Word, Excel nebo PowerPoint.
Na kartě Soubor vyberte možnost Otevřít>Procházet a vyhledejte poškozený soubor.
Vyberte soubor, vyberte nabídku Otevřít ve spodní části okna a poté vyberte možnost Otevřít a opravit.
Tato možnost opraví poškození souboru a pak soubor otevře. Po opravě dokumentu, sešitu nebo prezentace je důležité ověřit, že se problém úspěšně vyřešil. Chcete-li to provést, začněte pracovat na souboru a ujistěte se, že vše funguje podle očekávání.
Řešení 3: Změna formátu souboru a opětovného uložení
Poškozený soubor můžete zachránit tak, že jej znovu uložíte do jiného formátu souboru a poté jej vrátíte do původního formátu. Tento příklad používá aplikaci Word.
Krok 1: Uložení souboru do jiného formátu
Spusťte aplikaci Word.
V nabídce Soubor vyberte Otevřít a poté vyhledejte a otevřete poškozený soubor.
V nabídce Soubor vyberte možnost Uložit jako>Procházet.
Přejděte do umístění souboru, do kterého chcete soubor uložit.
V seznamu Uložit jako typ vyberte požadovaný formát souboru. Vyberte například Formát RTF (*rtf).
Vyberte Uložit a poté vyberte Soubor>Zavřít.
Krok 2: Opětovné uložení souboru jako dokumentu aplikace Word
Vyberte Soubor>Otevřít.
Vyberte nový soubor, který se uloží jako soubor RTF, a pak vyberte Otevřít.
Vyberte Soubor>Uložit jako.
V seznamu typů Uložit jako vyberte Dokument aplikace Word.
Přejmenujte soubor a poté vyberte Uložit.
Musíte to udělat jenom jednou, abyste se ujistili, že dokument bude nyní na vašem zařízení správně fungovat. Mějte však na paměti, že uložením souboru jako nového dokumentu vytvoříte jiný soubor. Pokud se chcete vyhnout nejasnostem, pojmenujte nový soubor jinak a archivujte nebo odstraňte poškozenou verzi. Tímto způsobem nechtěně znovu neotevřete původní soubor, který nebyl přeformátován.
Řešení 4: Otevření nerozpoznaného formátu souboru
Pokud jako důvod můžete vyloučit poškození souboru, zkontrolujte přidružení typu souboru a nerozpoznané formáty souborů. Někdy se soubor na vašem zařízení neotevře, protože zařízení, na které byl soubor vytvořen, používalo software, který vaše zařízení nemá.
Například v Word chcete zobrazit soubor PDF, který je připojený k e-mailové zprávě. Nemáte ale nainstalovaný prohlížeč PDF. Proto vaše zařízení neví, jaký program má otevřít, aby se soubor zobrazil. V takovém případě můžete změnit formát souboru tak, aby odpovídal programu, který máte nainstalovaný.
Uložte přílohu do počítače. Chcete-li to provést, vyberte šipku dolů vedle přílohy ve zprávě, vyberte možnost Uložit jako, přejděte na požadované místo a poté vyberte možnost Uložit.
V nabídce Soubor vyberte možnost Otevřít>Procházet a vyhledejte soubor.
Klikněte pravým tlačítkem myši na soubor, přejděte na Otevřít v programu a poté vyberte jiný program pro otevření souboru.
Pokud požadovaný program není v seznamu, vyberte Zvolit jinou aplikaci a vyhledejte jiný program.
Poznámka
Pokud to funguje a chcete, aby vybraný program vždy otevíral tento typ souboru, zaškrtněte políčko (například) Vždy používat tuto aplikaci k otevírání souborů .docx.
Další informace o formátech souborů a jejich správě naleznete v části Další informace o formátech souborů.
Řešení 5: Uvolnění místa na disku
Pokud vám na pevném disku dochází místo, nemusí být možné otevřít nový soubor nebo uložit soubor do zařízení. Na plném disku velkou část místa zabírají dočasné, duplicitní a nepotřebné položky. Nejrychlejší a nejjednodušší způsob, jak uvolnit místo na pevném disku, je použít aplikaci Vyčištění disku, která je součástí Windows.
Vyberte Hledat a zadejte Vyčištění disku.
V seznamu výsledků vyberte Vyčištění disku.
Otevře se dialogové okno s možnostmi odstranění nepotřebných souborů. Zaškrtněte políčko vedle každé kategorie položek, které chcete ze zařízení odstranit, a poté vyberte OK. Všechno v tomto seznamu je možné bezpečně odstranit.
Po zobrazení výzvy potvrďte, že chcete nepotřebné soubory trvale odstranit.
Následující typy souborů jsou příklady vyměnitelných položek, které se můžou zobrazit v seznamu Vyčištění disku:
- Windows Update: Nedávné soubory, které byly staženy ze služby Windows Update (výběrem těchto neodeberete aktuálně nainstalované verze aktualizací)
- Stažené programové soubory: Nepotřebné programové soubory, často související s instalací programu
- Dočasné internetové soubory: Soubory automaticky ukládané webovými prohlížeči při návštěvě webových stránek
- Hlášení chyb systému Windows: Soubory hlášení chyb vytvořené systémem
- Koš: Všechny soubory uložené v koši, které jste ručně neodstranili
- Dočasné soubory: Jiné dočasné soubory vytvořené programy nebo webovými prohlížeči
- Historie uživatelských souborů: Soubory, které zaznamenávají vaši historii procházení (webové stránky, které jste navštívili, výsledky vyhledávání atd.)
Další informace
Stále potřebujete pomoc? Přejděte na web Microsoft Community.
Váš názor
https://aka.ms/ContentUserFeedback.
Připravujeme: V průběhu roku 2024 budeme postupně vyřazovat problémy z GitHub coby mechanismus zpětné vazby pro obsah a nahrazovat ho novým systémem zpětné vazby. Další informace naleznete v tématu:Odeslat a zobrazit názory pro