Message d’erreur « Code d’erreur spécifique au service -2147944102 » si vous essayez de démarrer le service BITS

Cet article fournit une solution à une erreur 2147944102 qui se produit lorsque vous démarrez le service BITS (Intelligent Transfer Service) en arrière-plan.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 326460

Symptômes

Si vous essayez de démarrer le service BITS sur un ordinateur Windows 2000 sur lequel les services Terminal Server sont installés, vous pouvez rencontrer les symptômes suivants :

  • Vous recevez l’un des messages d’erreur suivants :

    Windows n’a pas pu démarrer le service de transfert intelligent en arrière-plan sur l’ordinateur local. Pour plus d’informations, consultez le journal des événements système. S’il s’agit d’un service non-Microsoft, contactez le fournisseur du service et reportez-vous au code d’erreur spécifique au service 2147023194.

    - ou -

    Une erreur spécifique au service s’est produite : -2147944102.

  • L’événement suivant est enregistré dans le journal système de Windows NT observateur d'événements :

    Type d'événement : Erreur
    Source de l’événement : Gestionnaire de contrôle de service
    Catégorie d’événement : Aucun
    ID d’événement : 7024
    Utilisateur : N/A
    Description : le service de transfert intelligent en arrière-plan s’est arrêté avec une erreur spécifique au service 2147944102.

Cause

Ce comportement peut se produire si le service Des services Terminal Server est désactivé.

Par défaut, lorsque le composant Services Terminal Server est installé, le type de démarrage du service Services Terminal Server est défini sur Automatique. Si un administrateur remplace le type de démarrage du service par Désactivé, le service BITS ne démarre pas.

Résolution

Pour résoudre ce problème, obtenez le dernier Service Pack pour Microsoft Windows 2000.

Solution de contournement

Pour contourner ce problème, utilisez l’une des méthodes suivantes (en fonction de votre situation).

Méthode 1 : Configurer les services Terminal Server pour qu’ils démarrent automatiquement

Pour configurer le service Services Terminal Server pour qu’il démarre automatiquement, procédez comme suit :

  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Outils d’administration, puis double-cliquez sur Services.
  3. Dans le volet droit, cliquez avec le bouton droit sur Services Terminal Server, puis cliquez sur Propriétés.
  4. Cliquez sur l'onglet Général.
  5. Dans la zone Type de démarrage , cliquez sur Automatique, puis sur OK.

Méthode 2 : Supprimer les services Terminal Server

Si vous n’avez pas besoin des services Terminal Server ou s’ils ne sont pas utilisés sur le serveur, supprimez les services Terminal Server. Pour cela, procédez comme suit :

  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Ajout/Suppression de programmes.
  3. Cliquez sur Ajouter/Supprimer des composants Windows.
  4. Dans l’Assistant Composants Windows, désactivez la zone case activée Services Terminal Server, puis cliquez sur Suivant.
  5. Dans la page Fin de l’Assistant Composants Windows , cliquez sur Terminer.
  6. Dans la fenêtre Ajout/Suppression de programmes , cliquez sur Fermer.

Statut

Microsoft a confirmé qu’il s’agit d’un problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé pour la première fois dans Microsoft Windows 2000 Service Pack 4.

Plus d’informations

Le problème décrit dans la section « Symptômes » de cet article peut également se produire après l’installation de Microsoft Software Update Services (SUS) 1.0 ou du client Automatic Mises à jour 2.2 sur un ordinateur Windows 2000 Server sur lequel les services Terminal Server sont installés.