En raison d’une erreur de sécurité, le client n’a pas pu se connecter au serveur Terminal Server

Cet article fournit une solution à un problème où les clients des services Terminal Server se voient refuser à plusieurs reprises l’accès au serveur Terminal Server après la mise à niveau de Windows.

S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 329896

Symptômes

Après la mise à niveau d’un domaine Microsoft Windows NT vers Windows 2000 ou Windows Server 2003, les clients Des services Terminal Server Windows 2000 peuvent se voir refuser à plusieurs reprises l’accès au serveur Terminal Server. Si vous utilisez un client Des services Terminal Server pour vous connecter au serveur Terminal Server, vous pouvez recevoir l’un des messages d’erreur suivants :

Le client n’a pas pu se connecter à Terminal Server car une erreur de sécurité s’est produite. Après vous être assuré que vous êtes connecté au réseau, essayez de vous reconnecter au serveur.

ou

Bureau à distance déconnecté. Le client n’a pas pu se connecter à l’ordinateur distant car une erreur de sécurité s’est produite. Vérifiez que vous êtes connecté au réseau et essayez de vous reconnecter.

En outre, les messages d’ID d’événement suivants peuvent être enregistrés observateur d'événements sur le serveur Terminal Server :

ID d’événement : 50
Source de l’événement : TermDD
Description de l’événement : le composant de protocole RDP X.224 a détecté une erreur dans le flux de protocole et a déconnecté le client.

et

ID d'événement : 1008
Source de l’événement : TermService
Description de l’événement : La période de grâce des licences des services Terminal Server a expiré et le service n’a pas été inscrit auprès d’un serveur de licences. Un serveur de licences des services Terminal Server est requis pour le fonctionnement continu. Un serveur Terminal Server peut fonctionner sans serveur de licences pendant 90 jours après le démarrage initial.

et

ID d’événement : 1004
Source de l’événement : TermService
Description de l’événement : Le serveur Terminal Server ne peut pas émettre de licence cliente.

et

ID d'événement : 1010
Source de l’événement : TermService
Description de l’événement : Les services terminal n’ont pas pu localiser un serveur de licences. Vérifiez que tous les serveurs de licences sur le réseau sont inscrits dans WINS\DNS, qu’ils acceptent les demandes réseau et que le service de gestion des licences des services Terminal Server est en cours d’exécution.

et

ID d’événement : 28
Source de l’événement : TermServLicensing
Description de l’événement : Les licences des services Terminal Server ne peuvent être exécutées que sur des contrôleurs de domaine ou un serveur dans un groupe de travail. Pour plus d’informations, consultez la rubrique d’aide sur les licences Terminal Server.

Cause

Ce problème peut se produire si un certificat sur le serveur Terminal Server est endommagé.

Résolution

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde et la restauration du Registre, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft : 322756 Comment sauvegarder et restaurer le Registre dans Windows

Pour résoudre ce problème, sauvegardez, puis supprimez les clés de Registre du certificat X509, redémarrez l’ordinateur, puis réactivez le serveur de licences des services Terminal Server. Pour cela, procédez comme suit.

Remarque

Effectuez la procédure suivante sur chacun des serveurs Terminal Server.

  1. Assurez-vous que le registre du serveur Terminal Server a été correctement sauvegardé.

  2. Démarrez l’Éditeur du Registre.

  3. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters

  4. Dans le menu Registre, cliquez sur Exporter un fichier du Registre.

  5. Tapez exported-parameters dans la zone Nom de fichier , puis cliquez sur Enregistrer.

    Remarque

    Si vous devez restaurer ultérieurement cette sous-clé de Registre, double-cliquez sur le fichier exportation.reg que vous avez enregistré à cette étape.

  6. Sous la sous-clé de Registre Paramètres , cliquez avec le bouton droit sur chacune des valeurs suivantes, cliquez sur Supprimer, puis cliquez sur Oui pour confirmer la suppression :

    • Certificat
    • X509 Certificate
    • X509 Certificate ID
  7. Quittez le Registre Rédacteur, puis redémarrez le serveur.

  8. Réactivez le serveur de licences des services Terminal Server à l’aide de la méthode de connexion par téléphone dans l’Assistant Gestion des licences.

    Remarque

    Si vous activez le serveur de licences des services Terminal Server à l’aide de l’option Téléphone , le serveur de licences utilise une autre forme de certificat.