Devido a um erro de segurança, o cliente não pôde se conectar ao servidor terminal

Este artigo fornece uma solução para um problema em que os clientes do Terminal Services são negados repetidamente ao servidor de terminal após a atualização do Windows.

Aplica-se a: Windows Server 2012 R2
Número de KB original: 329896

Sintomas

Depois de atualizar um domínio do Microsoft Windows NT para o Windows 2000 ou Windows Server 2003, os clientes do Windows 2000 Terminal Services podem ter acesso negado repetidamente ao servidor terminal. Se você estiver usando um cliente do Terminal Services para fazer logon no servidor de terminal, poderá receber uma das seguintes mensagens de erro:

Devido a um erro de segurança, o cliente não pôde se conectar ao servidor de Terminal. Depois de certificar-se de que você está conectado à rede, tente se conectar ao servidor novamente.

ou

Área de Trabalho Remota desconectada. Devido a um erro de segurança, o cliente não pôde se conectar ao computador remoto. Verifique se você está conectado à rede e tente se conectar novamente.

Além disso, as seguintes mensagens de ID de evento podem ser registradas em Visualizador de Eventos no servidor do terminal:

ID do evento: 50
Fonte do evento: TermDD
Descrição do evento: o componente de protocolo RDP X.224 detectou um erro no fluxo de protocolo e desconectou o cliente.

e

ID do evento: 1008
Fonte do evento: TermService
Descrição do evento: o período de carência de licenciamento dos serviços de terminal expirou e o serviço não foi registrado com um servidor de licença. Um servidor de licença de serviços de terminal é necessário para operação contínua. Um servidor de terminal pode operar sem um servidor de licença por 90 dias após a inicialização inicial.

e

ID do evento: 1004
Fonte do evento: TermService
Descrição do evento: o servidor de terminal não pode emitir uma licença de cliente.

e

ID do evento: 1010
Fonte do evento: TermService
Descrição do evento: os serviços de terminal não conseguiram localizar um servidor de licença. Confirme se todos os servidores de licença na rede estão registrados em WINS\DNS, aceitando solicitações de rede e o Serviço de Licenciamento dos Serviços de Terminal está em execução.

e

ID do evento: 28
Fonte do evento: TermServLicensing
Descrição do evento: o Licenciamento dos Serviços terminais só pode ser executado em controladores de domínio ou servidor em um grupo de trabalho. Para obter mais informações, consulte Tópico de ajuda de Licenciamento do Terminal Server.

Motivo

Esse problema poderá ocorrer se um certificado no servidor de terminal estiver corrompido.

Resolução

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento da Microsoft: 322756 Como fazer backup e restaurar o registro no Windows

Para resolve esse problema, faça backup e remova as chaves do Registro de Certificado X509, reinicie o computador e reativar o servidor de Licenciamento dos Serviços de Terminal. Para fazer isso, execute as etapas a seguir.

Observação

Execute o procedimento a seguir em cada um dos servidores de terminal.

  1. Verifique se o registro do servidor de terminal foi feito com backup com êxito.

  2. Inicie o Editor do Registro.

  3. Localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters

  4. No menu Registro, clique em Exportar Arquivo do Registro.

  5. Digite parâmetros exportados na caixa Nome do arquivo e clique em Salvar.

    Observação

    Se você tiver que restaurar essa sub-chave do Registro no futuro, clique duas vezes no arquivo Exported-parameters.reg que você salvou nesta etapa.

  6. Na subchave parâmetros do registro, clique com o botão direito do mouse em cada um dos seguintes valores, clique em Excluir e clique em Sim para confirmar a exclusão:

    • Certificado
    • Certificado X509
    • ID do Certificado X509
  7. Saia do Registro Editor e reinicie o servidor.

  8. Reativar o servidor de Licenciamento dos Serviços de Terminal usando o método de conexão telefônica no Assistente de Licenciamento.

    Observação

    Se você ativar o servidor de Licenciamento dos Serviços de Terminal usando a opção Telefone , o servidor de licenciamento usará uma forma diferente de certificado.