Impossible d’ouvrir les fichiers EXE

Cet article fournit une résolution du problème lié au fait que vous obtenez des erreurs lors de l’ouverture de fichiers exe.

S’applique à : Windows Server 2012 R2, Windows 10 (toutes les éditions)
Numéro de la base de connaissances d’origine : 555067

Cet article a été écrit par Yuval Sinay, MVP Microsoft.

Symptômes

Lorsque vous essayez d’ouvrir des fichiers EXE, vous pouvez recevoir des messages d’erreur tels que : « Refus d’accès », « Erreur d’exécution », etc.

Cause

Les paramètres du Registre ou un produit tiers (ou virus) peuvent modifier la configuration par défaut pour l’exécution des fichiers EXE. Cela peut entraîner l’échec de l’opération lorsque vous essayez d’exécuter des fichiers EXE.

Résolution

  1. Cliquez sur Démarrer, puis sélectionnez Exécuter.

  2. Tapez "command.com", puis appuyez sur Entrée. (Une fenêtre DOS s’ouvre.)

  3. Tapez les lignes de commande suivantes :

    cd\
    
    cd \windows
    

    Appuyez sur Entrée après avoir tapé chacune d’elles.

  4. Tapez copiez « regedit.exe regedit.com », puis appuyez sur Entrée.

  5. Tapez « start regedit.com », puis appuyez sur Entrée.

  6. Accédez à et sélectionnez la clé :

    HKEY_CLASSES_ROOT\exefile\shell\open\command

  7. Dans le volet droit, double-cliquez sur la valeur (par défaut).

  8. Supprimez les données de valeur actuelles, puis tapez :

    "%1" %*

    Conseil : tapez les caractères : quote-percent-one-quote-space-percent-asterisk.

  9. Fermez l’utilitaire Regedit.

    Remarque

    Si vous utilisez Windows XP et que vous activez « Restauration du système », vous devez désactiver « Restauration du système » en « mode sans échec » avant d’utiliser les instructions ci-dessus.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés au déploiement.

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