Windows accede e si disconnette immediatamente

Questo articolo descrive un problema per cui non è possibile accedere al sistema e viene richiesto ripetutamente il nome utente e la password.

Si applica a: Windows Server 2003
Numero KB originale: 555648

Sintomi

Windows accede e si disconnette immediatamente quando si prova ad accedere a Windows. Quando si digitano il nome utente e la password, viene visualizzata di nuovo la finestra di dialogo Nome utente e Password. Ci si sforza di entrare, ma senza alcun risultato.

Causa

Non è possibile accedere al sistema usando la modalità normale o la modalità provvisoria. Ciò si verifica solo quando il servizio Winlogon tenta di caricare la shell predefinita di Windows (explorer.exe) e la shell utente (userinit.exe) dal Registro di sistema. Questo servizio cerca Explorer.exe e Userinit.exe nel percorso seguente del Registro di sistema:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

Risoluzione

Modificare questi valori e digitare il percorso corretto della shell:

Shell = explorer.exe
Userinit=X:\windows\system32\userinit.exe

Nota

Questi file possono anche essere eliminati dagli spyware. Potrebbe essere necessario estrarli usando il CD di Windows.

Procedura per risolvere il problema

  • Accedere a un computer in rete.

  • Eseguire Regedit.exe.

  • Posizionare il cursore su HKEY_LOCAL_MACHINE.

  • Selezionare FileConnect Remote Registry (Connetti file > registro remoto).

  • Digitare il nome del computer (computer infetto).

  • Passare al percorso seguente nel Registro di sistema del computer di destinazione o infetto:

    HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

  • Modificare questi due valori nel riquadro destro:

    Guscio
    Userinit

  • Modificare questi due valori in

    Shell=explorer.exe
    Userinit = x:\windows\system32\userinit.exe

  • Uscire dal Registro di sistema.

  • Riavviare il computer infetto.

  • Dovrebbe essere possibile accedere al computer.

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