Fehler beim Versuch, Windows Server 2003 über das Internet zu aktivieren: Meldungsnummer 32777

Dieser Artikel enthält Problemumgehungen für ein Problem, bei dem beim Aktivieren von Microsoft Windows Server 2003 über das Internet ein Fehler angezeigt wird.

Gilt für: Windows Server 2003
Ursprüngliche KB-Nummer: 816897

Symptome

Wenn Sie versuchen, Windows Server 2003 über das Internet zu aktivieren, ist die Windows-Produktaktivierung möglicherweise nicht erfolgreich, und es können die folgenden Probleme auftreten:

  • Sie erhalten eine Meldung, in der Sie zur Eingabe eines Benutzernamens und Kennworts aufgefordert werden.

  • Die folgende Fehlermeldung wird angezeigt:

    Es kann keine Verbindung mit dem Aktivierungsserver hergestellt werden. Überprüfen Sie Ihre Netzwerkeinstellungen, vergewissern Sie sich, dass Sie eine Verbindung mit dem Internet herstellen können, und versuchen Sie es dann erneut. Meldungsnummer 32777.

Die Windows-Produktaktivierung ist nicht erfolgreich, unabhängig davon, ob Sie Ihren Benutzernamen und Ihr Kennwort eingeben oder nicht.

Ursache

Dieses Problem tritt auf, wenn die beiden folgenden Bedingungen erfüllt sind:

  • Die erweiterte Sicherheitskonfiguration von Microsoft Internet Explorer ist auf dem Server aktiviert.
  • Sie stellen eine Verbindung mit dem Internet über einen Proxyserver her, auf dem die Standardauthentifizierung aktiviert ist.

Die Internet Explorer Enhanced Security Configuration (auch als Internet Explorer-Härtung bezeichnet) verwendet die Zertifikatsperrung. Dieser Nachschlagevorgang für die Zertifikatsperrung umfasst einen URL-Abrufvorgang. In diesem Fall erfolgt der URL-Abruf über den Proxyserver und erfolgt außerhalb des expliziten Kontexts des angemeldeten Benutzers. Daher werden Sie von der Standardauthentifizierung versehentlich zur Eingabe eines Benutzerkontonamens und Kennworts aufgefordert. Als Benutzer wissen Sie in der Regel nicht, dass Zertifikate überprüft werden, und Sie werden möglicherweise wiederholt während der Überprüfung einer Reihe von Zertifikaten aufgefordert.

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu umgehen.

Hinweis

Die folgenden Methoden werden in der Reihenfolge der am meisten bevorzugten gegenüber der am wenigsten bevorzugten aufgeführt, wobei die am meisten bevorzugte Methode zuerst angezeigt wird.

Problemumgehung 1: Standardauthentifizierung nicht verwenden

Vermeiden Sie die Verwendung der Standardauthentifizierung auf dem Proxyserver. Wenn Sie die Standardauthentifizierung verwenden müssen, schließen Sie die URLs für die Zertifikatsperrlisten (Certificate Revocation Lists, CRLs) von der Anforderung für die Standardauthentifizierung aus. Konfigurieren Sie dazu die folgende Liste von CRLs, die auf dem Proxyserver nicht authentifiziert werden:

  • http://crl.microsoft.com/pki/crl/productsMicrosoftProductSecureServer.crl
  • http://crl.microsoft.com/pki/crl/products/MicrosoftProductSecureCommunications.crl
  • http://crl.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl
  • http://www.microsoft.com/pki/crl/productsMicrosoftProductSecureServer.crl
  • http://www.microsoft.com/pki/crl/products/MicrosoftProductSecureCommunications.crl
  • http://www.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl

Problemumgehung 2: Aktivieren über das Telefon

Wenn Beim Versuch, Windows zu aktivieren, die im Abschnitt Symptome dieses Artikels beschriebene Fehlermeldung angezeigt wird, klicken Sie im Assistenten zum Aktivieren von Windows auf die Schaltfläche Telefon , um Windows über das Telefon zu aktivieren.

Problemumgehung 3: Deaktivieren der Zertifikatsperrung in Internet Explorer

Deaktivieren Sie die Zertifikatsperrung in Internet Explorer, damit die Windows-Aktivierung erfolgreich ist. Führen Sie hierzu die folgenden Schritte aus.

Hinweis

Microsoft empfiehlt, die Zertifikatsperrung in Internet-Explorer nicht zu deaktivieren.

  1. Starten Sie Internet Explorer.

  2. Klicken Sie im Menü Extras auf Internetoptionen.

  3. Klicken Sie auf die Registerkarte Erweitert , und deaktivieren Sie dann die folgenden Kontrollkästchen in der Liste Einstellungen :

    • Überprüfen auf Zertifikatsperrung des Herausgebers
    • Überprüfen auf Die Sperrung des Serverzertifikats (neustart erforderlich)
  4. Klicken Sie im Feld Wähleinstellungen (Telefonkontext) auf Durchsuchen, um die Wähleinstellungen für den Benutzer zu suchen.

  5. Beenden Sie Internet Explorer, und starten Sie es dann neu.

  6. Windows aktivieren.

  7. Klicken Sie in Internet Explorer im Menü Extras auf Internetoptionen.

  8. Klicken Sie auf die Registerkarte Erweitert , und aktivieren Sie dann die folgenden Kontrollkästchen in der Liste Einstellungen :

    • Überprüfen auf Zertifikatsperrung des Herausgebers
    • Überprüfen auf Die Sperrung des Serverzertifikats (neustart erforderlich)
  9. Klicken Sie im Feld Wähleinstellungen (Telefonkontext) auf Durchsuchen, um die Wähleinstellungen für den Benutzer zu suchen.

  10. Beenden Sie Internet Explorer, und starten Sie es dann neu.

Weitere Informationen

Da andere Probleme die Fehlermeldung 32777 generieren können, können Sie die Setuplog.txt-Datei anzeigen, um festzustellen, ob das in diesem Artikel beschriebene Problem die Ursache dieses Fehlers ist. Der Statuscode 407 gibt in der Regel das Auftreten des in diesem Artikel beschriebenen Problems an. Es folgt ein Beispiel für den Statuscode 407, wie er in einer Setuplog.txt-Datei angezeigt wird:

<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,4423,,DISPID_EXTERNAL_CONNECTEDTOINTERNETEx
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1560,,versucht, eine Verbindung mit dem WPA-HTTP-Server herzustellen
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,2170,,Disabled RAS Autodial for current logon session
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1480,,HTTP status Code von WPA HTTP Server 407
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,2184,,Restore value of RAS Autodial for current logon session
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobcomm\connmgr.cpp,1657,, könnte eine Verbindung mit dem WPA-HTTP-Server herstellen
<DateTime,OOBE> Trace,0,GetPreferredConnection: null
<DateTime,OOBE> Trace,0,,UseModem: false
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,3049,,DISPID_EXTERNAL_CONNECT
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,3054,,DISPID_EXTERNAL_RECONNECT
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,4500,,DISPID_EXTERNAL_ACTIVATE
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,6979,,Warten auf Antwort von m_pLicenseAgent-AsyncProcessHandshakeRequest>()
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,5724,, m_pLicenseAgent-AsyncProcessHandshakeRequest>() fehlgeschlagen. Fehler = 32777
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,311,,Windows-Produktaktivierungsfehler.
<DateTime,d>:\dnsrv\base\ntsetup\oobe\msobmain\msobmain.cpp,313,,ReturnActivationStatus: Status = 7, Detail = 32777
<DateTime,OOBE-Ablaufverfolgung,0,Aktivierung> fehlgeschlagen. Fehler = 7

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.