"Error 1919. Error al configurar el origen de datos ODBC" al ejecutar el programa de instalación para Office

Síntomas

Al ejecutar el programa de instalación para cualquiera de los programas enumerados en la sección "Se aplica a", puede recibir el siguiente mensaje de error:

Error 1919. Error al configurar el origen de datos ODBC: base de datos de MS Access. Error odbc 6: componente no encontrado en el Registro. Compruebe que el archivo MS Access Database existe y que puede acceder a él.

Si selecciona Omitir, puede recibir el siguiente mensaje de error:

Error 1919. Error al configurar el origen de datos ODBC: Archivos de Excel. Error ODBC 0: compruebe que el archivo Archivos de Excel existe y que puede acceder a él.

También puede recibir cualquiera de los siguientes mensajes de error:

  • Error 1919. Error al configurar el origen de datos ODBC: base de datos de MS Access. Error ODBC 0: compruebe que el archivo MS Access Database existe y que puede acceder a él.

  • Error 1919. Error al configurar el origen de datos ODBC: Base de datos de Visual FoxPro. Error ODBC 0: compruebe que el archivo Visual FoxPro Database existe y que puede acceder a él.

  • Error 1919. Error al configurar el origen de datos ODBC: Tablas de Visual FoxPro. Error ODBC 0: compruebe que el archivo Visual FoxPro Tables existe y que puede acceder a él.

  • Error 1919. Error al configurar el origen de datos ODBC: archivos dBASE. Error ODBC 6: compruebe que el archivo dBASE Files existe y que puede acceder a él.

Causa

Estos problemas pueden producirse si al Registro de Windows le faltan algunas claves del Registro.

Solución

Para resolver este problema, reemplace las claves del Registro que faltan. Para ello, use uno de los métodos siguientes.

Método 1: Instalación de MDAC 2.8

Para obtener más información sobre MDAC 2.8, incluidas las instrucciones de instalación y eliminación, consulte Instalación de componentes de Microsoft Data Access (MDAC).

Después de instalar MDAC 2.8, debe reiniciar el equipo e iniciar sesión con credenciales administrativas.

Nota:

MDAC 2.8 también se instala al instalar Microsoft Windows XP Service Pack 2 (SP2). Si el sistema operativo es Windows XP, puede optar por instalar Windows XP SP2 en lugar de seguir los pasos anteriores.

Método 2: Restablecer las claves del Registro mediante el archivo Mdac.inf

Use Mdac.inf para restablecer las claves del Registro. Este programa puede solicitarle su CD de Windows para obtener nuevos archivos.

Realice una de las siguientes acciones según corresponda para el sistema operativo y si tiene el CD de Windows.

Para las ediciones minoristas de Microsoft Windows XP y Microsoft Windows Server 2003

  1. Haga clic en Inicio, en Ejecutar, escriba path\inf en el cuadro Abrir y, a continuación, haga clic en Aceptar.

    En este ejemplo, path es la ruta de acceso de la carpeta de Windows. Por ejemplo, escriba C:\Windows\Inf o C:\Winnt. De forma predeterminada, C:\Windows es la carpeta donde está instalado Windows XP, C:\Winnt es la carpeta donde está instalado Windows XP si actualizaste Windows 2000 a Windows XP.

  2. En el menú Herramientas , haga clic en Opciones de carpeta.

  3. En la pestaña Ver , en el cuadro Configuración avanzada , haga clic en Mostrar archivos y carpetas ocultos y, a continuación, haga clic en Aceptar.

  4. Haga clic con el botón derecho en Mdac.inf y, a continuación, haga clic en Instalar.

  5. Si se le pide el CD de Windows, inserte el CD de Windows en la unidad de CD-ROM o en la unidad de DVD-ROM.

  6. Haga clic en la carpeta I386 del disco duro (normalmente, C:\I386) y, a continuación, haga clic en Aceptar.

    Si la carpeta I386 es una subcarpeta de la carpeta Windows, en algunos equipos no se puede seleccionar. En este caso, escriba la ruta de acceso completa en el cuadro Copiar archivos desde (por ejemplo, escriba C:\Windows\I386 o C:\Winnt\I386) y, a continuación, haga clic en Aceptar.

  7. Reinicie el equipo.

Para las ediciones de fabricante de equipos originales (OEM) de Windows XP

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Paso 1: Modificar las claves del Registro

  1. Busque la carpeta I386 en el disco duro y anote su ruta de acceso.

  2. Haga clic en Inicio y luego en Ejecutar.

  3. En el cuadro Abrir, escriba regedit y luego haga clic en Aceptar.

  4. En Editor del Registro, busque y haga clic en la clave siguiente:

    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup

  5. Haga clic con el botón derecho en la entrada Orígenes de instalación y, a continuación, haga clic en Modificar.

  6. En el cuadro Datos de valor , cambie el valor a la ruta de acceso de la carpeta I386 del disco duro y, a continuación, haga clic en Aceptar.

  7. Repita los pasos 5 y 6 para cada una de las entradas siguientes:

    • SourcePath
    • ServicePackSourcePath
  8. Salga del editor del Registro.

Paso 2: Instalar Mdac.inf

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba C:\Winnt\Inf en el cuadro Abrir y, a continuación, haga clic en Aceptar.

  2. En el menú Herramientas , haga clic en Opciones de carpeta.

  3. En la pestaña Ver del cuadro Configuración avanzada , haga clic en Mostrar archivos y carpetas ocultos y, a continuación, haga clic en Aceptar.

  4. Haga clic con el botón derecho en Mdac.inf y, a continuación, haga clic en Instalar.

  5. Si se le pide el CD de Windows, inserte el CD de Windows en la unidad de CD-ROM o en la unidad de DVD-ROM.

  6. Haga clic en la carpeta I386 del disco duro (normalmente, C:\I386) y, a continuación, haga clic en Aceptar.

    Nota:

    • Si no tiene el CD para la instalación actual de Windows, haga clic en Examinary, a continuación, busque y seleccione la carpeta I386 .
    • Si la carpeta I386 es una subcarpeta de la carpeta Windows , en algunos equipos no se puede seleccionar. En este caso, escriba la ruta de acceso completa en el cuadro Copiar archivos desde (por ejemplo, escriba C:\Windows\I386 o C:\Winnt\I386) y, a continuación, haga clic en Aceptar.
  7. Restart your computer.

Método 3: Importar las claves del Registro desde otro equipo de la red

Nota Al importar las claves del Registro desde otro equipo, asegúrese de que el equipo de origen y el equipo de destino ejecutan el mismo sistema operativo. Por ejemplo, si usa este método en un equipo que ejecuta Windows XP, busque un equipo que ejecute Windows XP que pueda usar para exportar las claves del Registro.

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Parte 1: Exportación de las claves del registro en el equipo de "origen"

  1. En un equipo al que no le faltan las claves (el equipo de "origen"), haga clic en Inicio, en Ejecutar, escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.

  2. Busque y haga clic en la siguiente clave del Registro:

    HKEY_CURRENT_USER\Software\ODBC

  3. En el menú Archivo , haga clic en Exportar.

  4. En el cuadro Guardar en , especifique una ubicación para guardar temporalmente el archivo de registro (archivo .reg).

    En el cuadro Nombre de archivo, escriba un nombre de archivo y, a continuación, haga clic en Guardar.

  5. Busque y haga clic en la clave siguiente:

    HKEY_LOCAL_MACHINE\Software\ODBC

  6. Repita los pasos 4 y 5 para exportar esta clave.

Parte 2: Importación de las claves en el registro del equipo de "destino"

  1. Copie los archivos .reg exportados desde el equipo de origen a una ubicación temporal en el equipo en el que faltan las claves (el equipo de "destino").
  2. Haga clic en Inicio, en Ejecutar, escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  3. En el menú Registro , haga clic en Importar archivo del Registro.
  4. Busque y, a continuación, haga clic en uno de los archivos .reg que copió en el paso 1 y, a continuación, haga clic en Abrir.
  5. Repita los pasos 4 y 5 para el otro archivo .reg.

Solución alternativa

Puede solucionar este problema haciendo clic en Reintentar varias veces cuando reciba estos mensajes de error. Sin embargo, es posible que este trabajo no funcione a largo plazo.