HTTPS kullanarak bir siteye erişmeye çalıştığınızda hata oluştu: Sayfa görüntülenemiyor

Bu makale, Köprü Metni Aktarım Protokolü Güvenli (HTTPS) kullanarak bir siteye erişmeye çalıştığınızda oluşan hatayı (Sayfa görüntülenemiyor) çözmenize yardımcı olur.

Özgün ürün sürümü: Internet Information Services
Özgün KB numarası: 824035

Belirtiler

Microsoft Internet Information Services(IIS) içinde barındırılan ve HTTPS protokolü kullanılarak Güvenli Yuva Katmanı (SSL) kullanacak şekilde yapılandırılmış bir siteye erişmeye çalıştığınızda, aşağıdaki hata iletisini alabilirsiniz:

Sayfa görüntülenemiyor

Aşağıdaki hata iletisi Web sunucusu olay günlüklerine kaydedilir:

Olay Türü:Hata

Olay Kaynağı:Schannel
Olay Kategorisi:Hiçbiri Olay Kimliği:36869
Tarih:12/18/2000
Saat:9:12:46
Kullanıcı:Yok
Bilgisayar:<SunucuAdı>
Açıklama: SSL sunucusu kimlik bilgilerinin sertifikasına eklenmiş bir özel anahtar bilgisi özelliği yok. Bu durum çoğu zaman bir sertifika yanlış yedeklendiğinde ve daha sonra geri yüklendiğinde oluşur. Bu ileti bir sertifika kayıt hatasına da işaret edebilir.

Neden

Bu sorun, Web sitesinin eşleşen bir özel anahtarı olmayan bir sertifikaya bağlı olması nedeniyle oluşur. Bu sertifikayı Sertifikalar Microsoft Yönetim Konsolu'ndan (MMC) dışarı aktarmaya çalışırsanız, özel anahtarı dışarı aktaramazsınız. Sertifikayı dışarı aktarmayı denediğinizde aşağıdaki uyarı iletisini alırsınız:

#You bu sertifikaya karşılık gelen bir özel anahtarınız yok.

Çözüm

Sorunu çözmek için özel anahtarla yeni bir sertifika oluşturun. Bunu yapmak için şu adımları uygulayın:

  1. Özel anahtarı olmayan geçerli sertifikayı kaldırın.

  2. Özel anahtarla yeni sertifikayı alın ve yükleyin.

Not

Özgün sertifika onarılabilir (başlangıçta Sertifikayı talep eden sunucudan). Sertifikayı onarma hakkında daha fazla bilgi için bkz. Internet Information Services'da özgün sertifikayı silmek için Sertifikalar ek bileşenini kullandıktan sonra yeni bir sertifikaya özel anahtar atama.