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Daylight saving time update

Important The update in this article is superseded by the cumulative update in Microsoft Knowledge Base article 955839.

You do not have to remove any previously installed DST update to apply this cumulative update.

Symptoms

When the time zone is set to (GMT+02:00) Cairo in Microsoft Windows Server 2003, in Microsoft Windows XP, or in Microsoft Windows 2000, daylight saving time may start or end on an incorrect date and at an incorrect time.

For example, a computer's clock may change to daylight saving time on the first Friday of May at 02:00, and it may change from daylight saving time on the last Wednesday of September at 02:00. However, in Egypt, daylight saving time starts on the last Friday in April at midnight (00:00:00) and ends on the last Friday in September at midnight (00:00:00).

The behavior occurs if the date and time properties are set to the following:

  • Time Zone is set to (GMT+02:00) Cairo.

  • The Automatically adjust clock for daylight saving changes check box is selected.

Cause

This problem occurs because the information in the registry for this time zone is incorrect. The reference data is stored in the following subkey:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\Egypt Standard TimeThe currently in-use information is stored in the following subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformationThe time zone information in both of these locations is in binary format. We do not recommend that you resolve this problem by modifying the registry.

Resolution

Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003.

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, 32-bit versions

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.2.3790.199

5,632

16-Aug-2004

18:09

x86

Cstegypt.dll

5.2.3790.199

5,632

16-Aug-2004

18:09

x86

Windows Server 2003, Itanium-based versions

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.2.3790.199

8,704

16-Aug-2004

18:09

IA-64

Cstegypt.dll

5.2.3790.199

8,704

16-Aug-2004

18:09

IA-64

Windows Server 2003 with Service Pack 1, 32-bit versions

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.2.3790.2688

6,144

24-Apr-2006

18:09

x86

Cstegypt.dll

5.2.3790.2688

6,144

24-Apr-2006

18:09

x86

Windows Server 2003 with Service Pack 1, Itanium-based versions

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.2.3790.2688

11,264

24-Apr-2006

22:31

IA-64

Cstegypt.dll

5.2.3790.2688

11,264

24-Apr-2006

22:31

IA-64

Windows Server 2003, x64-based versions

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.2.3790.2688

9,216

24-Apr-2006

22:31

x64

Cstegypt.dll

5.2.3790.2688

9,216

24-Apr-2006

22:31

x64

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.1.2600.2505

5,632

14-Aug-2004

00:24

x86

Cstegypt.dll

5.1.2600.2505

5,632

14-Aug-2004

00:24

x86

Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Cstegypt.dll

5.0.2195.6961

5,392

30-Jul-2004

18:38

x86

Cstegypt.dll

5.0.2195.6961

5,392

30-Jul-2004

18:38

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

More Information

The hotfix changes the registry settings to the following values:

  • DST Start: Last Thursday of April at 11:59:59 PM

  • DST End: Last Thursday of September at 11:59:59 PM

To set your computer to adjust for daylight saving time automatically, use the following methods.

Set your computer to adjust for daylight saving time automatically in Windows Server 2003

  1. Click Start, point to Control Panel, and then click Date and Time.

  2. On the Time Zone tab, use one of the following procedures:

    • To set the computer to change the system clock for daylight saving time, click to select the Automatically adjust clock for daylight saving changes check box, and then click OK.

    • To set the computer not to change the system clock for daylight saving time, click to clear the Automatically adjust clock for daylight saving changes check box, and then click OK.

Set your computer to adjust for daylight saving time automatically in Windows XP

  1. Click Start, click Run, type timedate.cpl, and then click OK two times.

  2. On the Time Zone tab, use one of the following procedures:

    • To set the computer to change the system clock for daylight saving time, click to select the Automatically adjust clock for daylight saving changes check box, and then click OK.

    • To set the computer not to change the system clock for daylight saving time, click to clear the Automatically adjust clock for daylight saving changes check box, and then click OK.

Set your computer to adjust for daylight saving time automatically in Windows Server 2000

  1. Click Start, point to Settings, and then click Control Panel.

  2. Double-click Date and Time.

  3. On the Time Zone tab, use one of the following procedures:

    • To set the computer to change the system clock for daylight saving time, click to select the Automatically adjust clock for daylight saving changes check box, and then click OK.

    • To set the computer not to change the system clock for daylight saving time, click to clear the Automatically adjust clock for daylight saving changes check box, and then click OK.

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