Un batch viene mantenuto nello stato Registrazione, Ricezione, Occupato, Contrassegnato, Bloccato o Modificato in Microsoft Dynamics GP

Questo articolo fornisce una soluzione a un errore che si verifica quando si tenta di pubblicare un batch e aprirlo in Microsoft Dynamics GP o in Microsoft Business Solutions - Great Plains.

Si applica a: Microsoft Dynamics GP
Numero KB originale: 850289

Sintomi

Dopo aver provato a pubblicare un batch in Microsoft Dynamics GP o in Microsoft Business Solutions - Great Plains, al batch viene assegnato uno degli stati seguenti:

  • Distacco
  • Ricezione
  • Occupato
  • Contrassegnato
  • Bloccato
  • Modificato

Non è possibile registrare o deselezionare il batch. Quando si tenta di aprire il batch, è possibile che venga visualizzato il messaggio di errore seguente:

"Batch è contrassegnato per la pubblicazione da un altro utente."

Causa

Questo problema può verificarsi perché una fluttuazione dell'alimentazione o un altro problema ha causato l'arresto del processo di registrazione.

Risoluzione

Nota

Tutti gli script inclusi nella sezione "Risoluzione" devono essere eseguiti in uno strumento di query. Per aprire lo strumento di query appropriato, eseguire l'istruzione in Microsoft SQL Server Management Studio. Per aprire SQL Server Management Studio, selezionare Start, scegliere Programmi>Microsoft SQL Server (2019) (o la versione disponibile) e quindi selezionare SQL Server Management Studio. Per eseguire uno script, selezionare Nuova query.

Per risolvere questo problema, seguire questa procedura:

  1. Assicurarsi di disporre di un backup corrente del database aziendale e chiedere a tutti gli utenti di uscire da Microsoft Dynamics GP. Per creare il backup in Microsoft Dynamics GP, seguire i passaggi appropriati dopo che tutti gli utenti si disconnetteno da Microsoft Dynamics GP:

    1. Scegliere Backup dal menu File.
    2. Nell'elenco Nome società selezionare la società di cui si vuole eseguire il backup.
    3. Nella casella Selezionare il file di backup selezionare la cartella gialla per aprire il percorso in cui si vuole inserire il file di backup.

    Oppure

    1. Nel Esplora oggetti espandere i database in modo da visualizzare il database di cui si vuole eseguire il backup.
    2. Fare clic con il pulsante destro del mouse sul nome del database, scegliere Attività e selezionare Backup.
    3. Selezionare il pulsante Aggiungi e selezionare il percorso e il nome del file in cui salvare il backup.
    4. Selezionare OK per avviare il backup.
  2. Visualizzare il contenuto delle tabelle seguenti per verificare che tutti gli utenti siano disconnetti: DYNAMICS..ACTIVITY, DYNAMICS..SY00800, DYNAMICS..SY00801, TEMPDB..DEX_LOCKe TEMPDB..DEX_SESSION. A tale scopo, eseguire lo script seguente.

    SELECT * FROM DYNAMICS..ACTIVITY SELECT * FROM DYNAMICS..SY00800 SELECT * FROM DYNAMICS..SY00801 SELECT * FROM TEMPDB..DEX_LOCK SELECT * FROM TEMPDB..DEX_SESSION
    

    Nota

    Quando tutti gli utenti si disconnettono da Microsoft Dynamics GP, queste tabelle non avranno alcun record.

  3. Se non vengono restituiti risultati, andare al passaggio 4. In caso contrario, cancellare i record bloccati usando uno degli script appropriati seguenti.

    DELETE DYNAMICS..ACTIVITY DELETE DYNAMICS..SY00800 DELETE DYNAMICS..SY00801 DELETE TEMPDB..DEX_LOCK DELETE TEMPDB..DEX_SESSION
    
  4. Eseguire lo script seguente nel database aziendale. Sostituire XXX con il numero di batch o il nome del batch che si sta tentando di pubblicare o selezionare in Microsoft Dynamics GP.

    UPDATE SY00500 SET MKDTOPST=0, BCHSTTUS=0 where BACHNUMB='XXX'
    

    Nota

    Il valore di BACHNUMB è uguale al valore della finestra ID batch in Microsoft Dynamics GP.

  5. Verificare l'accuratezza delle transazioni.

  6. Verificare che sia possibile modificare e pubblicare i batch.