Microsoft Dynamics GP'de Deftere Nakil, Alma, Meşgul, İşaretli, Kilitli veya Düzenlendi durumunda bir toplu iş tutulur

Bu makale, bir toplu iş gönderip Microsoft Dynamics GP'de veya Microsoft Business Solutions - Great Plains'te açmaya çalıştığınızda oluşan bir hataya çözüm sağlar.

Şunlar için geçerlidir: Microsoft Dynamics GP
Özgün KB numarası: 850289

Belirtiler

Bir toplu işlemi Microsoft Dynamics GP'de veya Microsoft Business Solutions - Great Plains'te göndermeye çalıştıktan sonra toplu işe aşağıdaki durumlardan biri atanır:

  • Gönderme
  • Alma
  • Meşgul
  • Işaretlenmiş
  • Kilitli
  • Düzenlen -miş

Toplu işlemi deftere nakledemez veya işaretini kaldıramazsınız. Toplu işlemi açmaya çalıştığınızda aşağıdaki hata iletisini alabilirsiniz:

"Batch başka bir kullanıcı tarafından deftere nakil için işaretlendi."

Neden

Bu sorun, bir güç dalgalanması veya başka bir sorun gönderme işleminin durmasına neden olduğu için oluşabilir.

Çözüm

Not

"Çözüm" bölümündeki tüm betikler bir sorgu aracında çalıştırılmalıdır. Uygun sorgu aracını açmak için microsoft SQL Server Management Studio deyimini çalıştırın. SQL Server Management Studio açmak için Başlat'ı seçin,Microsoft SQL Server (2019) (veya sahip olduğunuz sürüm)programlar'ın> üzerine gelin ve SQL Server Management Studio'ı seçin. Betiği çalıştırmak için Yeni Sorgu'yu seçin.

Bu sorunu çözmek için şu adımları izleyin:

  1. Şirket veritabanının geçerli bir yedeğine sahip olduğunuzdan emin olun ve tüm kullanıcılardan Microsoft Dynamics GP'den çıkmalarını isteyin. Microsoft Dynamics GP'de yedekleme oluşturmak için, tüm kullanıcılar Microsoft Dynamics GP'de oturumu kapatıldıktan sonra uygun adımları izleyin:

    1. Dosya menüsünde Yedekle'yi seçin.
    2. Şirket Adı listesinde, yedeklemek istediğiniz şirketi seçin.
    3. Yedekleme dosyasını seçin kutusunda, yedekleme dosyasını yerleştirmek istediğiniz konumu açmak için sarı klasörü seçin.

    Veya

    1. Nesne Gezgini, yedeklemek istediğiniz veritabanını görmek için veritabanlarınızı genişletin.
    2. Veritabanı Adı'na sağ tıklayın, Görevler'e gidin ve Yedekle'yi seçin.
    3. Ekle düğmesini seçin ve yedeklemenizi kaydetmek istediğiniz konumu ve dosya adını seçin.
    4. Yedeklemeyi başlatmak için Tamam'ı seçin.
  2. Tüm kullanıcıların oturumunun kapatıldığını doğrulamak için aşağıdaki tabloların içeriğini görüntüleyin: DYNAMICS..ACTIVITY, DYNAMICS..SY00800, DYNAMICS..SY00801, TEMPDB..DEX_LOCKve TEMPDB..DEX_SESSION. Bunu yapmak için aşağıdaki betiği çalıştırın.

    SELECT * FROM DYNAMICS..ACTIVITY SELECT * FROM DYNAMICS..SY00800 SELECT * FROM DYNAMICS..SY00801 SELECT * FROM TEMPDB..DEX_LOCK SELECT * FROM TEMPDB..DEX_SESSION
    

    Not

    Tüm kullanıcıların Microsoft Dynamics GP'de oturumları kapatıldığında, bu tablolarda hiçbir kayıt olmaz.

  3. Sonuç döndürülmezse 4. adıma gidin. Aksi takdirde, aşağıdaki uygun betiklerden birini kullanarak takılan kayıtları temizleyin.

    DELETE DYNAMICS..ACTIVITY DELETE DYNAMICS..SY00800 DELETE DYNAMICS..SY00801 DELETE TEMPDB..DEX_LOCK DELETE TEMPDB..DEX_SESSION
    
  4. Aşağıdaki betiği şirket veritabanında çalıştırın. XXX değerini, Microsoft Dynamics GP'de göndermeye veya seçmeye çalıştığınız toplu iş numarası veya toplu iş adıyla değiştirin.

    UPDATE SY00500 SET MKDTOPST=0, BCHSTTUS=0 where BACHNUMB='XXX'
    

    Not

    değeri BACHNUMB , Microsoft Dynamics GP'deki Batch Id penceresinin değeriyle aynıdır.

  5. İşlemlerin doğruluğunu doğrulayın.

  6. Toplu işleri düzenleyip gönderebildiğinizi doğrulayın.