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Symptoms

When you use one or more programs to move files and to rename those files, you may experience both of the following symptoms:

  • You occasionally receive the following error message:

    The file or directory is corrupt and unreadable. Please run the Chkdsk utiltity.

  • If you run the Chkdsk.exe tool, the Chkdsk.exe tool does not report any problems with the hard disk or with the file indexes.

Cause

This problem may occur if you are running Microsoft Windows Server 2003 on a computer that has multiple central processing units (CPUs). A race condition may occur where two separate threads rename and move a particular file in the NTFS file sytem at the same time. This problem occurs because NTFS incorrectly determines that the name of a parent folder does not change when NTFS opens a file. For example, one thread might rename a file at the same time that the other thread moves the same file. NTFS then tries to remove a link that no longer exists to the file. Therefore, NTFS generates the error message that is listed earlier in this article.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart your computer to apply the changes after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions
   Date         Time   Version       Size     File name
----------------------------------------------------
07-Jun-2004 15:57 5.2.3790.181 619,008 Ntfs.sys
Windows Server 2003, 64-bit editions
   Date         Time   Version       Size       File name
------------------------------------------------------
07-Jun-2004 16:02 5.2.3790.181 1,694,208 Ntfs.sys

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

More Information

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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