Microsoft Dynamics SL の買掛金勘定で部分的にリリースされたバッチのトラブルシューティング

この記事では、Microsoft Dynamics SL で買掛金勘定でバッチをリリースしようとしたときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics SL 2011
元の KB 番号: 871362

現象

Microsoft Dynamics SL で買掛金勘定でバッチをリリースしようとすると、バッチはリリースされません。 調査すると、[ リリース AP バッチ (03.400.00)] ダイアログ ボックスのバッチの状態が部分的にリリースされていることがわかります。 イベント ログに次のいずれかのエラー メッセージが表示される場合があります。

システム メッセージ 8888 - バッチ %s のリリース中に予期しないエラーが発生しました。 このバッチのサポートについては、ソロモンにお問い合わせください。

システム メッセージ 6019 - バッチの残高が不足しており、リリースされていません。

システム メッセージ 6909 - 別のプロセスで %s 項目が既に追加されています。 プログラムを終了する必要があります。

原因

エラー メッセージには、いくつかの原因が考えられます。

注:

次のいずれかの原因が適用されない場合は、デバッグ スクリプトを実行します。 デバッグ スクリプトを実行する方法の詳細については、「 解決策 2」を参照してください。

  • リリース プロセス中に、Microsoft Dynamics SL と SQL Server のインスタンス間の接続が失われました。 解決策 1 を参照してください。
  • リリース プロセス中に、[リリース AP バッチ (03.400.00)] ダイアログ ボックスで [キャンセル] を選択しました。 解決策 1 を参照してください。
  • システム メッセージ 6909 エラー メッセージは、期間を [転記] に変更しようとした後、[ 照合の確認 (03.060.00)] ダイアログ ボックスから照合バッチをリリースしようとすると発生する可能性があります。
  • Microsoft Business Solutions - ソロモン 6.0 では、バグ 7318 によってシステム メッセージ 6909 エラー メッセージが表示される可能性があります。

解決方法

注:

現在 Microsoft Dynamics SL 2011 以降のバージョンを使用している場合は、データ入力画面からバッチを削除して再入力できます。

解決方法 1

バッチをもう一度リリースしてみてください。 これを行うには、次の手順に従います。

  1. [ リリース AP バッチ (03.400.00)] ダイアログ ボックスを開きます。
  2. イベント ログで参照されているバッチ番号の横にある [選択したチェック] ボックスを選択します。
  3. [ 処理の開始] を選択します

解決方法 2

Microsoft SQL Server 2000 を実行している場合は、SQL Query Analyzer でAP_6019_DEBUG スクリプトを実行し、スクリプトの結果とイベント ログを Microsoft カスタマー サポート サービスに送信します。 これを行うには、次の手順に従います。 AP デバッグ スクリプトを実行するプロセスをステップ実行するビデオも利用できます。

  1. AP_6019_DEBUG.sql ファイルをダウンロードします。

    Microsoft はこのファイルをスキャンしてウイルスを検出しました。 Microsoft では、ファイルが投稿された日付に利用可能な最新のウイルス検出ソフトウェアを使用しました。 ファイルは、ファイルに対する未承認の変更を防ぐのに役立つセキュリティ強化サーバーに格納されます。

  2. [スタート] を選択し、[すべてのプログラム] をポイントし、[Microsoft SQL Server] をポイントして、[クエリ アナライザー] を選択します。

  3. [SQL Serverに接続] ダイアログ ボックスで、[SQL Server] ボックスにSQL Server名のインスタンスの名前を入力し、[認証のSQL Server] を選択します。

  4. [ログイン名] ボックスに「sa」と入力し、[パスワード] ボックスにパスワードを入力し、[OK] を選択します

  5. [クエリ アナライザー] ツール バーで、アプリケーション データベースを選択します。

  6. [ ツール ] メニューの [ オプション] を選択し、[ 結果 ] タブを選択します。

  7. [ 既定の結果のターゲット ] ボックスで、[結果] を [テキスト] に選択します

  8. [ 結果の出力形式 ] ボックスで、[ タブ区切り] を選択し、[ OK] を選択します

  9. XXXXXX を 6 桁のバッチ番号に置き換えます。

  10. スクリプトを実行するには、 F5 キーを押します。

  11. スクリプトの実行が完了したら、下のウィンドウを 1 回クリックします。

  12. [ファイル] メニューの [名前を付けて保存] をクリックします。

  13. [ ファイル名 ] ボックスに「 IncidentAP」と入力します。 インシデントを実際のインシデント番号に置き換えます。

  14. [ 名前を付けて保存] ボックスで 、[ レポート ファイル (*.rpt)] を選択し、[保存] を選択 します

  15. このファイルをイベント ログと一緒に圧縮し、ファイルを Microsoft カスタマー サポート サービスに送信します。

Microsoft SQL Server 2005 または Microsoft SQL Server 2008 を実行している場合は、SQL Server Management StudioでAP_6019_DEBUG スクリプトを実行し、スクリプトの結果とイベント ログを Microsoft カスタマー サポート サービスに送信します。 これを行うには、次の手順に従います。

  1. AP_6019_DEBUG.sqlデバッグ ファイルをダウンロードします。

    次のファイルは、Microsoft Dynamics File Exchange Server: AP_6019_DEBUG.sqlからダウンロードできます。

    Microsoft はこのファイルをスキャンしてウイルスを検出しました。 Microsoft では、ファイルが投稿された日付に利用可能な最新のウイルス検出ソフトウェアを使用しました。 ファイルは、ファイルに対する未承認の変更を防ぐのに役立つセキュリティ強化サーバーに格納されます。

  2. SQL Server Management Studioを開始し、サーバーにサインインし、出力の書式設定を変更します。 これを行うには、次の手順に従います。

    1. [ツール] メニューの [オプション] を選択します。
    2. [ クエリ結果] を選択します
    3. [ 結果の既定の変換先 ] ボックスで、[ 結果からテキストへ] を選択します。
    4. [クエリ結果] を展開し、SQL Serverのインスタンスを展開します。
    5. [ 結果] を [テキスト] に選択します
    6. [ 出力形式 ] ボックスで、[ タブ区切り] を選択します。
    7. 結果セットの [列ヘッダーを含める] チェックボックスを選択します。
    8. [ OK] を選択 して 、[オプション] ダイアログ ボックスを閉じます。
  3. [ ファイル ] メニューの [ 開く] を選択 し、AP_6019_DEBUG.sql ファイルを見つけて、 AP_6019_DEBUG.sql ファイルをダブルクリックします。

  4. XXXXXX プレースホルダーを、中断されたバッチの 6 桁のバッチ番号に置き換えます。

  5. F5 キーを押します。

  6. スクリプトが完了したら、ウィンドウの下のペインを左クリックします。

  7. [ファイル] メニューの [名前を付けて保存] をクリックします。

  8. [ ファイル名 ] ボックスに「 IncidentAP」と入力します。

    注:

    Incident プレースホルダーを、中断されたバッチのバッチ番号に置き換えます。

  9. [ 名前を付けて保存] の種類ボックスで 、[ レポート ファイル (*.rpt)] を選択します。

  10. [保存] を選択します。

  11. ファイルを圧縮します。

  12. 圧縮されたファイルとイベント ログを Microsoft カスタマー サポート サービスに送信します。

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