Mensaje de error "Error 633: el módem (u otro dispositivo de conexión) ya está en uso" al intentar establecer una conexión VPN

En este artículo se proporciona una solución alternativa para el problema en el que es posible que no pueda establecer una conexión VPN debido a un conflicto de puerto TCP.

Se aplica a: Windows Server 2003
Número de KB original: 885959

Importante

Este artículo contiene información sobre cómo modificar el Registro. Antes de modificarlo, asegúrese de hacer una copia de seguridad de este y de comprender cómo restaurarlo si hay un problema. Para obtener información sobre cómo realizar copias de seguridad, restaurar y editar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986 Descripción del Registro de Microsoft Windows

Síntomas

Al intentar usar una conexión de red privada virtual (VPN) en un equipo basado en Microsoft Windows Server 2003, es posible que reciba el siguiente mensaje de error:

Error 633: el módem (u otro dispositivo de conexión) ya está en uso o no está configurado correctamente.

Causa

Este problema puede producirse si otro programa ya usa el puerto TCP que usa la conexión VPN. La conexión VPN usa el puerto TCP 1723 para establecer una conexión. Si otro programa ya usa este puerto, no puede establecer una conexión VPN.

Solución alternativa

Advertencia

Si utiliza incorrectamente el Editor del Registro, puede causar serios problemas que tal vez requieran volver a instalar el sistema operativo. Microsoft no le garantiza que pueda solucionar los problemas que sean consecuencia del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Para resolver este problema, use uno de los métodos siguientes:

  • Reserve explícitamente el puerto TCP que se usa para la conexión VPN. Para ello, siga estos pasos:
    1. Haga clic en Inicio, en Ejecutar, escriba regedit.exe en el cuadro Abrir y, a continuación, haga clic en Aceptar.
    2. En Editor del Registro, busque y, a continuación, haga clic en la siguiente subclave del Registro:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    3. En el menú Editar , seleccione Nuevo y, a continuación, haga clic en Valor de cadena múltiple.
    4. Cambie el nombre del valor de varias cadenas por "ReservedPorts" y, a continuación, haga doble clic en ReservedPorts.
    5. En el cuadro Datos de valor , escriba 1723-1723 y, a continuación, haga clic en Aceptar.
    6. Salga del editor del Registro.
  • Use el comando netstat para buscar el programa que usa el puerto 1723. A continuación, finalice el proceso para ese programa. Para ello, siga estos pasos:
    1. Haga clic en Inicio, en Ejecutar, escriba cmd.exe en el cuadro Abrir y, a continuación, haga clic en Aceptar.

    2. En el símbolo del sistema, escriba el siguiente comando y presione ENTRAR:
      netstat -aon

    3. En la salida que se muestra, identifique el identificador de proceso del programa, si existe, que usa el puerto TCP 1723.

    4. En el símbolo del sistema, escriba el siguiente comando y presione ENTRAR:
      taskkill /PID PID /F

      Nota:

      El comando taskkill finaliza el proceso que corresponde al número de identificador del proceso. La /F opción se usa para finalizar el proceso con fuerza.

    5. En el símbolo del sistema, escriba exit y presione ENTRAR para salir del símbolo del sistema.

  • Restart your computer. Puede hacer que el programa que usa el puerto TCP 1723 use un puerto diferente.