Mensagem de erro "Erro 633 – o modem (ou outro dispositivo de conexão) já está em uso" quando você tenta estabelecer uma conexão VPN

Este artigo fornece uma solução alternativa para o problema em que talvez você não seja capaz de estabelecer uma conexão VPN devido a um conflito de porta TCP.

Aplica-se a: Windows Server 2003
Número de KB original: 885959

Importante

Este artigo contém informações sobre como modificar o Registro. Antes de modificar o Registro, certifique-se de fazer o backup e de que saiba restaurá-lo caso ocorra algum problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número do artigo a seguir para exibir o artigo na Base de Dados de Conhecimento da Microsoft:
256986 Descrição do Registro do Microsoft Windows

Sintomas

Ao tentar usar uma conexão VPN (rede virtual privada) em um computador baseado no Microsoft Windows Server 2003, você poderá receber a seguinte mensagem de erro:

Erro 633 – o modem (ou outro dispositivo de conexão) já está em uso ou não está configurado corretamente.

Motivo

Esse problema poderá ocorrer se a porta TCP usada pela conexão VPN já estiver sendo usada por outro programa. A conexão VPN usa a porta TCP 1723 para estabelecer uma conexão. Se outro programa já estiver usando essa porta, você não poderá estabelecer uma conexão VPN.

Solução alternativa

Aviso

O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. Use o Editor do Registro por sua própria conta e risco.

Para contornar esse problema, use um dos seguintes métodos:

  • Reserve explicitamente a porta TCP usada para a conexão VPN. Para fazer isso, siga estas etapas:
    1. Clique em Iniciar, clique em Executar, digite regedit.exe na caixa Abrir e clique em OK.
    2. No Registro Editor, localize e clique na subchave do registro a seguir:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    3. No menu Editar , aponte para Novo e clique em Valor de Várias Cadeias de Caracteres.
    4. Renomeie o valor de várias cadeias de caracteres como "ReservedPorts" e clique duas vezes em ReservedPorts.
    5. Na caixa de dados Valor , digite 1723-1723 e clique em OK.
    6. Saia do Editor do Registro.
  • Use o comando netstat para localizar o programa que usa a porta 1723. Em seguida, encerre o processo para esse programa. Para fazer isso, siga estas etapas:
    1. Clique em Iniciar, clique em Executar, digite cmd.exe na caixa Abrir e clique em OK.

    2. No prompt de comando, digite o seguinte comando e pressione ENTER:
      netstat -aon

    3. Na saída exibida, identifique a ID do processo para o programa, se houver, que usa a porta TCP 1723.

    4. No prompt de comando, digite o seguinte comando e pressione ENTER:
      taskkill /PID PID /F

      Observação

      O comando taskkill encerra o processo que corresponde ao número de ID do processo. A /F opção é usada para encerrar o processo com força.

    5. No prompt de comando, digite saída e pressione ENTER para sair do prompt de comando.

  • Restart your computer. Isso pode fazer com que o programa que usa a porta TCP 1723 use uma porta diferente.