Messaggio di errore quando si tenta di installare una stampante di rete condivisa

In questo articolo viene descritto un problema per cui non è possibile installare localmente una stampante di rete condivisa in un computer con sistema operativo Windows Server o Windows.

Si applica a: Windows 10: tutte le edizioni, Windows Server 2012 R2
Numero della Knowledge Base originale: 888046

Sintomi

Se si tenta di installare una stampante di rete condivisa, si verificano sintomi se si verificano le condizioni seguenti:

  • Si dispone di una stampante di rete condivisa installata in un server di stampa con sistema operativo Microsoft Windows 2000 Advanced Server.

  • Si tenta di installare localmente la stampante di rete condivisa in un computer che fa parte di un dominio Windows.

  • Si tenta di installare localmente la stampante di rete condivisa in un computer che esegue uno dei sistemi operativi seguenti:

    • Windows XP Service Pack 1 (SP1)
    • Windows Server 2003

In questo scenario, si verificano i sintomi seguenti se si tenta di installare una stampante di rete condivisa:

  • Se si tenta di installare la stampante su un client basato su Windows XP SP1 utilizzando l'Installazione guidata stampante o utilizzando il nome di condivisione della stampante dal percorso \\PrintServerName\PrinterShareName, viene visualizzato il seguente messaggio di errore:

    Nel computer è in vigore un criterio che impedisce la connessione a questa coda di stampa. Contattare l'amministratore del sistema.

  • Se si utilizza l'Installazione guidata stampante per tentare di installare la stampante in un client con sistema operativo Windows Server 2003, viene visualizzato il seguente messaggio di errore quando si fa clic su Fine per completare l'installazione della stampante:

    Impossibile installare la stampante. Il driver della stampante non è compatibile con un criterio abilitato nel computer che blocca i driver di Windows NT 4.0. Se si desidera utilizzare questo driver, contattare l'amministratore di sistema per disabilitare questo criterio.

Causa

Questo problema si verifica se il driver della stampante installato nel server di stampa è un driver della stampante di terze parti. Non è possibile installare localmente una stampante di rete condivisa con un driver della stampante di terze parti in un computer con sistema operativo Windows XP SP1 se si è un utente normale o un membro del gruppo Power Users. Windows XP SP1 non consente agli utenti normali o ai membri del gruppo Power Users di installare driver di terze parti. In Windows XP SP1, solo le seguenti persone dispongono dell'autorizzazione per installare un driver di terze parti:

  • Amministratore locale
  • Membri del gruppo Administrators
  • Membri del gruppo Power Users che dispongono delle autorizzazioni del criterio Caricamento/rimozione di driver di dispositivo

Se il computer con sistema operativo Windows XP SP1 fa parte di un dominio basato su Microsoft Windows NT 4.0, gli utenti normali e i membri del gruppo Power Users possono installare driver di stampante di terze parti nel computer client con sistema operativo Windows XP SP1. È possibile che si verifichino problemi nell'installazione di un driver della stampante di terze parti in un computer con sistema operativo Windows XP SP1 se il computer con Windows XP SP1 fa parte di un gruppo di lavoro o fa parte di un dominio basato su Microsoft Windows 2000.

In Windows Server 2003, non è possibile installare localmente una stampante di rete condivisa se il driver della stampante installato nel server di stampa utilizza driver della stampante in modalità kernel di terze parti. Un'impostazione dei criteri in Windows Server 2003 impedisce agli utenti di installare stampanti che utilizzano driver di stampa in modalità kernel di terze parti.

Questo problema può verificarsi anche in presenza delle seguenti condizioni:

  • La ricerca della zona inversa DNS non è configurata.
  • DNS non è configurato correttamente nel server di stampa.
  • Problemi DNS nel server di stampa.

Risoluzione

Per risolvere questo problema, modificare le impostazioni di Criteri di gruppo per l'oggetto Criteri di gruppo (GPO) che dispone di criteri stampante definiti per gli utenti di dominio nel controller di dominio. A tale scopo, utilizzare uno dei seguenti metodi.

Metodo 1

  1. Configurare l'impostazione del criterio Caricamento/rimozione di driver di dispositivo per il gruppo Power Users. A tal fine, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Programmi, Strumenti di amministrazione e infine Utenti e computer di Active Directory.
    2. Nel pannello di navigazione fare clic con il pulsante destro del mouse sul proprio dominio, quindi fare clic su Proprietà.
    3. Fare clic sulla scheda Criteri di gruppo, selezionare l'oggetto Criteri di gruppo desiderato, quindi fare clic su Modifica.
    4. Nell'Editor oggetti Criteri di gruppo individuare e fare clic sulla cartella Configurazione computer\Impostazioni di Windows\Sicurezza Impostazioni\Criteri locali\Assegnazione diritti utente.
    5. Individuare e quindi fare doppio clic su Caricamento/rimozione di driver di dispositivo.
    6. Fare clic per selezionare la casella di controllo Definisci le impostazioni relative ai criteri e quindi fare clic su sul gruppo di dominio Aggiungere utente o gruppo ai Power Users.
    7. Nella finestra di dialogo Aggiungi utente o gruppo fare clic sul gruppo di dominio Sfoglia per individuare Power Users. In Immettere i nomi degli oggetti da selezionare digitare Power Users e quindi fare clic su Controlla nomi per risolvere il nome del gruppo. Cliccare tre volte su OK.
  2. Disattivare il criterio Non consentire installazione di stampanti che utilizzano driver in modalità kernel. A tal fine, attenersi alla seguente procedura:
    1. Nel riquadro sinistro individuare e fare clic sulla cartella Configurazione computer\Modelli amministrativi\Stampanti.
    2. Individuare e fare doppio clic su Non consentire installazione di stampanti che utilizzano driver in modalità kernel, fare clic su Disabilitato e quindi su OK.
  3. Disabilitare il criterio Restrizioni di selezione e stampa. A tal fine, attenersi alla seguente procedura:
    1. Nel riquadro sinistro individuare e fare clic sulla cartella Configurazione utente\Modelli amministrativi\Pannello di controllo\Stampanti.
    2. Individuare e quindi fare doppio clic su Restrizioni di selezione e stampa, fare clic su Disabilitato e quindi su OK.
  4. Scegliere Esci dal menu File.
  5. Fare clic su Start>Esegui, digitare cmd.exe, quindi fare clic su OK.
  6. Al prompt dei comandi digitare gpupdate /force, quindi premere INVIO.
  7. Ripetere i passaggi da 5 a 6 nei computer client con sistema operativo Windows XP SP1 e Windows Server 2003 del dominio.

Metodo 2

  1. Sul server di stampa con sistema operativo Windows Server 2003 fare clic sul pulsante Start>Esegui, digitare Cmd e quindi fare clic su OK.

  2. Al prompt dei comandi digitare C:\, quindi premere INVIO.

  3. Digitare Cd\, quindi premere INVIO.

  4. Digitare Ipconfig /all, quindi premere INVIO.

  5. Annotare l'indirizzo IP del computer server di stampa.

    Nota

    L'output del Ipconfig /all comando può essere simile al seguente:

    Configurazione IP di Windows
    Nome host . . . . . . . . . . . . : NomeComputer
    Suffisso DNS primario . . . . . . . : DomainName.com
    Elenco di ricerca suffissi DNS. . . . . . : DomainName.com
    Scheda Ethernet LAN:
    Indirizzo IP. . . . . . . . . . . . : 169.0.0.10
    Subnet Mask . . . . . . . . . . . : 255.255.252.0
    Server DNS . . . . . . . . . . . : 169.0.0.1 169.0.0.2 169.0.0.3

  6. Nel computer client con sistema operativo Windows XP, fare clic sul pulsante Start>Esegui, digitare Cmd e quindi fare clic su OK.

  7. Al prompt dei comandi digitare C:\, quindi premere INVIO.

  8. Digitare Cd\, quindi premere INVIO.

  9. Digitare Nslookup PrintServer_IP, quindi premere INVIO.

    Nota

    PrintServer_IP è l'indirizzo IP annotato nel passaggio 5.

  10. Verificare che l'output del comando NsLookup contenga il nome di dominio completo (FQDN) corretto del server di stampa. Se non è corretto, è necessario contattare l'amministratore di rete per risolvere il problema di DNS.

Ulteriori informazioni

Quando si disabilita il criterio Restrizioni di selezione e stampa disponibile in Configurazione utente\Modelli amministrativi\Pannello di controllo\Stampanti, gli utenti possono utilizzare la funzionalità Selezione e stampa per selezionare qualsiasi stampante condivisa a cui hanno accesso.

Come utilizzare il Registro di sistema per impostare il criterio Restrizioni di selezione e stampa

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni sull'esecuzione del backup e del ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows

Il criterio Restrizioni di selezione e stampa può essere impostato anche nella sottochiave del Registro di sistema seguente:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint
Valore: InForest
Digitare: REG_DWORD
Valore dati: 0 or 1

L'impostazione del valore 0 disabilita questa voce. L'impostazione del valore 1 limita l'accesso delle stampanti alle stampanti nella foresta.

Valore: Limitato
Digitare: REG_DWORD
Valore dati: 0 or 1

L'impostazione del valore 0 disabilita questa voce. L'impostazione del valore 1 limita tutte le stampanti.

Valore: TrustedServers
Digitare: REG_DWORD
Valore dati: 0 or 1

L'impostazione del valore 0 disabilita questa voce. L'impostazione del valore 1 consente la visualizzazione delle stampanti nella finestra di dialogo dell'elenco dei server.

Per ulteriori informazioni su problemi relativi all'installazione della stampante, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

282011 driver della stampante non è compatibile se nel computer è abilitato un criterio

Supporto tecnico per le versioni x64 di Microsoft Windows

Il produttore dell'hardware offre supporto tecnico e assistenza per le versioni x64 di Microsoft Windows se il sistema viene fornito con una versione x64 di Microsoft Windows già installata. In questo caso il supporto e l'assistenza tecnica per tale software vengono forniti direttamente dalla casa produttrice dell'hardware. Il produttore dell'hardware potrebbe infatti avere personalizzato l'installazione della versione x64 di Windows con componenti univoci, quali specifici driver di periferica o impostazioni facoltative, per ottimizzare le prestazioni dell'hardware. Microsoft si impegna a prendere tutte le misure necessarie per offrire assistenza tecnica con la versione x64 di Windows. ma potrebbe essere necessario contattare direttamente il produttore dell'hardware, in quanto soggetto più qualificato per fornire supporto per il software preinstallato nell'hardware. Se è stata acquistata separatamente dall'hardware una versione x64 di Windows, ad esempio la versione x64 di Microsoft Windows Server 2003, contattare Microsoft per ottenere il supporto tecnico.

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando il TSS per i problemi relativi all'esperienza utente.