共有ネットワーク プリンターをインストールしようとするとエラー メッセージが表示される

この記事では、共有ネットワーク プリンターを Windows Server または Windows ベースのコンピューターにローカルでインストールできない問題について説明します。

適用対象: Windows 10 - すべてのエディション、Windows Server 2012 R2
元の KB 番号: 888046

現象

共有ネットワーク プリンターをインストールしようとすると、次の条件が当てはまる場合に現象が発生します。

  • Microsoft Windows 2000 Advanced Server ベースのプリント サーバーにインストールされている共有ネットワーク プリンターがあります。

  • Windows ドメインの一部であるコンピューターに共有ネットワーク プリンターをローカルでインストールしようとしています。

  • 次のいずれかのオペレーティング システムを実行しているコンピューターに、共有ネットワーク プリンターをローカルでインストールしようとしています。

    • Windows XP Service Pack 1 (SP1)
    • Windows Server 2003

このシナリオでは、共有ネットワーク プリンターをインストールしようとすると、次の現象が発生します。

  • プリンターの追加ウィザードを使用するか、 \\PrintServerName\PrinterShareName の場所のプリンター共有名を使用して、Windows XP SP1 ベースのクライアントにプリンターをインストールしようとすると、次のエラー メッセージが表示されます。

    ポリシー設定が原因で、この印刷キューに接続できません。 システム管理者に問い合わせてください。

  • プリンターの追加ウィザードを使用して Windows Server 2003 ベースのクライアントにプリンターをインストールしようとする場合、[完了] をクリックしてプリンターのインストールを完了すると、次のエラー メッセージが表示されます。

    プリンターをインストールできませんでした。 このコンピュータのポリシーが Windows NT 4.0 ドライバをブロックするように設定されているため、このプリンタ ドライバを使用することができません。 このドライバを使用する場合は、このポリシーを無効にするようシステム管理者に連絡してください。

原因

この問題は、プリント サーバーにインストールされているプリンター ドライバーがサード パーティのプリンター ドライバーである場合に発生します。 通常のユーザーまたは Power Users グループのメンバーである場合、サード パーティのプリンター ドライバーを備えた共有ネットワーク プリンターを Windows XP SP1 ベースのコンピューターにローカルでインストールすることはできません。 Windows XP SP1 では、通常のユーザーまたは Power Users グループのメンバーがサード パーティのドライバーをインストールすることはできません。 Windows XP SP1 では、サード パーティのドライバーをインストールするアクセス許可を持っているのは次のユーザーだけです。

  • ローカル管理者
  • Administrators グループのメンバー
  • デバイス ドライバーのロードとアンロード ポリシーのアクセス許可を持つ Power Users グループのメンバー

Windows XP SP1 ベースのコンピューターが Microsoft Windows NT 4.0 ベースのドメインに参加している場合、通常のユーザーと Power Users グループのメンバーは、サード パーティのプリンター ドライバーを Windows XP SP1 ベースのクライアント コンピューターにインストールできます。 Windows XP SP1 ベースのコンピューターがワークグループの一部または Microsoft Windows 2000 ベースのドメインの一部である場合、Windows XP SP1 ベースのコンピューターにサード パーティのプリンター ドライバーをインストールする際に問題が発生する可能性があります。

Windows Server 2003 では、プリント サーバーにインストールされているプリンター ドライバーがサード パーティのカーネル モード プリンター ドライバーを使用している場合、共有ネットワーク プリンターをローカルでインストールすることはできません。 Windows Server 2003 のポリシー設定により、ユーザーはサード パーティのカーネル モードのプリント ドライバーを使用するプリンターをインストールできなくなります。

この問題は、以下の条件が当てはまる場合にも発生することがあります。

  • DNS 逆引きゾーン ルックアップが構成されていません。
  • プリント サーバーで DNS が正しく構成されていません。
  • DNS の問題がプリント サーバーにあります。

解決方法

この問題を解決するには、ドメイン コントローラーのドメイン ユーザーに対してプリンター ポリシーが定義されているグループ ポリシー オブジェクト (GPO) のグループ ポリシー設定を変更します。 それには、以下のいずれかの方法を使用します。

方法 1

  1. Power Users グループのデバイス ドライバーのロードとアンロードのポリシー設定を構成します。 これを行うには、次の手順を実行します。
    1. [スタート] ボタンをクリックして、[プログラム]、[管理ツール] の順にポイントし、[Active Directory ユーザーとコンピューター] をクリックします。
    2. ナビゲーション ウィンドウで、ドメイン名を右クリックし、[プロパティ] をクリックします。
    3. [グループ ポリシー] タブをクリックし、変更する GPO をクリックして、[編集] をクリックします。
    4. グループ ポリシー オブジェクト エディターで、Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment フォルダーを見つけてクリックします。
    5. [デバイス ドライバのロードとアンロード] をダブルクリックします。
    6. [これらのポリシーの設定を定義する] チェックボックスをオンにして、[ユーザーまたはグループを追加して Power Users を追加する] ドメイン グループをクリックします。
    7. [ユーザーまたはグループの追加] ダイアログ ボックスで、[Power Users を見つけるために参照する] ドメイン グループをクリックします。 [選択するオブジェクト名を入力してください] に「Power Users」と入力し、[名前の確認] をクリックしてグループ名を解決します。 [OK] を 3 回クリックします。
  2. [カーネル モードのドライバーを使用しているプリンターのインストールを禁止する] ポリシーをオフにします。 これを行うには、次の手順を実行します。
    1. 左側のウィンドウで、Computer Configuration\Administrative Templates\Printers フォルダーを見つけてクリックします。
    2. [カーネル モードのドライバーを使用しているプリンターのインストールを禁止する] を見つけてダブルクリックし、[無効] をクリックして、[OK] をクリックします。
  3. [ポイント アンド プリントの制限] ポリシーを無効にします。 これを行うには、次の手順を実行します。
    1. 左側のウィンドウで、User Configuration\Administrative Templates\Control Panel\Printers フォルダーを見つけてクリックします。
    2. [ポイント アンド プリントの制限] を見つけてダブルクリックし、[無効] をクリックして、[OK] をクリックします。
  4. [ファイル] メニューの [終了] をクリックします。
  5. [スタート]、[ファイル名を指定して実行] の順にクリックし、「cmd.exe」と入力して、[OK] をクリックします。
  6. コマンド プロンプトで「gpupdate /force」と入力し、Enter キーを押します。
  7. ドメインの Windows XP SP1 ベースおよび Windows Server 2003 ベースのクライアント コンピューターで、手順 5 〜 6 を繰り返します。

方法 2

  1. Windows Server 2003 ベースのプリント サーバーでは、[スタート]、[ファイル名を指定して実行] の順にクリックし、「Cmd」と入力して、[OK] をクリックします。

  2. コマンド プロンプトで 「C:\」と入力し、Enter キーを押します。

  3. 「Cd\」と入力し、Enter キーを押します。

  4. Ipconfig /all」と入力し、Enter キーを押します。

  5. プリント サーバー コンピューターの IP アドレスを書き留めます。

    注:

    Ipconfig /all コマンドの出力は、次のようになります。

    Windows IP 構成
    ホスト名. . . . . . . . . . . . : MachineName
    プライマリ DNS サフィックス. . . . . . . : DomainName.com
    DNS サフィックス検索リスト. . . . . . : DomainName.com
    イーサネット アダプター LAN:
    IP アドレス. . . . . . . . . . . . : 169.0.0.10
    サブネット マスク. . . . . . . . . . . : 255.255.252.0
    DNS サーバー. . . . . . . . . . . : 169.0.0.1 169.0.0.2 169.0.0.3

  6. Windows XP ベースのクライアント コンピューターで、[スタート]、[ファイル名を指定して実行] の順にクリックし、「Cmd」と入力して、[OK] をクリックします。

  7. コマンド プロンプトで 「C:\」と入力し、Enter キーを押します。

  8. 「Cd\」と入力し、Enter キーを押します。

  9. 「Nslookup PrintServer_IP」と入力し、Enter キーを押します。

    注:

    PrintServer_IP は、手順 5 で書き留めた IP アドレスです。

  10. NsLookup コマンドの出力に、プリント サーバーの正しい完全修飾ドメイン名 (FQDN) が含まれていることを確認します。 正しくない場合は、ネットワーク管理者に連絡して DNS の問題を解決する必要があります。

詳細

User Configuration\Administrative Templates\Control Panel\Printers の下にある [ポイント アンド プリントの制限] ポリシーを無効にすると、ユーザーはポイント アンド プリント機能を使用して、アクセスできる共有プリンターを選択できます。

レジストリを使用して [ポイント アンド プリントの制限] ポリシーを設定する方法

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法

[ポイント アンド プリントの制限] ポリシーは、次のレジストリ サブキーで設定することもできます。

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint
値: InForest
種類: REG_DWORD
値: 0 または 1

0 に設定すると、このエントリは無効になります。 1 に設定すると、フォレスト内のプリンターへのプリンター アクセスが制限されます。

値: 制限付き
種類: REG_DWORD
値: 0 または 1

0 に設定すると、このエントリは無効になります。 1 に設定すると、すべてのプリンターが制限されます。

値: TrustedServers
種類: REG_DWORD
値: 0 または 1

0 に設定すると、このエントリは無効になります。 1 に設定すると、プリンターがサーバー リスト ダイアログ ボックスに表示されます。

プリンターのインストールに関連する問題の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を参照してください。

282011「コンピューターでポリシーが有効になっている場合、プリンター ドライバーは互換性がない」

x64 ベースの Microsoft Windows のテクニカル サポート

ハードウェアにあらかじめ Microsoft Windows x64 エディションがインストールされていた場合、Windows x64 エディションのテクニカル サポートと支援はハードウェアの製造元から提供されます。 つまり、Windows x64 エディションをハードウェアにインストールしたハードウェアの製造元がサポートを提供します。 ハードウェアの製造元は、独自のコンポーネントを使用して Windows x64 エディションのインストール環境をカスタマイズしている場合があります。 独自のコンポーネントとして特定のデバイス ドライバーが組み込まれていることや、ハードウェアのパフォーマンスを最大限に発揮させるためのオプション設定が組み込まれていることがあります。 Windows x64 エディションに関するテクニカル サポートが必要な場合、マイクロソフトではできる限りの支援を行います。 しかし、製造元がハードウェアにインストールして提供するソフトウェアについては製造元によるサポートが最適であるため、 ハードウェアの製造元に直接お問い合わせいただくことが必要な場合があります。 Microsoft Windows Server 2003 x64 Edition など、Windows x64 エディションを個別に購入した場合、テクニカル サポートについてはマイクロソフトにお問い合わせください。

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