Mensagem de erro quando tenta instalar uma impressora de rede compartilhada

Este artigo descreve um problema em que você não consegue instalar uma impressora de rede compartilhada localmente em um Windows Server ou em um computador baseado em Windows.

Aplica-se a: Windows 10 — todas as edições, Windows Server 2012 R2
Número original do KB: 888046

Sintomas

Se você tentar instalar uma impressora de rede compartilhada, você verá sintomas se as seguintes condições forem verdadeiras:

  • Você tem uma impressora de rede compartilhada instalada em um servidor de impressão do Microsoft Windows 2000 Advanced Server.

  • Você tenta instalar a impressora de rede compartilhada localmente em um computador que faz parte de um domínio do Windows.

  • Você tenta instalar a impressora de rede compartilhada localmente em um computador que está executando um dos seguintes sistemas operacionais:

    • Windows XP Service Pack 1 (SP1)
    • Windows Server 2003

Nesse cenário, você verá os seguintes sintomas se tentar instalar uma impressora de rede compartilhada:

  • Se você tentar instalar a impressora em um cliente baseado em Windows XP SP1 usando o Assistente para Adicionar Impressora ou usando o nome de compartilhamento de impressora no local \\PrintServerName\PrinterShareName você receberá a seguinte mensagem de erro:

    Uma política está em vigor no computador, o que impede que você se conecte a essa fila de impressão. Entre em contato com o administrador do sistema.

  • Se você usar o Assistente para Adicionar Impressora para tentar instalar a impressora em um cliente baseado no Windows Server 2003, receberá a seguinte mensagem de erro ao clicar em Concluir para terminar a instalação da impressora:

    Não é possível instalar a impressora. O driver de impressora não é compatível com uma política habilitada em seu computador que bloqueia as drivers do Windows NT 4.0. Se você quiser usar esse driver, entre em contato com o administrador do sistema sobre como desabilitar essa política.

Motivo

Esse problema ocorrerá se o driver de impressora instalado no servidor de impressão for um driver de impressora de terceiros. Não é possível instalar uma impressora de rede compartilhada que tenha um driver de impressora de terceiros localmente em um computador baseado no Windows XP SP1 se você for um usuário comum ou membro do grupo Usuários Avançados. O Windows XP SP1 não permite que usuários comuns ou membros do grupo Usuários Avançados instalem drivers de terceiros. No Windows XP SP1, somente as seguintes pessoas têm permissão para instalar um driver de terceiros:

  • Administrador local
  • Membros do grupo Administradores
  • Membros do grupo Usuários Avançados que têm as permissões de política Carregar e descarregar drivers do dispositivo

Se o computador baseado no Windows XP SP1 estiver associado a um domínio baseado no Microsoft Windows NT 4.0, os usuários comuns e membros do grupo Usuários Avançados poderão instalar drivers de impressora de terceiros no computador de cliente baseado no Windows XP SP1. Você pode ter problemas na instalação de um driver de impressora de terceiros em um computador baseado no Windows XP SP1 se o computador baseado no Windows XP SP1 fizer parte de um grupo de trabalho ou parte de um domínio baseado no Microsoft Windows 2000.

No Windows Server 2003, você não pode instalar uma impressora de rede compartilhada localmente se o driver de impressora instalado no servidor de impressão usar drivers de impressora de modo kernel de terceiros. Uma configuração de política no Windows Server 2003 impede que os usuários instalem impressoras que usam drivers de impressão de modo kernel de terceiros.

Este problema também pode ocorrer se as seguintes condições forem verdadeiras:

  • A procura de zona inversa de DNS não está configurada.
  • O DNS é configurado incorretamente no servidor de impressão.
  • Problemas de DNS no servidor de impressão.

Resolução

Para resolver esse problema, modifique as configurações da Política de Grupo para o objeto de Política de Grupo (GPO) que tem políticas de impressora definidas para os usuários de domínio no controlador de domínio. Para fazer isso, utilize um dos métodos seguintes.

Método 1

  1. Configure a configuração de política Carregar e descarregar drivers do dispositivo para o grupo Usuários Avançados. Para fazer isso, siga estas etapas:
    1. Clique em Iniciar, aponte para Programas, Ferramentas administrativas e clique em Usuários e computadores do Active Directory.
    2. No painel de navegação, clique com o botão direito do mouse no nome de seu domínio e clique em Propriedades.
    3. Clique na guia Política do Grupo, clique no GO que deseja modificar e clique em Editar.
    4. No Editor de Objeto da Política de Grupo, localize e clique na pasta Configuração do Computador\Configurações do Windows\Configurações de Segurança\Políticas Locais\Atribuição de Direitos do Usuário.
    5. Localize e clique duas vezes em Carregar e descarregar drivers do dispositivo.
    6. Clique para selecionar a caixa de seleção Definir essas configurações de política e clique em Adicionar Usuário ou Grupo para adicionar o grupo de domínio Usuários Avançados.
    7. Na caixa de diálogo Adicionar Usuário ou Grupo, clique em Procurar para localizar o grupo de domínio Usuários Avançados. Em Introduzir os nomes do objeto para selecionar, digite Usuários Avançados, e clique em Verificar nomes para resolver o nome do grupo. Clique em OK três vezes.
  2. Desativar o Não permitir instalação de impressoras usando a política de drivers no modo kernel. Para fazer isso, siga estas etapas:
    1. No painel esquerdo, localize e clique na pasta Configuração do Computador\Modelos Administrativos\Impressoras.
    2. Localize e clique duas vezes em Não permitir a instalação de impressoras usando drivers de modo kernel, clique em Desabilitado e clique em OK.
  3. Desabilite a política Restrições de ponto e impressão. Para fazer isso, siga estas etapas:
    1. No painel esquerdo, localize e clique na pasta Configuração do Usuário\Modelos Administrativos\Painel de Controle\Impressoras.
    2. Localize e clique duas vezes em Restrições de ponto e Impressão, clique em Desabilitado e clique em OK.
  4. No menu Arquivo, clique em Sair.
  5. Clique em Iniciar>, em Executar, digite cmd.exe e depois clique em OK.
  6. No prompt de comando, digite gpupdate /force e pressione ENTER.
  7. Repita as etapas de 5 a 6 nos computadores de cliente baseado no Windows XP SP1 e Windows server 2003 baseados no domínio.

Método 2

  1. No servidor de impressão baseado no Windows Server 2003, clique em Iniciar>, clique em Executar, digite Cmd e depois clique em OK.

  2. No prompt de comando, digite C:\ e pressione ENTER.

  3. Digite Cd\ e pressione ENTER.

  4. Digite Ipconfig /all e pressione ENTER.

  5. Anote o endereço IP do computador do servidor de impressão.

    Observação

    A saída do comando Ipconfig /all pode ser semelhante à seguinte:

    Configuração do IP Windows
    Nome do host . . . . . . . . . . . . : MachineName
    Sufixo DNS primário . . . . . . . : DomainName.com
    Lista de pesquisa de sufixo DNS. . . . . . : DomainName.com
    LAN de adaptador Ethernet:
    Endereço IP. . . . . . . . . . . . : 169.0.0.10
    Máscara de sub-rede . . . . . . . . . . . : 255.255.252.0
    Servidores DNS . . . . . . . . . . . : 169.0.0.1 169.0.0.2 169.0.0.3

  6. No computador cliente com base no Windows XP, clique em Iniciar>, clique em Executar, digite Cmd e depois clique em OK.

  7. No prompt de comando, digite C:\ e pressione ENTER.

  8. Digite Cd\ e pressione ENTER.

  9. Digite Nslookup PrintServer_IP e pressione ENTER.

    Observação

    PrintServer_IP é o endereço IP que você anotou na etapa 5.

  10. Certifique-se de que a saída do comando NsLookup contenha o FQDN (nome de domínio totalmente qualificado) correto do servidor de impressão. Se estiver incorreto, entre em contato com o administrador de rede para resolver o problema de DNS.

Mais informações

Quando você desabilita a política de Restrições de Ponto e Impressão localizada em Configuração do Usuário\Modelos Administrativos\Painel de Controle\Impressoras, os usuários podem usar a funcionalidade Ponto e Impressão para selecionar qualquer impressora compartilhada à qual tenham acesso.

Como usar o registro para definir a política de Restrições de Ponto e Impressão

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como fazer o backup e a restauração do Registro no Windows

A política de Restrições de Ponto e Impressão também pode ser definida sob a seguinte subchave do registro:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint
Valor: InForest
Tipo: REG_DWORD
Dados: 0 ou 1

Uma configuração de 0 desabilita esta entrada. Uma configuração de 1 restringe o acesso da impressora a impressoras na floresta.

Valor: Restrito
Tipo: REG_DWORD
Dados: 0 ou 1

Uma configuração de 0 desabilita esta entrada. Uma configuração de 1 restringe todas as impressoras.

Valor: TrustedServers
Tipo: REG_DWORD
Dados: 0 ou 1

Uma configuração de 0 desabilita esta entrada. Uma configuração de 1 permite que as impressoras apareçam na caixa de diálogo da lista de servidores.

Para obter informações adicionais sobre problemas de instalação de impressora, clique no número abaixo para ler o respectivo artigo na Base de Dados de Conhecimento Microsoft:

282011 O driver da impressora não é compatível se uma política estiver habilitada em seu computador

Suporte técnico para versões do Microsoft Windows com base em x64

Se o hardware já vier com uma edição de x64 do Microsoft Windows instalada, o fabricante do hardware fornecerá assistência técnica e suporte para as versões com base em x64 do Microsoft Windows. Nesse caso, ele oferece suporte porque uma edição de x64 do Windows foi incluída no hardware. O fabricante também pode ter personalizado a instalação da edição x64 do Windows, usando componentes exclusivos. O fabricante pode incluir drivers de dispositivos específicos ou configurações opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se você precisar de ajuda técnica com uma edição x64 do Windows. No entanto, pode ser necessário contatar diretamente o fabricante. O fabricante é o mais qualificado para dar suporte ao software instalado no hardware. Se você comprou separadamente uma edição x64 do Windows, como o Microsoft Windows Server 2003 x64, contate a Microsoft para obter suporte técnico.

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