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Symptoms

After you configure Microsoft Internet Security and Acceleration (ISA) Server 2004 to filter HTTP content based on signatures or on extensions, users in your organization experience the following symptom.

When a user visits certain URLs, that user receives the following error message in the Web browser:

Error Code 502: Proxy error. The parameter is incorrect. (87)

If you remove all signatures and extensions from the HTTP Filter settings, and if you configure the HTTP Filter component to allow all signatures and extensions, you no longer experience this problem.

Note For more information about how to configure the ISA Server 2004 HTTP Filter component, see the "More Information" section.

Cause

This problem occurs because of a problem in the ISA Server 2004 HTTP Security Filter component. This component is named HTTPFilter.dll.

Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891024 How to obtain the latest ISA Server 2004 service pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

If you are running ISA Server 2004, Standard Edition, you must have ISA Server 2004 Service Pack 1 installed to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891024 How to obtain the latest ISA Server 2004 service pack

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

ISA Server 2004, Standard Edition
   Date         Time   Version       Size     File name
---------------------------------------------------------
31-Mar-2005 18:22 4.0.2163.251 120.320 HTTPFilter.dll
ISA Server 2004, Enterprise Edition
   Date         Time   Version       Size     File name
---------------------------------------------------------
03-Apr-2005 14:00 4.0.3440.251 128.792 HTTPFilter.dll

Workaround

To work around this problem, configure the options on the Signatures tab and on the Extensions tab of the HTTP Filter settings. To do this, follow these steps:

  1. Remove all the signatures and extensions that are listed on these tabs.

  2. Configure the HTTP Filter to allow all signatures and extensions.

For more information about how to configure the ISA Server 2004 HTTP Filter component, see the "More Information" section.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

More Information

To configure the ISA Server 2004 HTTP Filter component to block or to allow all signatures and extensions for HTTP traffic, follow these steps:

  1. Click Start, point to All Programs, point to Microsoft ISA Server, and then click ISA Server Management.

  2. In the left pane, expand ServerName, where ServerName is the name of the computer that is running ISA Server.

    Note If you are running ISA Server 2004, Enterprise Edition, expand Arrays in the left pane, and then expand ServerName.

  3. Click Firewall Policy.

  4. In the center pane, right-click the access rule that you want to configure, and then click Configure HTTP.

  5. In the Configure HTTP policy for rule dialog box, take one of the following actions:

    • To configure content blocking for content that contains certain signatures, click the Signatures tab.

    • To configure content blocking for content that contains certain extensions, click the Extensions tab.

  6. Configure the options on the Signatures tab or on the Extensions tab to allow or to block the content that you want, and then click OK.

  7. Click Apply to save your changes to the firewall policy, and then click OK.

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

885957 How to install ISA Server hotfixes and updates

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