Budete přesměrováni na přihlašovací stránku nebo chybovou stránku nebo se zobrazí výzva k zadání ověřovacích informací po kliknutí na hypertextový odkaz na web jednotného přihlašování v dokumentu Office.

Příznaky

Když kliknete na hypertextový odkaz v dokumentu Microsoft Office, můžete před otevřením požadované stránky zaznamenat následující chování:

  • Budete přesměrováni na přihlašovací stránku nebo chybovou stránku.
  • Zobrazí se výzva k zadání ověřovacích informací.

K tomuto chování obvykle dochází, pokud jsou splněny následující podmínky:

  • Dokument Office otevřete v režimu úprav mimo webový prohlížeč.
  • Web v hypertextovém odkazu používá ověřovací systém jednotného Sign-On (SSO), který se při identifikaci klienta spoléhá na soubory cookie relace HTTP. I když jste už zadali přihlašovací údaje uživatele, zobrazí se výzva k opětovnému zadání přihlašovacích údajů uživatele.

Příčina

Office umožňuje upravovat a vytvářet dokumenty na webu, pokud server podporuje vytváření webů a spolupráci. Nejprve se Office pokusí komunikovat s webovým serverem. Pak se Office pokusí vytvořit vazbu k prostředku přímo pomocí knihovny Microsoft Hyperlink Library (Hlink.dll) a rozhraní URLMON API.

Když Office odešle požadavek na webovou stránku, můžete být přesměrováni na přihlašovací stránku webu pro systém jednotného přihlašování. K tomuto chování dochází, protože relace Sady Office je nezávislá na relaci webového prohlížeče, ve které jste již pravděpodobně zadali přihlašovací údaje uživatele.

Vzhledem k tomu, že relace jsou nezávislé, soubory cookie relací se nesdílí. Pokud se systém jednotného přihlašování spoléhá výhradně na informace o souborech cookie relace, může se zdát, že systém jednotného přihlašování nefunguje, protože stejný uživatel přechází z více než jedné relace. Toto chování představuje základní omezení návrhu systému jednotného přihlašování, pokud systém jednotného přihlašování není navržen tak, aby podporoval ověřování jednotného přihlašování ve více prohlížečích nebo webových aplikacích na klientské ploše. Vzhledem k tomu, že Office je aplikace plně pracující s webem, může se problém zdát jedinečný pro aplikace Office, pokud se jedná o jediné webové klienty nainstalované klientem. Původní příčina tohoto problému však není omezena na Microsoft Office a k tomuto problému může dojít, když používáte software jiného výrobce.

Řešení

Problémem je omezení systému jednotného přihlašování, který používá webový server. Pomocí některé z následujících metod však můžete snížit aktuální účinky na web chráněný jednotným přihlašováním.

Pokud k tomuto problému dochází, když hypertextové odkazy na webové stránce otevřou soubor Office a webová stránka je hostovaná v Internet Exploreru, můžete se tomuto problému vyhnout tím, že obsah explicitně označíte jako stažený soubor jen pro čtení místo jako vloženou navigaci.

Uděláte to tak, že do odpovědi GET pro obsah souboru Office přidáte vlastní hlavičku HTTP. Přidejte hlavičku Content-Disposition: Attachment. Pokud odpověď GET obsahuje tuto hlavičku, Internet Explorer vyzve uživatele k otevření nebo uložení staženého souboru. Pokud se uživatel rozhodne soubor otevřít, otevře se soubor z mezipaměti dočasných souborů aplikace Internet Explorer jen pro čtení. Uživatel se může rozhodnout soubor upravit a uložit místně. Uživatel však nebude moci soubor uložit na server nebo spolupracovat s webovými službami pro daný web. Proto toto řešení funguje pouze v případě, že chcete soubor nastavit jen pro čtení.

Hlavičku Content-Disposition můžete nastavit pomocí kódu v microsoft active serverových stránkách (ASP), v Microsoft ASP.NET nebo v ROZHRANÍ ISAPI při práci s dynamicky generovaným obsahem. Pokud je obsah statický, můžete nakonfigurovat hlavičku pro daný soubor nebo složku pomocí Správce služby IIS a metabáze služby IIS. Další informace o hlavičce HTTP Content-Disposition najdete v tématu How to raise a File Download dialog box for a known MIME type.

Pokud k tomuto problému dochází při kliknutí na hypertextové odkazy v dokumentech Office, které buď přímo otevřou webový obsah HTML, nebo jsou přesměrovány na obsah HTML, můžou se uživatelé klienta vyhnout tomuto problému tím, že povolíte klíč registru pro odesílání navigace hypertextovými odkazy do prohlížeče místo přímé vazby na hypertextový odkaz z Office. Další informace najdete v tématu Chybová zpráva při kliknutí na hypertextový odkaz v Office: Nejde najít internetový server nebo proxy server.

Poznámka

Bez ohledu na nainstalovanou verzi Office přidejte klíč registru přesně do umístění zadaného v části Chybová zpráva při kliknutí na hypertextový odkaz v Office: "Nelze najít internetový server nebo proxy server".

Když použijete toto nastavení registru, komponenta HLINK, kterou používá Office, otevře hypertextový odkaz ve výchozím webovém prohlížeči. Toto nastavení registru ovlivňuje všechny klienty HLINK, nejen Office. Proto tento klíč registru používejte pečlivě.

Další informace

Pokud chcete tento problém plně vyřešit, doporučujeme poskytovatelům jednotného přihlašování vyvinout systém, který by mohl umožnit vytváření webů, a klienta, který používá více relací. Tato konfigurace zvyšuje složitost systému jednotného přihlašování. Tato konfigurace ale také klientům nabízí nejvíce možností použitelnosti. Microsoft v současné době spolupracuje s klíčovými poskytovateli jednotného přihlašování na dlouhodobém řešení.

Microsoft navíc zkoumá, jak koncoví uživatelé používají Office k lepšímu predikci a správě následujících scénářů:

  • Uživatel má v úmyslu otevřít hypertextový odkaz v režimu jen pro čtení. V tomto scénáři se hypertextový odkaz otevře v režimu procházení.
  • Uživatel chce obsah upravit. V tomto scénáři se pro vytváření obsahu a spolupráci vyžaduje nová relace.

Tyto změny konfigurace můžou snížit dopad problému popsaného v části "Příznaky". Tyto změny také můžou uživateli dodat flexibilitu, když uživatel navštíví lokalitu jednotného přihlašování, která nepodporuje konfigurace zahrnující klienty s více relacemi.

Pokud jste návrhář nebo vývojář jednotného přihlašování, můžete přidat podporu pro klienty s více relacemi. Můžete například použít následující metody:

  • Pomocí trvalých informací o souborech cookie a informací o souborech cookie relací můžete identifikovat, kdy jeden klient prošel relacemi mezi aplikacemi na ploše. Potom zadejte webové odpovědi, které buď přenesou klienta zpět do jedné relace, nebo ověří novou relaci.

  • K vytvoření integrovaného ověřovacího systému použijte komponentu na straně klienta. Tento integrovaný ověřovací systém slouží k ověření všech procesů, které se spouští pod stejným ověřovacím tokenem uživatele.

  • K ověření klienta použijte certifikáty nebo jinou metodu identifikace rozšířenou o zabezpečení.

  • V případě požadavku HTTP, který může být žádostí klienta s více relacemi, vydejte odpověď přesměrování na straně klienta místo odpovědi přesměrování na straně serveru. Například místo odpovědi HTTP 302 odešlete skript HTTP nebo značku META REFRESH. Tato změna vynutí klienta zpět do výchozího webového prohlížeče uživatele. Proto výchozí relace prohlížeče může zpracovat volání a může ponechat volání v jedné relaci jen pro čtení.

    Tato metoda neumožňuje vytváření obsahu. Tato metoda však jasně vysvětluje, že systém jednotného přihlašování nezpracuje klienty s více relacemi a chce, aby klient zůstal pouze ve výchozí relaci prohlížeče.

Přesný přístup k této změně konfigurace závisí na vašich cílech návrhu a úrovni integrace, kterou chcete mít s klientskou plochou.