É redirecionado para uma página de início de sessão ou para uma página de erro ou são-lhe pedidas informações de autenticação quando clica numa hiperligação para um Web site do SSO num documento do Office

Sintomas

Quando clica numa hiperligação num documento do Microsoft Office, pode deparar-se com o seguinte comportamento antes de poder abrir a página que pediu:

  • É redirecionado para uma página de início de sessão ou uma página de erro
  • São-lhe pedidas informações de autenticação.

Normalmente, este comportamento ocorre quando as seguintes condições são verdadeiras:

  • Abra o documento do Office no modo de edição fora do browser.
  • O Web site na hiperligação utiliza um sistema de autenticação de Sign-On Único (SSO) que depende de cookies de sessão HTTP para identificação de cliente. Mesmo que já tenha fornecido credenciais de utilizador, ser-lhe-á pedido que forneça as credenciais de utilizador novamente.

Causa

O Office permite-lhe editar e criar documentos num Web site se o servidor suportar a criação e colaboração na Web. Primeiro, o Office tenta comunicar com o servidor Web. Em seguida, o Office tenta vincular-se diretamente ao recurso com a Biblioteca de Hiperligações da Microsoft (Hlink.dll) e a API URLMON.

Quando o Office envia o pedido de página Web, poderá ser redirecionado para a página de início de sessão do Web site do sistema SSO. Este comportamento ocorre porque a sessão do Office é independente da sessão do browser na qual pode já ter fornecido credenciais de utilizador.

Uma vez que as sessões são independentes, os cookies de sessão não são partilhados. Se o sistema SSO depender exclusivamente de informações de cookies de sessão, o sistema SSO poderá não parecer funcionar porque o mesmo utilizador passa de mais do que uma sessão. Este comportamento é uma limitação de conceção fundamental de um sistema SSO quando o sistema SSO não foi concebido para suportar a autenticação SSO em mais do que um browser ou aplicação com suporte para a Web no ambiente de trabalho do cliente. Uma vez que o Office é uma aplicação totalmente com suporte para a Web, o problema pode parecer exclusivo para as aplicações do Office se forem os únicos clientes com suporte para a Web que são instalados pelo cliente. No entanto, a causa principal deste problema não se limita ao Microsoft Office e este problema pode ocorrer quando utiliza software de terceiros.

Solução

O problema é uma limitação do sistema SSO que é utilizado pelo servidor Web. No entanto, poderá conseguir reduzir os efeitos atuais do Web site protegido por SSO através de um dos seguintes métodos.

Se este problema ocorrer quando as hiperligações numa página Web abrem um ficheiro do Office e a página Web está alojada no Internet Explorer, pode evitar este problema marcando explicitamente o conteúdo como uma transferência só de leitura em vez de como uma navegação inline.

Para tal, adicione um cabeçalho HTTP personalizado à resposta GET para os conteúdos dos ficheiros do Office. Adicione o cabeçalho "Content-Disposition: Attachment". Quando uma resposta GET contém este cabeçalho, o Internet Explorer pede ao utilizador para abrir ou guardar a transferência. Se o utilizador optar por abrir a transferência, o ficheiro é aberto a partir da cache de Ficheiro Temporário do Internet Explorer só de leitura. O utilizador pode optar por modificar e guardar o ficheiro localmente. No entanto, o utilizador não poderá guardar o ficheiro no servidor ou colaborar com serviços Web do Web site. Por conseguinte, esta solução só funciona se pretender tornar o ficheiro só de leitura.

Pode definir o cabeçalho "Content-Disposition" ao utilizar código nas Páginas do Microsoft Active Server (ASP), no Microsoft ASP.NET ou na ISAPI quando trabalha com conteúdo gerado dinamicamente. Se o conteúdo for estático, pode configurar o cabeçalho para um determinado ficheiro ou pasta com o Gestor do IIS e a metabase do IIS. Para obter mais informações sobre o cabeçalho HTTP Content-Disposition, consulte Como criar uma caixa de diálogo Transferência de Ficheiros para um tipo de MIME conhecido.

Se este problema ocorrer quando clica em hiperligações em documentos do Office que abrem diretamente conteúdo Web HTML ou são redirecionados para conteúdo HTML, os utilizadores cliente podem evitar o problema ao ativar uma chave de registo para enviar a navegação de hiperligação para o browser em vez de vincular diretamente à hiperligação a partir do Office. Para obter mais informações, consulte Mensagem de erro ao clicar em hiperligação no Office: "Não é possível localizar o servidor da Internet ou o servidor proxy".

Nota

Independentemente da versão do Office que tenha instalado, adicione a chave de registo na localização exata especificada na Mensagem de erro ao clicar na hiperligação no Office: "Não é possível localizar o servidor da Internet ou o servidor proxy".

Quando utiliza esta definição de registo, o componente HLINK utilizado pelo Office abre a hiperligação no browser predefinido. Esta definição de registo afeta todos os clientes HLINK e não apenas o Office. Por conseguinte, utilize cuidadosamente esta chave de registo.

Mais Informações

Para resolver totalmente este problema, incentivamos os fornecedores de SSO a desenvolver um sistema que possa permitir a criação da Web e um cliente que utilize múltiplas sessões. Esta configuração adiciona complexidade ao sistema SSO. No entanto, esta configuração também oferece aos clientes as opções de utilização mais elevadas. ATualmente, a Microsoft está a trabalhar com fornecedores principais de SSO para uma solução a longo prazo.

Além disso, a Microsoft está a investigar como os utilizadores finais utilizam o Office para prever e gerir melhor os seguintes cenários:

  • O utilizador pretende abrir uma hiperligação no modo só de leitura. Neste cenário, a hiperligação é aberta no modo de procura.
  • O utilizador quer modificar o conteúdo. Neste cenário, é necessária uma nova sessão para a criação e colaboração.

Estas alterações de configuração podem reduzir o efeito do problema descrito na secção "Sintomas". Estas alterações também podem adicionar flexibilidade ao utilizador quando o utilizador visita um site SSO que não suporta configurações que incluam clientes de várias sessões.

Se for um estruturador ou programador de SSO, pode adicionar suporte para clientes de várias sessões. Por exemplo, pode utilizar os seguintes métodos:

  • Utilize informações persistentes sobre cookies e informações de cookies de sessão para identificar quando um único cliente cruzou sessões entre aplicações no ambiente de trabalho. Em seguida, forneça respostas Web para transferir o cliente novamente para uma única sessão ou para autenticar a nova sessão.

  • Utilize um componente do lado do cliente para criar um sistema de autenticação integrado. Utilize este sistema de autenticação integrado para autenticar todos os processos iniciados no mesmo token de autenticação de utilizador.

  • Utilize certificados ou outro método de identificação persistente, avançado de segurança, para autenticar o cliente.

  • Para um pedido HTTP que possa ser um pedido de cliente de várias sessões, emita uma resposta de redirecionamento do lado do cliente em vez de uma resposta de redirecionamento do lado do servidor. Por exemplo, envie um script HTTP ou uma etiqueta META REFRESH em vez de uma resposta HTTP 302. Esta alteração força o cliente a voltar ao browser predefinido do utilizador. Por conseguinte, a sessão predefinida do browser pode processar a chamada e manter a chamada numa única sessão só de leitura.

    Este método não permite a criação. No entanto, este método deixa claro que o sistema SSO não processa clientes de várias sessões e quer que o cliente permaneça apenas na sessão de browser predefinida.

A abordagem exata a esta alteração de configuração depende dos seus objetivos de conceção e do nível de integração que pretende ter com o ambiente de trabalho do cliente.