증상
"적용 대상" 절에 나열 된 Microsoft 게임 중 하나를 시작 하려고 하면 다음 오류 메시지 중 하나가 나타납니다.
오류 메시지 1
D3dx9_25 파일을 찾을 수 없습니다.
오류 메시지 2
D3dx9_27 파일을 찾을 수 없습니다.
원인
이 문제는 오류 메시지에 언급 된 Microsoft DirectX 파일이 손상 되었거나 올바르게 복사 되지 않은 경우에 발생할 수 있습니다.
해결 방법
최신 버전의 DirectX를 다운로드 하 여 설치 합니다.
이 문제를 해결 하려면 최신 버전의 DirectX 최종 사용자 런타임 웹 설치 관리자를 다운로드 하 여 설치 합니다. 이렇게 하려면 다음 Microsoft 웹 사이트를 방문하세요.
http://www.microsoft.com/download/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en 참고 설치 중에 다음과 같은 오류 메시지가 나타날 수 있습니다.
설치하고 있는 소프트웨어는 현재 버전의 Windows와의 호환성 확인을 위한 Windows 로고 테스트를 통과하지 않았습니다. (이 테스트가 중요한 이유)
자세한 내용을 확인하려면 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
822798 일부 업데이트 또는 프로그램을 설치할 수 없음
수동으로 파일 복사
이 문제를 해결 하려면 게임 CD/DVD 팩의 디스크 1 CD/DVD에서 D3dx9_25 .dll 파일 또는 D3dx9_27 .dll 파일을 해당 게임 폴더에 복사 합니다. 이렇게 하려면 Windows 버전에 따라 적절 한 단계를 수행 합니다.
Windows 7 또는 Windows Vista
-
게임의 디스크 1 CD/DVD를 컴퓨터의 CD/DVD 드라이브에 삽입 합니다.
-
시작 클릭 를 선택한 다음 문서를 클릭 합니다.
-
컴퓨터를 찾아 클릭 합니다.
-
CD/DVD 드라이브를 찾아 클릭 합니다.
-
다음 폴더를 찾아 클릭 합니다.
CDDrive:\ DirectX9 참고 이 경로에서 Cddrive는 CD 드라이브의 드라이브 문자를 나타냅니다.
-
Apr2005_d3dx9_25_x86를 두 번 클릭 하 고 d3dx9_25 .dll을 마우스 오른쪽 단추로 클릭 한 다음 복사를 클릭 합니다.
참고 X64 기반 Windows 운영 체제 버전에 대 한 Apr2005_d3dx9_25_x64 .cab 파일을 사용 합니다.
-
게임에 사용할 다음 폴더를 찾습니다.
드라이브: a # Files\Microsoft 게임 \게임 제목 참고 이 경로에서 drive는 게임이 설치 된 드라이브 문자를 나타내고 게임 제목은 복구 하려는 게임을 나타냅니다.
-
컴퓨터에 설치 되어 있는 게임에 해당 하는 게임 폴더를 마우스 오른쪽 단추로 클릭 한 다음 붙여넣기를 클릭 합니다. 참고 컴퓨터에 여러 게임을 설치한 경우 다른 게임에 대해 7 ~ 8 단계를 반복 합니다.
Windows XP
-
게임의 디스크 1 CD/DVD를 컴퓨터의 CD/DVD 드라이브에 삽입 합니다.
-
시작을 클릭 하 고 프로그램을 가리킨 다음 보조 프로그램을 가리킨 다음 Windows 탐색기를 클릭 합니다.
-
다음 폴더를 찾아 클릭 합니다.
CDDrive:\ DirectX9 참고 이 경로에서 Cddrive는 CD 드라이브의 드라이브 문자를 나타냅니다.
-
Apr2005_d3dx9_25_x86를 두 번 클릭 하 고 d3dx9_25 .dll을 마우스 오른쪽 단추로 클릭 한 다음 복사를 클릭 합니다.
참고 Microsoft Windows 운영 체제의 x64 기반 버전에 대 한 Apr2005_d3dx9_25_x64 .cab 파일을 사용 합니다.
-
게임에 사용할 다음 폴더를 찾습니다.
드라이브: a # Files\Microsoft 게임 \게임 제목
참고 이 경로에서 drive 는 게임이 설치 된 드라이브의 드라이브 문자를 나타내고 게임 제목은 복구 하려는 게임을 나타냅니다.
-
컴퓨터에 설치 되어 있는 게임에 해당 하는 게임 폴더를 마우스 오른쪽 단추로 클릭 한 다음 붙여넣기를 클릭 합니다. 참고 컴퓨터에 여러 게임을 설치한 경우 다른 게임에 대해 5-6 단계를 반복 합니다.
다음 단계
추가 도움이 필요한 경우 Microsoft 기술 지원 서비스 웹 사이트를 사용하여 다른 솔루션을 찾을 수도 있습니다. 이 웹 사이트에서는 다음 서비스를 제공합니다.
-
Microsoft 커뮤니티 (http://answers.microsoft.com/en-us/windows/default.aspx): 피어 및 Microsoft의 소중한 전문가 (mvp)와 상호 작용 합니다.
-
솔루션 센터(http://support.microsoft.com/select/?target=hub): 제품별 FAQ(질문과 대답) 및 지원 사항을 볼 수 있습니다.
-
검색 가능한 기술 자료 문서(http://support.microsoft.com/search/?adv=1): Microsoft 제품의 기술 지원 정보와 자체 도움말 도구를 검색할 수 있습니다.
-
기타 지원 옵션(http://support.microsoft.com/default.aspx?pr=csshome): 웹을 사용하여 질문을 올리거나, Microsoft 기술 지원 서비스에 문의하거나, 의견을 제공하십시오.