Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Quando tentas iniciar um dos jogos da Microsoft que estão listados na secção "Aplica-te a", recebes uma das seguintes mensagens de erro:

Mensagem de erro 1

O ficheiro d3dx9_25.dll não foi encontrado.

Mensagem de erro 2

O ficheiro d3dx9_27.dll não foi encontrado.

Causa

Este problema pode ocorrer se o ficheiro Microsoft DirectX mencionado na mensagem de erro for corrompido ou não for copiado corretamente.

Resolução

Faça o download e instale a versão mais recente do DirectX

Para resolver este problema, faça o download e instale a versão mais recente do DirectX End-User Runtimes Web Installer. Para tal, visite o seguinte site da Microsoft:

http://www.microsoft.com/download/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en Nota Pode receber a seguinte mensagem de erro durante a instalação:

O software que está a instalar não passou nos testes do Windows Logo para verificar a sua compatibilidade com esta versão do Windows. (Diga-me por que este teste é importante.)

Para mais informações, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:

822798 Não é possível instalar algumas atualizações ou programas  

Copie manualmente o ficheiro

Para resolver este problema, copie o ficheiro D3dx9_25.dll ou o ficheiro D3dx9_27.dll do disco 1 CD/DVD do pacote CD/DVD do jogo para a pasta de jogo correspondente. Para isso, siga os passos adequados para a sua versão do Windows:

Windows 7 ou Windows Vista

  1. Insira o disco 1 CD/DVD para o seu jogo na unidade CD/DVD do computador.

  2. Clique em Iniciar  windows icon, e depois clique em Documentos.

  3. Localizar e clicar em Computador.

  4. Localize e clique na unidade CD/DVD.

  5. Localizar e clicar na seguinte pasta:

    CDDrive:\ DirectX9 Nota Neste caminho, o CDDriverepresenta a letra de acionamento da unidade de CD.

  6. Clique duas vezes Apr2005_d3dx9_25_x86.cabin,clique à direita d3dx9_25.dlle, em seguida, clique em Copiar.

    Nota Utilize o ficheiro Apr2005_d3dx9_25_x64.cab para a versão x64 do sistema operativo Windows.

  7. Localize a seguinte pasta para o seu jogo:

    Unidade:\Ficheiros de programa\Microsoft Games\Título do jogo Nota Neste caminho, Driverepresenta a letra de unidade na qual o jogo está instalado, e o Título de Jogo representa o jogo que queres reparar.

  8. Clique com o botão direito na pasta do jogo que corresponde ao jogo que está instalado no computador e, em seguida, clique em Pasta. Nota Se tiver instalado mais de um jogo no computador, repita os passos 7 e 8 para os outros jogos.

Windows XP

  1. Insira o disco 1 CD/DVD para o seu jogo na unidade CD/DVD do computador.

  2. Clique em Iniciar,aponte para programas,aponte para acessóriose, em seguida, clique no Windows Explorer.

  3. Localizar e clicar na seguinte pasta:

    CDDrive:\ DirectX9 Nota Neste caminho, o CDDriverepresenta a letra de acionamento da unidade de CD.

  4. Clique duas vezes Apr2005_d3dx9_25_x86.cabin,clique à direita d3dx9_25.dlle, em seguida, clique em Copiar.

    Nota Utilize o ficheiro Apr2005_d3dx9_25_x64.cab para a versão x64 do sistema operativo Microsoft Windows.

  5. Localize a seguinte pasta para o seu jogo:

    Unidade:\Ficheiros de programa\Microsoft Games\Título do jogo

    Nota Neste caminho, Drive representa a letra de unidade da unidade em que o jogo está instalado, e o Título de Jogo representa o jogo que queres reparar.

  6. Clique com o botão direito na pasta do jogo que corresponde ao jogo que está instalado no computador e, em seguida, clique em Pasta. Nota Se tiver instalado mais de um jogo no computador, repita os passos 5 e 6 para os outros jogos.

Passos seguintes

Se precisar de mais ajuda, visite o web site do Microsoft Customer Support Services para encontrar outras soluções. Este Web site fornece os seguintes serviços:

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×