Une erreur s’est produite lors du chargement Microsoft Dynamics CRM erreur de fonctionnalité lors du démarrage d’Outlook

Cet article fournit des solutions aux problèmes qui peuvent se produire lorsque vous démarrez le client Microsoft Dynamics CRM pour Outlook.

S’applique à : Microsoft CRM client pour Microsoft Office Outlook
Numéro de la base de connaissances d’origine : 911384

Symptômes

Symptômes 1

Lorsque vous ouvrez le client Microsoft Dynamics CRM pour Microsoft Office Outlook, le message d’erreur suivant s’affiche :

Une erreur s’est produite lors du chargement Microsoft CRM fonctionnalité, essayez de redémarrer Outlook.

Dans le journal des événements, les messages d’erreur qui ressemblent à ce qui suit sont enregistrés.

Message d’erreur 1

La description de l’ID d’événement ( 2 ) dans Source ( Microsoft CRM ) est introuvable. L’ordinateur local ne dispose peut-être pas des informations de Registre ou des fichiers DLL de message nécessaires pour afficher les messages d’un ordinateur distant. Vous pourrez peut-être utiliser l’indicateur /AUXSOURCE= pour récupérer cette description . Pour plus d’informations, consultez Aide et support.

Les informations suivantes font partie de l’événement. Rapport d’erreurs de plateforme MSCRM :

Erreur : Exception de HRESULT : 0x80040220. Message d’erreur : Exception de HRESULT : 0x80040220. Détails de l’erreur : les détails de cette erreur n’ont pas été fournis par la plateforme. Fichier source : Numéro de ligne non disponible : Informations de trace de pile non disponibles : sur System.Web.UI.Page.HandleError(Exception e) à System.Web.UI.Page.ProcessRequestMain() sur System.Web.UI.Page.ProcessRequest() sur System.Web.UI.UI .Page.ProcessRequest(HttpContext context) sur System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() à l’adresse System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously).

Message d’erreur 2

La description de l’ID d’événement ( 16930 ) dans Source ( MSCRMAddin ) est introuvable. L’ordinateur local ne dispose peut-être pas des informations de Registre ou des fichiers DLL de message nécessaires pour afficher les messages d’un ordinateur distant. Vous pourrez peut-être utiliser l’indicateur /AUXSOURCE= pour récupérer cette description . Pour plus d’informations, consultez Aide et support. Les informations suivantes font partie de l’événement : 80004005, , CAddin ::HrActivateAddin, 472.

Message d’erreur 3

La description de l’ID d’événement ( 5944 ) dans Source ( MSCRMAddin ) est introuvable. L’ordinateur local ne dispose peut-être pas des informations de Registre ou des fichiers DLL de message nécessaires pour afficher les messages d’un ordinateur distant. Vous pourrez peut-être utiliser l’indicateur /AUXSOURCE= pour récupérer cette description . Pour plus d’informations, consultez Aide et support. Les informations suivantes font partie de l’événement : 80004005, , CAddin ::HrInitializeUI, 137.

Symptômes 2

Lorsque vous utilisez Windows Vista avec le Microsoft Dynamics CRM pour Outlook et lorsque vous activez le suivi de plateforme, vous recevez un message d’erreur semblable au suivant :

Configuration du client : [Erreur] Les clés de Registre COM semblent endommagées. Réexécutez l’Assistant Configuration CRM ou contactez votre administrateur Microsoft Dynamics CRM. >--- System.TypeLoadException : Échec de la récupération de la fabrique de classe COM pour le composant avec LE CLSID {<ID>} en raison de l’erreur suivante : 80131522. à
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) à l’adresse
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) sur System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) à l’adresse
System.Activator.CreateInstance(Type type, Boolean nonPublic) à l’adresse
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) --- Fin de la trace de pile d’exceptions interne --- à l’adresse
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) à l’adresse Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)

Symptômes 3

Lorsque vous essayez d’exécuter le client Microsoft Dynamics CRM pour Outlook, vous ne pouvez pas afficher la structure de dossiers Microsoft Dynamics CRM. En outre, le message d’erreur suivant s’affiche :

Une erreur s’est produite lors du chargement Microsoft CRM fonctionnalité, essayez de redémarrer Outlook.

Les messages d’erreur suivants sont enregistrés dans le journal des événements :

Type d’événement : Erreur Source de l’événement : MSCRMAddin Catégorie d’événement : Aucun ID d’événement : 16930 Date : Date Heure Utilisateur : N/A Ordinateur : ComputerName Description : Échec de l’initialisation de l’interface utilisateur Microsoft CRM. Essayez de redémarrer Microsoft Outlook. HR=0x80004005. Context=. Function=CAddin ::HrActivateAddin. Ligne=521. En outre, vous recevez le message d’erreur suivant dans le fichier journal de trace OUTLOOK-YYDDMM.log : [Date et heure] Processus : OUTLOOK |Thread :0832 |Catégorie : Unmanaged.Platform |Utilisateur : PlatformUser |Niveau : Erreur | Fichier HrGetXmlDOM : c :\bt\643\src\application\outlook\v3caddin\xmlutil.cpp Ligne : 179 >h = 0x80004005

Remarque

Dans ce message d’erreur, l’espace réservé Date et Heure représente la date et l’heure réelles. Par exemple, la date et l’heure réelles peuvent être « 2007-10-19 17 :53 :26.138 ».

Symptômes 4

Lorsque vous démarrez le client Microsoft Dynamics CRM pour Outlook, le message d’erreur suivant s’affiche :

Une erreur s’est produite lors du chargement Microsoft CRM fonctionnalité, essayez de redémarrer Outlook. En outre, l’événement d’erreur 80072f19 est référencé dans le journal des applications : Événement : 16941 Un problème s’est produit lors de l’initialisation de la barre d’outils de progression d’initialisation. Redémarrez Microsoft CRM et réessayez. HR=0x80072f19. Context=. Function=CAddin ::HrActivateAddin. Line=322.

Symptômes 5

Lorsque vous essayez de démarrer Microsoft Office Outlook sur un ordinateur sur lequel le client Microsoft Dynamics CRM pour Outlook est installé, le message d’erreur suivant s’affiche :

Une erreur s’est produite lors du chargement Microsoft Dynamics CRM fonctionnalité.

Essayez de redémarrer Microsoft Outlook.

Contactez votre administrateur système si les erreurs persistent.

En outre, le message d’erreur suivant est enregistré dans le journal des événements de l’application :

Type d'événement : Erreur
Source de l’événement : MSCRMAddin
Catégorie d’événement : Aucun
ID d’événement : 16931
Description :

Un problème s’est produit lors de l’initialisation Microsoft CRM COM Interop. Redémarrez Microsoft CRM et réessayez. HR=0x80131700. Context=. Function=CAddin ::HrActivateAddin. Ligne=274.

Type d'événement : Erreur
Source de l’événement : MSCRMAddin
Catégorie d’événement : Aucun
ID d’événement : 5903
Description :

Impossible d’initialiser correctement le complément Microsoft CRM Outlook. Redémarrez Microsoft Outlook et réessayez. HR=0x80070057. Context=. Function=CAddin ::OnConnection. Line=196.

Cause

Cause 1

Ce problème se produit parce que le rôle affecté au compte d’utilisateur n’a pas d’accès en lecture à l’entité Vue enregistrée dans Microsoft Dynamics CRM. Voir Résolution 1.

Cause 2

La configuration de la page d’accueil désactiver le dossier est activée via stratégie de groupe. La configuration de la page d’accueil Désactiver le dossier est une configuration de modèle d’administration Microsoft Office 2003 (OUTLK11.adm). Si ce paramètre est activé, Office 2003 ne peut pas charger la structure de dossiers Microsoft Dynamics CRM. Voir Résolution 2.

Cause 3

Ce problème se produit si IIS ne contient pas les mappages pour les extensions .srf qui pointent vers le fichier CRMisapi.dll. Voir Résolution 3.

Cause 4

Ce problème se produit parce que la case activée pour la révocation de certificat de serveur est activée. Voir Résolution 4.

Cause 5

Ce problème se produit car le fichier Outlook.exe.config existe dans le dossier d’installation de Microsoft Office. Ce fichier est utilisé dans les instances de résolution des problèmes pour le client Microsoft Outlook CRM pour Outlook afin qu’Outlook puisse utiliser une version spécifique de Microsoft .NET Framework. Voir Résolution 5.

Résolution

Résolution 1

Pour démarrer correctement le client Microsoft Dynamics CRM pour Outlook, le rôle attribué au compte d’utilisateur doit disposer d’un accès en lecture à l’entité Affichage enregistré. Pour modifier l’accès de l’utilisateur, procédez comme suit :

  1. Ouvrez Microsoft Dynamics CRM.
  2. Sélectionnez Paramètres, Paramètres, Paramètres, Paramètres de l’unité commerciale, Utilisateurs, puis double-cliquez sur l’utilisateur pour ouvrir l’utilisateur.
  3. Sélectionnez Rôles, double-cliquez sur le rôle pour ouvrir le rôle, sélectionnez l’onglet Enregistrements principaux, puis sélectionnez Accès en lecture pour l’entité Affichage enregistré .

Résolution 2

Pour résoudre ce problème, définissez le paramètre de la configuration de la page d’accueil désactiver le dossier sur désactivé status. Pour ce faire, procédez comme suit pour Outlook 2003 :

  1. Pour modifier le stratégie de groupe qui contient le modèle d’administration Office 2003, ouvrez stratégie de groupe éditeur d’objet.
  2. Développez Configuration utilisateur, Stratégies, Modèles d’administration, puis Microsoft Office Outlook 2003.
  3. Sélectionnez Pages d’accueil des dossiers pour les dossiers spéciaux Outlook, puis double-cliquez sur Désactiver les pages d’accueil des dossiers.
  4. Dans la page Désactiver les propriétés des pages d’accueil du dossier, sélectionnez la zone Case activée désactivé, puis sélectionnez OK.
  5. Quittez stratégie de groupe éditeur d’objet.
  6. Redémarrez l’ordinateur client affecté.

Procédez comme suit pour Outlook 2007 :

  1. Pour modifier le stratégie de groupe qui contient le modèle d’administration Office 2007, ouvrez stratégie de groupe éditeur d’objets.
  2. Développez Configuration utilisateur, Stratégies, Modèles d’administration , puis Microsoft Office Outlook 2007.

    [REMARQUE] Le dossier Microsoft Office Outlook 2007 peut être contenu sous Modèles d’administration classiques (ADM).

  3. Sélectionnez Pages d’accueil des dossiers pour les dossiers spéciaux Outlook, puis double-cliquez sur Ne pas autoriser la définition de l’URL de la page d’accueil dans le dossier Propriétés.
  4. Dans la page Ne pas autoriser la définition de l’URL de la page d’accueil dans le dossier Propriétés, sélectionnez la zone Case activée désactivé, puis sélectionnez OK.
  5. Quittez stratégie de groupe éditeur d’objet.
  6. Redémarrez l’ordinateur client affecté.

Résolution 3

Pour résoudre ce problème, ajoutez le mappage .srf au site Web Microsoft Dynamics CRM. Pour cela, procédez comme suit :

  1. Développez le site Web Microsoft Dynamics CRM dans IIS.
  2. Cliquez avec le bouton droit sur le répertoire virtuel de l’application MSCRMServices , puis sélectionnez Propriétés.
  3. Sous l’onglet Répertoire virtuel , sélectionnez Configuration.
  4. Dans la section Extensions d’application , sélectionnez Ajouter.
  5. Recherchez le fichier CRMIsapi.dll , puis placez le chemin entre guillemets comme suit :
    C :\Program Files\Microsoft CRM\Server\bin\CrmIsapi.dll
  6. Dans la zone Extension , entrez .srf.
  7. Dans la zone Limite à, entrez GET, POST, HEAD.
  8. Sélectionnez la zone case activée moteur de script et la zone Vérifier que le fichier existe case activée, puis sélectionnez OK.
  9. Réinitialisez IIS. Pour ce faire, sélectionnez Démarrer, Exécuter, tapez iisreset dans la zone Ouvrir , puis sélectionnez OK.

Résolution 4

Pour résoudre ce problème, procédez comme suit :

  1. Dans Internet Explorer, sélectionnez le menu Outils, puis Options Internet.
  2. Sélectionnez l’onglet Avancé, puis désactivez la case à cocher Vérifier la révocation du certificat de serveur (nécessite un redémarrage) case activée.
  3. Redémarrez Outlook.

Résolution 5

Pour résoudre ce problème, supprimez ou renommez le fichier Outlook.exe.config, puis redémarrez Outlook.