Kimlik doğrulama etki alanı denetleyicisinde Windows Server 2003 SP1 yüklüyse İnternet'e bağlanamazsınız ve etki alanına katılamaz veya oturum açamazsınız

Bu makalede, istemcilerin etki alanına katılamaması veya etki alanında oturum açamaması sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Windows Server 2003
Özgün KB numarası: 912023

Belirtiler

Aşağıdaki senaryoyu inceleyin. Microsoft Windows XP tabanlı bir istemci bilgisayar, Bir Microsoft Windows Server 2003 etki alanına katılmıştır. Ayrıca, kimlik doğrulama etki alanı denetleyicisine Windows Server 2003 Service Pack 1 (SP1) yüklenir. Bu senaryoda aşağıdaki belirtilerle karşılaşırsınız:

  • İnternet'e bağlanamazsınız.
  • Etki alanına katılamaz veya etki alanına oturum açamazsınız. Bu nedenle, etki alanı denetleyicisi IPsec Blok modundadır.

Etki alanı denetleyicisinde IPSEC Hizmetleri bileşenini başlattığınızda, aşağıdakine benzer bir hata iletisi alabilirsiniz:

Sistem belirtilen dosyayı bulamıyor.

Ayrıca, aşağıdaki olaylar sunucunun Sistem günlüğüne kaydedilebilir:

Olay Türü: Hata
Olay Kaynağı: IPSEC
Olay Kategorisi: Yok
Olay Kimliği: 4292
Tarih: <DateTime>
Saat: <DateTime>
Kullanıcı: Yok
Bilgisayar: <ComputerName>
Açıklama:
IPSec sürücüsü Engelle moduna girdi. IPSec, önyükleme zamanı IPSec İlkesi muafiyetleri tarafından izin verilmeyen tüm gelen ve giden TCP/IP ağ trafiğini atar.

Olay Türü: Hata
Olay Kaynağı: Hizmet Denetim Yöneticisi
Olay Kategorisi: Yok
Olay Kimliği: 7023
Tarih: <DateTime>
Saat: <DateTime>
Kullanıcı: Yok
Bilgisayar: <ComputerName>
Açıklama:
IPSEC Hizmetleri hizmeti şu hatayla sonlandırıldı: Sistem belirtilen dosyayı bulamıyor

Neden

IPSec\Policy\Local kayıt defteri anahtarı silinirse veya ilke deposunda bozuk bir dosya olduğunda bu sorun oluşabilir. İlke diske yazılırken bir kesinti oluşursa dosya bozulabilir.

Çözüm

Önemli

Bu bölüm, yöntem veya görev, kayıt defterini nasıl değiştireceğinizin anlatıldığı adımları içermektedir. Ancak kayıt defterini hatalı biçimde değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle bu adımları dikkatle uyguladığınızdan emin olun. Ek koruma için kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Böylece, bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için bkz. Windows'ta kayıt defterini yedekleme ve geri yükleme.

Bu sorunu çözmek için şu adımları izleyin:

  1. Yerel ilke kayıt defteri alt anahtarını silin. Bunu yapmak için şu adımları uygulayın:

    1. Başlat'a tıklayın, Çalıştır'a tıklayın, kutusuna regedit yazın ve ardından Tamam'a tıklayın.

    2. Kayıt Defteri Düzenleyici aşağıdaki alt anahtarı bulun ve tıklatın:

      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\IPSec\Policy\Local

    3. Düzenle menüsünde Sil'e tıklayın.

    4. Alt anahtarı silmek istediğinizi onaylamak için Evet'e tıklayın.

    5. Kayıt Defteri Düzenleyicisi'nden çıkın.

  2. Yeni bir yerel ilke deposu yeniden oluşturun. Bunu yapmak için Başlat'a tıklayın, Çalıştır'a tıklayın, kutusuna regsvr32 polstore.dll yazın ve tamam'a tıklayın.

  3. IPSEC Hizmetleri bileşeninin otomatik olarak ayarlandığını doğrulayın ve ardından etki alanı denetleyicisini yeniden başlatın.

Geçici Çözüm

Bu sorunu geçici olarak çözmek için IPSEC Hizmetleri bileşenini devre dışı bırakın ve ardından etki alanı denetleyicisini yeniden başlatın.