L’ID d’événement 10000 est enregistré dans le journal des applications sur un ordinateur Windows Server 2003 sur lequel Terminal Server est activé

Cet article fournit une solution à un problème où l’ID d’événement 10000 est enregistré dans le journal des applications lorsque vous utilisez un ordinateur Terminal Server exécutant Windows Server 2003.

Produit concerné : Windows Server 2003
Numéro de la base de connaissances d’origine : 914052

Importante

Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l’article dans la Base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows

Symptômes

Lorsque vous essayez de vous connecter à un ordinateur Microsoft Windows Server 2003 sur lequel Terminal Server est activé, un événement semblable à ce qui suit est enregistré dans le journal des applications :

Type d’événement :Error Event Source :DCOM Event Category :None Event ID :10000 Date :<Date> Time :<Time> User :N/A Computer : Computer_Name
Description : Impossible de démarrer un serveur DCOM : {0002DF01-0000-0000-C000-0000000000046} L’erreur : « %%233 » s’est produite lors du démarrage de cette commande : <commande> -Incorporation

Remarque

Computer_Name est le nom de l’ordinateur Terminal Server.

Cause

Ce problème se produit lorsque les entrées de Registre requises pour les notifications Winlogon sont manquantes dans le Registre de l’ordinateur Terminal Server.

Résolution

Avertissement

De graves problèmes peuvent se produire si vous vous trompez en modifiant le Registre à l’aide de l’Éditeur du Registre ou toute autre méthode. Ces problèmes peuvent nécessiter la réinstallation du système d’exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l’ensemble des risques liés à la modification du Registre. Pour résoudre ce problème, ajoutez les entrées de Registre suivantes au registre de l’ordinateur Terminal Server. Pour cela, procédez comme suit :

  1. Cliquez sur Démarrer, puis Exécuter, entrez regedit dans la zone Ouvrir et cliquez sur OK.

  2. Trouvez la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\termsrv

  3. Sous cette sous-clé, ajoutez les entrées de Registre suivantes :

    Nom Type Données de la valeur
    Déconnexion REG_SZ TSEventLogoff
    Ouverture de session REG_SZ TSEventLogon
  4. Redémarrez l’ordinateur Terminal Server.