Le destinataire ne reçoit pas les e-mails qu’un utilisateur Microsoft Dynamics CRM envoie à l’aide du client web Microsoft Dynamics CRM

Cet article fournit une résolution du problème lié au fait que le destinataire ne peut pas recevoir les messages électroniques envoyés à partir du client web Microsoft Dynamics CRM.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 915827

Symptômes

Lorsqu’un utilisateur Microsoft Dynamics CRM envoie un e-mail à l’aide du client web Microsoft Dynamics CRM 2011, le message électronique est envoyé ou est mis en file d’attente. Toutefois, si un problème se produit lorsque l’utilisateur envoie l’e-mail, l’utilisateur reçoit l’un des messages d’erreur suivants dans l’activité de messagerie.

Message d’erreur 1

Ce message n’a pas encore été envoyé pour remise. 1 tentatives ont été effectuées jusqu’à présent.

Message d’erreur 2

Échec de la remise du message. Il doit être soumis à nouveau pour tout traitement ultérieur.

En outre, vous recevez un message d’erreur semblable au suivant dans le journal des événements MSCRMEmailLog :

Type d’événement :Erreur
Source de l’événement :MSCRMEmailLog
Catégorie d’événement : Aucun
ID d’événement : 0
Date : Date
Heure : Heure
Utilisateur : N/A
Ordinateur : ComputerName
Description : #61042 - Une erreur s’est produite lors du traitement du message électronique sortant avec l’objet « test 3 aujourd’hui CRM :0001011 » pour SMTP : https://adsrv:81/MS1 pour la remise via adsrv. System.Net.Mail.SmtpException : échec de l’envoi de messages. >--- System.Net.WebException : impossible de se connecter au serveur distant --->
System.Net.Sockets.SocketException : aucune connexion n’a pu être établie, car l’ordinateur cible l’a refusé activement
sur System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
sur System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
dans System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket&, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- Fin du --- de trace de la pile d’exceptions interne
dans System.Net.ServicePoint.GetConnection(PooledStream PooledStream, Object owner, Boolean async, IPAddress& address, Socket& abortSocket, Socket& abortSocket6, Int32 timeout)
sur System.Net.PooledStream.Activate(Object owningObject, Boolean async, Int32 timeout, GeneralAsyncDelegate asyncCallback)
sur System.Net.PooledStream.Activate(Object owningObject, GeneralAsyncDelegate asyncCallback)
sur System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
sur System.Net.Mail.SmtpConnection.GetConnection(String host, Int32 port)
sur System.Net.Mail.SmtpTransport.GetConnection(String host, Int32 port)
sur System.Net.Mail.SmtpClient.GetConnection()
sur System.Net.Mail.SmtpClient.Send(MailMessage message)
--- Fin du --- de trace de la pile d’exceptions interne
sur System.Net.Mail.SmtpClient.Send(MailMessage message)
sur Microsoft.Crm.Tools. Email. Providers.SmtpPollingSendEmailProvider.SendMessage(MailMessage mailMessage)
sur Microsoft.Crm.Tools. Email. Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(emailMessage)
sur Microsoft.Crm.Tools. Email. Providers.CrmPollingSendEmailProvider.ProcessMessage(email emailMessage)
sur Microsoft.Crm.Tools. Email. Providers.CrmPollingSendEmailProvider.Run()

Pour plus d’informations, consultez Le Centre d’aide et de support à l’adresse https://go.microsoft.com/fwlink/events.asp.

Cause

Microsoft Dynamics CRM s’appuie sur le serveur SMTP local pour transférer les messages électroniques au serveur Exchange. Ce problème se produit pour l’une des raisons suivantes :

  • La configuration SMTP sur le serveur Microsoft Dynamics CRM n’est pas configurée pour transférer les messages électroniques au serveur Exchange.
  • Le serveur Exchange n’est pas configuré pour autoriser les messages de relais du serveur Microsoft Dynamics CRM.

Résolution

Pour résoudre ce problème, procédez comme suit :

Étape 1 : Configurer SMTP sur le serveur Microsoft Dynamics CRM pour transférer les messages électroniques au serveur Exchange

  1. Sur le serveur Microsoft Dynamics CRM, ouvrez Internet Information Services (IIS). Pour ce faire, sélectionnez Démarrer, Outils d’administration, puis Gestionnaire des services Internet (IIS).
  2. Dans le Gestionnaire des services Internet (IIS), développez Serveur virtuel SMTP par défaut, cliquez avec le bouton droit sur Domaines, pointez sur Nouveau, puis sélectionnez Domaine.
  3. Dans l’Assistant Nouveau SMTP, sélectionnez Distant sous Spécifier le type de domaine, puis sélectionnez Suivant.
  4. Tapez votre nom de domaine dans la zone Nom , puis sélectionnez Terminer.
  5. Dans le volet droit, cliquez avec le bouton droit sur le nom de domaine que vous avez ajouté aux étapes 2 à 4, puis sélectionnez Propriétés.
  6. Sous l’onglet Général, sélectionnez la zone Autoriser le relais du courrier entrant vers ce domaine case activée, puis sélectionnez Transférer tous les messages vers l’hôte actif. Dans la zone sous Transférer tous les messages à l’hôte actif, tapez le nom du serveur Exchange, puis sélectionnez OK.
  7. Redémarrez le service SMTP sur le serveur Microsoft Dynamics CRM. Pour ce faire, sélectionnez Démarrer, Outils d’administration, puis Services. Cliquez avec le bouton droit sur SMTP (Simple Mail Transfer Protocol), puis sélectionnez Redémarrer.

Étape 2 : Configurer le serveur Exchange pour autoriser les messages de relais à partir du serveur Microsoft Dynamics CRM

Exchange Server 2003

Si vous utilisez Microsoft Exchange Server 2003, vous devez d’abord configurer les restrictions de relais, puis vérifier le contrôle Connections.

Configurer les restrictions de relais
  1. Sélectionnez Démarrer, pointez sur Programmes, pointez sur Microsoft Exchange, puis sélectionnez System Manager.

  2. Sélectionnez Serveurs, sélectionnez le nom du serveur Exchange, sélectionnez Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur Serveur virtuel SMTP par défaut, sélectionnez Propriétés, puis sélectionnez l’onglet Accès .

  4. Dans la zone Restrictions de relais , sélectionnez Relais.

  5. Vérifiez que l’option Uniquement la liste ci-dessous est sélectionnée, puis ajoutez le serveur Microsoft Dynamics CRM à la liste.

    Si vous utilisez Microsoft Dynamics CRM 2011, veillez à ajouter le serveur sur lequel le routeur Exchange est installé à la liste.

  6. Redémarrez le service SMTP. Pour cela, procédez comme suit :

    1. Sélectionnez Démarrer, pointez sur Programmes, sur Outils d’administration, puis sélectionnez Services.
    2. Cliquez avec le bouton droit sur SMTP (Simple Mail Transfer Protocol), puis sélectionnez Redémarrer.
Vérifier le contrôle Connections
  1. Sélectionnez Démarrer, pointez sur Programmes, pointez sur Microsoft Exchange, puis sélectionnez System Manager.

  2. Sélectionnez Serveurs, sélectionnez le nom du serveur Exchange, sélectionnez Protocoles, puis SMTP.

  3. Cliquez avec le bouton droit sur Serveur virtuel SMTP par défaut, sélectionnez Propriétés, puis sélectionnez l’onglet Accès .

  4. Dans la zone contrôle Connections, sélectionnez Connexion.

  5. Par défaut, l’option Tout sauf la liste ci-dessous est sélectionnée. Si le serveur Microsoft Dynamics CRM est ajouté à cette liste, vous devez contacter l’administrateur Exchange pour déterminer la raison pour laquelle le serveur Microsoft Dynamics CRM a été ajouté.

    Remarque

    Pour Microsoft Dynamics CRM les messages électroniques fonctionnent correctement, le serveur Microsoft Dynamics CRM doit être en mesure de se connecter au serveur Exchange.

  6. Si l’option Uniquement la liste ci-dessous est sélectionnée, vous devez ajouter le serveur Microsoft Dynamics CRM à la liste pour lui permettre de se connecter au serveur Exchange.

  7. Si vous avez apporté des modifications aux paramètres de contrôle de connexion, redémarrez le service SMTP. Pour cela, procédez comme suit :

    1. Sélectionnez Démarrer, pointez sur Programmes, sur Outils d’administration, puis sélectionnez Services.
    2. Cliquez avec le bouton droit sur SMTP (Simple Mail Transfer Protocol), puis sélectionnez Redémarrer.

Exchange Server 2007

Si vous utilisez Microsoft Exchange Server 2007, vous devez créer un connecteur de réception Exchange, configurer le connecteur pour l’utilisateur anonyme, configurer les autorisations de protocole pour le connecteur de réception, puis redémarrer le service de transport Microsoft Exchange sur le serveur Exchange.

Créer un connecteur de réception Exchange
  1. Ouvrez Exchange Management Console.

  2. Développez Configuration du serveur.

  3. Sélectionnez Transport hub.

  4. Cliquez avec le bouton droit sur Connecteurs de réception, puis sélectionnez Nouveau connecteur de réception.

  5. Tapez un nom dans la zone Nom .

  6. Dans la liste Sélectionner l’utilisation prévue pour ce connecteur de réception , sélectionnez Interne, puis Suivant.

  7. Dans la section Paramètres du réseau distant, sélectionnez Ajouter, puis tapez l’adresse IP du serveur Microsoft Dynamics CRM.

    Remarque

    Si vous voyez la valeur 0.0.0.0-255.255.255.255, sélectionnez Supprimer.

  8. Sélectionnez Suivant, Nouveau, puis Terminer.

Configurer le connecteur pour l’utilisateur anonyme
  1. Cliquez avec le bouton droit sur le connecteur de réception Exchange que vous avez créé, puis sélectionnez Propriétés.
  2. Sélectionnez l’onglet Groupes d’autorisations .
  3. Vérifiez que l’option Spécifier qui est autorisé à se connecter au connecteur de réception est définie sur Utilisateurs anonymes, sélectionnez Appliquer, puis OK.
Configurer les autorisations de protocole pour le connecteur de réception

Remarque

Les outils de support Windows doivent être installés pour effectuer ces étapes. Seul un administrateur expérimenté doit utiliser l’outil Adsiedit.msc.

  1. Démarrez l’outil Adsiedit.msc.
  2. Développez Configuration, Services, Microsoft Exchange, CN= First Organization, Groupes d’administration, Groupe d’administration Exchange, Serveurs, Protocoles, puis Connecteurs de réception SMTP.
  3. Cliquez avec le bouton droit sur le connecteur de réception Exchange que vous avez créé, puis sélectionnez Propriétés.
  4. Sélectionnez l’onglet Sécurité.
  5. Sélectionnez Ouverture de session anonyme.
  6. Sélectionnez la zone Envoyer des messages à n’importe quel destinataire case activée et la zone Accepter l’expéditeur de domaine faisant autorité case activée, sélectionnez Appliquer, puis sélectionnez OK.
Redémarrer le service de transport Microsoft Exchange sur le serveur Exchange
  1. Sélectionnez Démarrer, Exécuter, tapez services.msc, puis sélectionnez OK.
  2. Cliquez avec le bouton droit sur Service de transport Microsoft Exchange, puis sélectionnez Redémarrer.