Получатель не получает сообщения электронной почты, которые пользователь Microsoft Dynamics CRM отправляет с помощью веб-клиента Microsoft Dynamics CRM

В этой статье описывается решение проблемы, из-за чего получатель не может получать сообщения электронной почты, отправляемые из веб-клиента Microsoft Dynamics CRM.

Область применения: Microsoft Dynamics CRM 2011 г.
Исходный номер базы знаний: 915827

Симптомы

Когда пользователь Microsoft Dynamics CRM отправляет сообщение электронной почты с помощью веб-клиента Microsoft Dynamics CRM 2011, сообщение электронной почты отправляется или помещается в очередь. Однако если возникает проблема, когда пользователь отправляет сообщение электронной почты, пользователь получает одно из следующих сообщений об ошибке в действии электронной почты.

Сообщение об ошибке 1

Это сообщение еще не отправлено для доставки. На данный момент предпринята 1 попытка.

Сообщение об ошибке 2

Сбой доставки сообщения. Его необходимо повторно отправить для дальнейшей обработки.

Кроме того, в журнале событий MSCRMEmailLog появляется сообщение об ошибке, похожее на следующее:

Тип события:Ошибка
Источник события: MSCRMEmailLog
Категория события:None
Идентификатор события:0
Дата: Дата
Время: время
Пользователь:не определен
Computer: ComputerName
Описание: No 61042 — произошла ошибка при обработке исходящего сообщения электронной почты с темой "test 3 today CRM:0001011" для SMTP: https://adsrv:81/MS1 для доставки через adsrv. System.Net.Mail.SmtpException: сбой при отправке почты. >--- System.Net.WebException: не удается подключиться к удаленному серверу --->
System.Net.Sockets.SocketException: не удалось подключиться, так как целевой компьютер отказался от него
в System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
в System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
в System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
--- конец --- трассировки внутреннего стека исключений
в System.Net.ServicePoint.GetConnection(PooledStream PooledStream, владелец объекта, логическое асинхронное значение, IPAddress& адрес, сокет& abortSocket, Socket& abortSocket6, Время ожидания Int32)
в System.Net.PooledStream.Activate(Object owningObject, Boolean async, Int32 timeout, GeneralAsyncDelegate asyncCallback)
в System.Net.PooledStream.Activate(Object owningObject, GeneralAsyncDelegate asyncCallback)
в System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
в System.Net.Mail.SmtpConnection.GetConnection(Узел строки, порт Int32)
в System.Net.Mail.SmtpTransport.GetConnection(Узел строки, порт Int32)
в System.Net.Mail.SmtpClient.GetConnection()
в System.Net.Mail.SmtpClient.Send(MailMessage message)
--- конец --- трассировки внутреннего стека исключений
в System.Net.Mail.SmtpClient.Send(MailMessage message)
в Microsoft.Crm.Tools. Email. Providers.SmtpPollingSendEmailProvider.SendMessage(MailMessage mailMessage)
в Microsoft.Crm.Tools. Email. Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(emailMessage)
в Microsoft.Crm.Tools. Email. Providers.CrmPollingSendEmailProvider.ProcessMessage(emailMessage)
в Microsoft.Crm.Tools. Email. Providers.CrmPollingSendemailProvider.Run()

Дополнительные сведения см. в разделе Центр справки и поддержки по адресу https://go.microsoft.com/fwlink/events.asp.

Причина

Microsoft Dynamics CRM использует локальный SMTP-сервер для пересылки сообщений электронной почты на сервер Exchange Server. Эта проблема может возникать по одной из следующих причин:

  • Конфигурация SMTP на сервере Microsoft Dynamics CRM не настроена для пересылки сообщений электронной почты на сервер Exchange Server.
  • Сервер Exchange server не настроен для разрешения сообщений ретрансляции с сервера Microsoft Dynamics CRM.

Решение

Чтобы устранить эту неполадку, выполните следующие действия:

Шаг 1. Настройка SMTP на сервере Microsoft Dynamics CRM для пересылки сообщений электронной почты на сервер Exchange Server

  1. На сервере Microsoft Dynamics CRM откройте службы IIS. Для этого нажмите кнопку Пуск, Администрирование, а затем выберите Диспетчер служб IIS.
  2. В диспетчере служб IIS разверните узел Виртуальный сервер SMTP по умолчанию, щелкните правой кнопкой мыши Пункты, наведите указатель мыши на пункт Создать, а затем выберите Домен.
  3. В мастере создания SMTP выберите Удаленный в разделе Укажите тип домена, а затем нажмите кнопку Далее.
  4. Введите доменное имя в поле Имя и нажмите кнопку Готово.
  5. В правой области щелкните правой кнопкой мыши доменное имя, добавленное на шагах 2–4, а затем выберите Свойства.
  6. На вкладке Общие установите флажок Разрешить ретрансляцию входящей почты в этот домен проверка, а затем выберите Переслать всю почту на смарт-узел. В поле Переадресация всей почты на смарт-узел введите имя сервера Exchange и нажмите кнопку ОК.
  7. Перезапустите службу SMTP на сервере Microsoft Dynamics CRM. Для этого нажмите кнопку Пуск, а затем выберите Администрирование, а затем — Службы. Щелкните правой кнопкой мыши протокол SMTP и выберите перезапустить.

Шаг 2. Настройка сервера Exchange server для разрешения сообщений ретрансляции с сервера Microsoft Dynamics CRM

Exchange Server 2003

Если вы используете Microsoft Exchange Server 2003, необходимо сначала настроить ограничения ретранслятора, а затем проверить элемент управления Connections.

Настройка ограничений ретранслятора
  1. Нажмите кнопку Пуск, выберите Пункт Программы, Microsoft Exchange, а затем — System Manager.

  2. Выберите Серверы, выберите имя сервера Exchange Server, выберите Протоколы, а затем — SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер по умолчанию, выберите Свойства, а затем перейдите на вкладку Доступ .

  4. В области Ограничения ретранслятора выберите Ретранслятор.

  5. Убедитесь, что выбран параметр Только список ниже, а затем добавьте сервер Microsoft Dynamics CRM в список.

    Если вы используете Microsoft Dynamics CRM 2011, убедитесь, что вы добавили в список сервер, на котором установлен маршрутизатор Exchange.

  6. Перезапустите службу SMTP. Для этого выполните следующие действия:

    1. Нажмите кнопку Пуск, наведите указатель на пункт Программы, а затем — Администрирование, а затем — Службы.
    2. Щелкните правой кнопкой мыши протокол SMTP и выберите перезапустить.
Проверка элемента управления Connections
  1. Нажмите кнопку Пуск, выберите Пункт Программы, Microsoft Exchange, а затем — System Manager.

  2. Выберите Серверы, выберите имя сервера Exchange Server, выберите Протоколы, а затем — SMTP.

  3. Щелкните правой кнопкой мыши виртуальный SMTP-сервер по умолчанию, выберите Свойства, а затем перейдите на вкладку Доступ .

  4. В области управление Connections выберите Подключение.

  5. По умолчанию выбран параметр Все, кроме списка ниже . Если сервер Microsoft Dynamics CRM добавлен в этот список, необходимо обратиться к администратору Exchange, чтобы определить причину добавления сервера Microsoft Dynamics CRM.

    Примечание.

    Чтобы Microsoft Dynamics CRM сообщения электронной почты работали правильно, сервер Microsoft Dynamics CRM должен иметь возможность подключения к серверу Exchange Server.

  6. Если выбран параметр Только список ниже, необходимо добавить сервер Microsoft Dynamics CRM в список, чтобы разрешить ему подключаться к серверу Exchange Server.

  7. Если вы внесли какие-либо изменения в параметры управления подключениями, перезапустите службу SMTP. Для этого выполните следующие действия:

    1. Нажмите кнопку Пуск, наведите указатель на пункт Программы, а затем — Администрирование, а затем — Службы.
    2. Щелкните правой кнопкой мыши протокол SMTP и выберите перезапустить.

Exchange Server 2007

Если вы используете Microsoft Exchange Server 2007, необходимо создать новый соединитель получения Exchange, настроить соединитель для анонимного пользователя, настроить разрешения протокола для соединителя получения, а затем перезапустить транспортную службу Microsoft Exchange на сервере Exchange Server.

Создание соединителя получения Exchange
  1. Откройте консоль управления Exchange.

  2. Разверните узел Конфигурация сервера.

  3. Выберите Транспорт концентратора.

  4. Щелкните правой кнопкой мыши Соединители получения и выберите Новый соединитель получения.

  5. Введите имя в поле Имя .

  6. В списке Выберите предполагаемое использование для этого соединителя получения выберите Внутренний, а затем нажмите кнопку Далее.

  7. В разделе Параметры удаленной сети выберите Добавить, а затем введите IP-адрес сервера Microsoft Dynamics CRM.

    Примечание.

    Если отображается значение 0.0.0.0-255.255.255.255, нажмите кнопку Удалить.

  8. Нажмите кнопку Далее, нажмите кнопку Создать, а затем нажмите кнопку Готово.

Настройка соединителя для анонимного пользователя
  1. Щелкните правой кнопкой мыши созданный соединитель получения Exchange и выберите Пункт Свойства.
  2. Перейдите на вкладку Группы разрешений .
  3. Убедитесь, что для параметра Указать, кому разрешено подключаться к соединителю Получения , задано значение Анонимные пользователи, нажмите кнопку Применить, а затем нажмите кнопку ОК.
Настройка разрешений протокола для соединителя получения

Примечание.

Для выполнения этих действий необходимо установить средства поддержки Windows. Только опытный администратор должен использовать средство Adsiedit.msc.

  1. Запустите средство Adsiedit.msc.
  2. Разверните узел Конфигурация, Службы, Microsoft Exchange, CN= Первая организация, Административные группы, Административные группы Exchange, Серверы, Протоколы, а затем Соединители получения SMTP.
  3. Щелкните правой кнопкой мыши созданный соединитель получения Exchange и выберите Пункт Свойства.
  4. Откройте вкладку Безопасность.
  5. Выберите Анонимный вход.
  6. Установите флажки Отправить сообщения любому получателю проверка, а затем проверка Принять полномочный отправитель домена, нажмите кнопку Применить, а затем нажмите кнопку ОК.
Перезапуск транспортной службы Microsoft Exchange на сервере Exchange
  1. Нажмите кнопку Пуск, выберите Выполнить, введите services.msc, а затем нажмите кнопку ОК.
  2. Щелкните правой кнопкой мыши Транспортную службу Microsoft Exchange и выберите Перезапустить.