Alıcı, Microsoft Dynamics CRM kullanıcının Microsoft Dynamics CRM web istemcisini kullanarak gönderdiği e-postaları almaz

Bu makalede, alıcının Microsoft Dynamics CRM web istemcisinden gönderilen e-posta iletilerini alamama sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics CRM 2011
Özgün KB numarası: 915827

Belirtiler

Microsoft Dynamics CRM bir kullanıcı Microsoft Dynamics CRM 2011 web istemcisini kullanarak bir e-posta iletisi gönderdiğinde, e-posta iletisi gönderilir veya kuyruğa eklenir. Ancak, kullanıcı e-posta iletisini gönderdiğinde bir sorun oluşursa, kullanıcı e-posta etkinliğinde aşağıdaki hata iletilerinden birini alır.

Hata iletisi 1

Bu ileti henüz teslim için gönderilmedi. Şimdiye kadar 1 girişimde bulunuldu.

Hata iletisi 2

İleti teslimi başarısız oldu. Daha fazla işlem için yeniden yayımlanmalıdır.

Ayrıca, MSCRMEmailLog olay günlüğünde aşağıdakine benzer bir hata iletisi alırsınız:

Olay Türü:Hata
Olay Kaynağı:MSCRMEmailLog
Olay Kategorisi:Yok
Olay Kimliği:0
Tarih: Tarih
Zaman: Saat
Kullanıcı:Yok
Bilgisayar: ComputerName
Açıklama: #61042 - Adsrv aracılığıyla teslim için SMTP için https://adsrv:81/MS1 "test 3 today CRM:0001011" konusuna sahip giden e-posta iletisi işlenirken bir hata oluştu. System.Net.Mail.SmtpException: Posta gönderme hatası. >--- System.Net.WebException: Uzak sunucuya bağlanılamıyor --->
System.Net.Sockets.SocketException: Hedef makine etkin bir şekilde reddettiğinden bağlantı yapılamadı
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
system.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP) adresinde
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& adresi, ConnectSocketState durumu, IAsyncResult asyncResult, Int32 zaman aşımı, Özel durum& özel durumu)
--- İç özel durum yığını izlemesi sonu ---
at System.Net.ServicePoint.GetConnection(PooledStream PooledStream, Nesne sahibi, Boole async, IPAddress& adresi, Yuva& abortSocket, Yuva& abortSocket6, Int32 zaman aşımı)
at System.Net.PooledStream.Activate(Object owningObject, Boolean async, Int32 zaman aşımı, GeneralAsyncDelegate asyncCallback)
at System.Net.PooledStream.Activate(Object owningObject, GeneralAsyncDelegate asyncCallback)
at System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout)
at System.Net.Mail.SmtpConnection.GetConnection(Dize ana bilgisayarı, Int32 bağlantı noktası)
at System.Net.Mail.SmtpTransport.GetConnection(Dize konağı, Int32 bağlantı noktası)
at System.Net.Mail.SmtpClient.GetConnection()
at System.Net.Mail.SmtpClient.Send(MailMessage iletisi)
--- İç özel durum yığını izlemesi sonu ---
at System.Net.Mail.SmtpClient.Send(MailMessage iletisi)
microsoft.crm.tools adresinden seçin. Email. Providers.SmtpPollingSendEmailProvider.SendMessage(MailMessage mailMessage)
microsoft.crm.tools adresinden seçin. Email. Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(email emailMessage)
microsoft.crm.tools adresinden seçin. Email. Providers.CrmPollingSendEmailProvider.ProcessMessage(e-posta e-postaİleti)
microsoft.crm.tools adresinden seçin. Email. Providers.CrmPollingSendEmailProvider.Run()

Daha fazla bilgi için, adresinde Yardım ve Destek Merkezi'ne https://go.microsoft.com/fwlink/events.aspbakın.

Neden

Microsoft Dynamics CRM, e-posta iletilerini Exchange sunucusuna iletmek için yerel SMTP sunucusuna bağlıdır. Bu sorun aşağıdaki nedenlerden biriyle oluşur:

  • Microsoft Dynamics CRM sunucusundaki SMTP yapılandırması, e-posta iletilerini Exchange sunucusuna iletecek şekilde yapılandırılmamış.
  • Exchange sunucusu, Microsoft Dynamics CRM sunucusundan geçiş iletilerine izin verecek şekilde yapılandırılmamış.

Çözüm

Bu sorunu gidermek için aşağıdaki adımları izleyin:

1. Adım - e-posta iletilerini Exchange sunucusuna iletmek için Microsoft Dynamics CRM sunucusunda SMTP'yi yapılandırma

  1. Microsoft Dynamics CRM sunucusunda Internet Information Services'i (IIS) açın. Bunu yapmak için Başlat'ı, Yönetim Araçları'nı ve ardından Internet Information Services (IIS) Yöneticisi'ni seçin.
  2. Internet Information Services (IIS) Yöneticisi'nde Varsayılan SMTP Sanal Sunucusu'nu genişletin, Etki Alanları'na sağ tıklayın, Yeni'nin üzerine gelin ve Etki Alanı'nı seçin.
  3. Yeni SMTP Sihirbazı'nda Etki alanı türünü belirtin'in altında Uzak'ı seçin ve ardından İleri'yi seçin.
  4. Ad kutusuna etki alanı adınızı yazın ve Son'u seçin.
  5. Sağ bölmede, 2 ile 4 arası adımlarda eklediğiniz etki alanı adına sağ tıklayın ve özellikler'i seçin.
  6. Genel sekmesinde Gelen postanın bu etki alanına geçirilmesine izin ver onay kutusunu ve ardından Tüm postaları akıllı ana bilgisayara ilet'i seçin. Tüm postaları akıllı ana bilgisayara ilet altındaki kutuya Exchange sunucusu adını yazın ve tamam'ı seçin.
  7. Microsoft Dynamics CRM sunucusunda SMTP hizmetini yeniden başlatın. Bunu yapmak için Başlat'ı, Yönetim Araçları'nı ve ardından Hizmetler'i seçin. Basit Posta Aktarım Protokolü 'ne (SMTP) sağ tıklayın ve yeniden başlat'ı seçin.

2. Adım - Exchange sunucusunu Microsoft Dynamics CRM sunucusundan ileti geçişine izin verecek şekilde yapılandırma

Exchange Server 2003

Microsoft Exchange Server 2003 kullanıyorsanız, önce Geçiş Kısıtlamaları'nı yapılandırmanız ve ardından Connections Denetimini doğrulamanız gerekir.

Geçiş Kısıtlamalarını Yapılandırma
  1. Başlat'ı seçin, Programlar'ın üzerine gelin, Microsoft Exchange'in üzerine gelin ve ardından Sistem Yöneticisi'ni seçin.

  2. Sunucular'ı seçin, Exchange sunucusunun adını seçin, Protokoller'i ve ardından SMTP'yi seçin.

  3. Varsayılan SMTP Sanal Sunucusu'na sağ tıklayın, Özellikler'i ve ardından Erişim sekmesini seçin.

  4. Geçiş Kısıtlamaları alanında Geçiş'i seçin.

  5. Yalnızca aşağıdaki liste seçeneğinin belirlendiğini doğrulayın ve ardından Microsoft Dynamics CRM sunucusunu listeye ekleyin.

    Microsoft Dynamics CRM 2011 kullanıyorsanız, Exchange yönlendiricisinin yüklü olduğu sunucuyu listeye eklediğinizden emin olun.

  6. SMTP hizmetini yeniden başlatın. Bunu yapmak için şu adımları uygulayın:

    1. Başlat'ı seçin, Programlar'ın üzerine gelin, Yönetim Araçları'nın üzerine gelin ve hizmetler'i seçin.
    2. Basit Posta Aktarım Protokolü 'ne (SMTP) sağ tıklayın ve yeniden başlat'ı seçin.
Connections Denetimini Doğrulama
  1. Başlat'ı seçin, Programlar'ın üzerine gelin, Microsoft Exchange'in üzerine gelin ve ardından Sistem Yöneticisi'ni seçin.

  2. Sunucular'ı seçin, Exchange sunucusunun adını seçin, Protokoller'i ve ardından SMTP'yi seçin.

  3. Varsayılan SMTP Sanal Sunucusu'na sağ tıklayın, Özellikler'i ve ardından Erişim sekmesini seçin.

  4. Connections Denetimi alanında Bağlantı'yı seçin.

  5. Varsayılan olarak , Aşağıdaki liste dışında tümü seçeneği seçilidir. Microsoft Dynamics CRM sunucusu bu listeye eklenirse, Microsoft Dynamics CRM sunucusunun eklenmesinin nedenini belirlemek için Exchange yöneticisine başvurmanız gerekir.

    Not

    Microsoft Dynamics CRM e-posta iletilerinin düzgün çalışması için, Microsoft Dynamics CRM sunucusunun Exchange sunucusuna bağlanabilmesi gerekir.

  6. Yalnızca aşağıdaki liste seçeneği belirlenmişse, Exchange sunucusuna bağlanmasına izin vermek için Microsoft Dynamics CRM sunucusunu listeye eklemeniz gerekir.

  7. Bağlantı Denetimi ayarlarında herhangi bir değişiklik yaptıysanız SMTP hizmetini yeniden başlatın. Bunu yapmak için şu adımları uygulayın:

    1. Başlat'ı seçin, Programlar'ın üzerine gelin, Yönetim Araçları'nın üzerine gelin ve hizmetler'i seçin.
    2. Basit Posta Aktarım Protokolü 'ne (SMTP) sağ tıklayın ve yeniden başlat'ı seçin.

Exchange Server 2007

Microsoft Exchange Server 2007 kullanıyorsanız, yeni bir Exchange alma bağlayıcısı oluşturmanız, anonim kullanıcı için bağlayıcıyı yapılandırmanız, alma bağlayıcısı için protokol izinlerini yapılandırmanız ve ardından Exchange sunucusunda Microsoft Exchange Aktarım Hizmeti'ni yeniden başlatmanız gerekir.

Exchange alma bağlayıcısı oluşturma
  1. Exchange Yönetim Konsolu açın.

  2. Sunucu Yapılandırması'nu genişletin.

  3. Hub Aktarım'ı seçin.

  4. Bağlayıcıları Al'a sağ tıklayın ve ardından Yeni Alma Bağlayıcısı'nı seçin.

  5. Ad kutusuna bir ad yazın.

  6. Bu Alma bağlayıcısı için hedeflenen kullanımı seçin listesinde İç'i ve ardından İleri'yi seçin.

  7. Uzak Ağ Ayarları bölümünde Ekle'yi seçin ve Microsoft Dynamics CRM sunucusunun IP adresini yazın.

    Not

    0.0.0.0-255.255.255.255.255 değerini görürseniz Sil'i seçin.

  8. İleri'yi, Yeni'yi ve ardından Son'u seçin.

Anonim kullanıcı için bağlayıcıyı yapılandırma
  1. Oluşturduğunuz Exchange alma bağlayıcısını sağ tıklatın ve özellikler'i seçin.
  2. İzin Grupları sekmesini seçin.
  3. Bağlayıcıyı al seçeneğine kimlerin bağlanmasına izin verileceğini belirtin seçeneğininAnonim kullanıcılar olarak ayarlandığından emin olun, Uygula'yı ve ardından Tamam'ı seçin.
Alma bağlayıcısı için protokol izinlerini yapılandırma

Not

Bu adımları tamamlamak için Windows Destek Araçları'nın yüklü olması gerekir. Adsiedit.msc aracını yalnızca deneyimli bir yönetici kullanmalıdır.

  1. Adsiedit.msc aracını başlatın.
  2. Yapılandırma'yı genişletin, Hizmetler'i genişletin, Microsoft Exchange'i genişletin, CN= İlk Kuruluş'u genişletin, Yönetim Grupları'nı genişletin, Exchange Yönetim Grubu'nu genişletin, Sunucular'ı genişletin, Protokoller'i genişletin ve ardından SMTP Alma Bağlayıcıları'nı genişletin.
  3. Oluşturduğunuz Exchange alma bağlayıcısını sağ tıklatın ve özellikler'i seçin.
  4. Güvenlik sekmesini seçin.
  5. Anonim Oturum Açma'ya tıklayın.
  6. Herhangi bir Alıcıya İleti Gönder onay kutusunu ve Yetkili Etki Alanı Göndereni Kabul Et onay kutusunu seçin, Uygula'yı ve ardından Tamam'ı seçin.
Exchange sunucusunda Microsoft Exchange Aktarım Hizmeti'ni yeniden başlatın
  1. Başlat'ı seçin, Çalıştır'ı seçin, services.msc yazın ve tamam'ı seçin.
  2. Microsoft Exchange Aktarım Hizmeti'ne sağ tıklayın ve yeniden başlat'ı seçin.