El tamaño del archivo de cola emf puede ser muy grande al imprimir un documento que contiene una gran cantidad de datos ráster

En este artículo se proporciona una solución para un problema en el que el tamaño del archivo de cola de metarchivo mejorado (EMF) crece muy grande al imprimir un documento que contiene muchos grupos de datos ráster.

Se aplica a: Windows Server 2012 R2
Número de KB original: 919543

Síntomas

Al imprimir un documento que contiene una gran cantidad de datos ráster, el tamaño del archivo de cola de metarchivo mejorado (EMF) puede ser muy grande. Archivos como archivos de Adobe .pdf o documentos de Microsoft Word .doc/.docx pueden contener una gran cantidad de datos ráster. Es más probable que los archivos de Adobe .pdf y los documentos de Word .doc/.docx que contienen degradados contengan una gran cantidad de datos ráster.

Causa

Este problema se produce porque la interfaz de dispositivo gráfico (GDI) no comprime los datos de trama cuando GDI procesa archivos de cola emf y genera archivos de cola emf.

Este problema es muy importante con impresoras que admiten resoluciones más altas. El tamaño de los datos ráster aumenta cuatro veces si los puntos por pulgada (ppp) del archivo aumentan dos veces. Por ejemplo, un archivo .pdf de 1 megabyte (MB) puede generar un archivo de cola emf de 500 MB. Por lo tanto, es posible que observe que el proceso de impresión disminuye en el rendimiento.

Solución

Para resolver este problema, omita la cola de EMF. Para ello, siga estos pasos:

  1. Abra el cuadro de diálogo de propiedades de la impresora.
  2. Haga clic en la ficha Opciones avanzadas.
  3. Haga clic en la opción Imprimir directamente en la impresora .

Nota:

Esto deshabilitará todas las características basadas en procesador de impresión, como las siguientes:

  • N-up
  • Watermark
  • Impresión de folletos
  • Intercalación de controladores
  • Escalado a ajuste

Una vez que la cola emf está desactivada, puede usar la aplicación para realizar cualquier impresión N-up necesaria.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".

Más información

Pasos para reproducir el problema

  1. Abra el cuadro de diálogo de propiedades de cualquier impresora de bandeja de entrada.
  2. Haga clic en la ficha Opciones avanzadas.
  3. Asegúrese de que la opción Imprimir directamente en la impresora no está seleccionada.
  4. Haga clic para activar la casilla Mantener documentos impresos .
  5. Imprima un documento de Adobe .pdf que contenga muchos grupos de datos ráster.
  6. Compruebe el tamaño del archivo de cola emf.

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante el uso de TSS para cuestiones relacionadas con la experiencia del usuario.