O serviço host do agente SMS não é iniciado depois que você reinicia um computador cliente do Servidor de Gerenciamento de Sistemas 2003

Este artigo fornece uma resolução para o problema de que o serviço host do Agente SMS não é iniciado depois que você reinicia um computador cliente do Servidor de Gerenciamento de Sistemas 2003.

Aplicável ao: Windows 10 - todas as edições
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Importante

Este artigo contém informações sobre como modificar o Registro. Faça backup do Registro antes de modificá-lo. Você deve saber como restaurar o Registro caso ocorra algum problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número do artigo a seguir para exibir o artigo na Base de Dados de Conhecimento da Microsoft:
256986 Descrição do registro do Microsoft Windows

Sintomas

Depois de reiniciar um computador cliente do Microsoft Systems Management Server (SMS) 2003, o serviço host do agente SMS (Ccmexec.exe) não é iniciado. Quando esse problema ocorre, entradas de erro que se assemelham às seguintes podem aparecer no arquivo CCMExec.log no computador cliente SMS:

CCMExec.log entrada de arquivo 1
Serviço CCMEXEC inicial... $$<CcmExec><Sex 13 8:13:13.819 2004 Central Standard Time><thread=1216 (0x4C0)>
Em execução no computadorName como sistema de usuário.
$$<CcmExec><Sex Feb 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
ERRO!! O WBEM não foi encontrado no caminho do sistema. $$<CcmExec><Sex Feb 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
O WBEM foi adicionado com êxito à variável de ambiente de processo PATH. $$<CcmExec><Sex Feb 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Inicializando COM. $$<CcmExec><Sex Feb 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Registrando-se para notificações de alteração de registro em log. $$<CcmExec><Sex Feb 13 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Configurando o componente de log padrão para o processo. $$<CcmExec><Sex Feb 13 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Definir o serviço status como RUNNING. $$<CcmExec><Sex Feb 13 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Verificando se o reparo é necessário. $$<CcmExec><Sex Feb 13 8:13:13.889 2004 Central Standard Time><thread=1216 (0x4C0)>
Falha ao abrir para o namespace WMI '\\root\ccm' (80004002) $$<CcmExec><Sex Feb 13 8:13:17.224 2004 Central Standard Time><thread=1216 (0x4C0)>
CCMExec.log entrada de arquivo 2
25/1/2006 9:16:35 Falha ao abrir para o namespace WMI '\\raiz\ccm' (8004100a)
Falha em 25/1/2006 9:16:35 PMCCMDoCertificateMaintenance (0x8004100a).
25/1/2006 9:16:35 Falha ao abrir para o namespace WMI '\\root\CCM\Events' (8004100a)
25/1/2006 9:16:35 PMCCMDoCertificateMaintenance() levantou CCM_ServiceHost_CertificateOperationsFailure status evento.
25/1/2006 9:16:35 Configurações do serviço de carregamento.
25/1/2006 9:16:35 Falha ao abrir para o namespace WMI '\\root\ccm\Policy\Machine' (8004100a)
25/1/2006 9:16:35 Configurações de serviço de carregamento do PmError. 0x8004100a de código
25/1/2006 9:16:35 Falha na inicialização doPhase 0 (0x8004100a).
25/1/2006 9:16:35 Falha na inicialização de serviço (0x8004100a).
25/1/2006 9:16:35 PMShutting down AdditonallyCCMEXEC...
Além disso, o arquivo Wbemcore.log pode conter uma entrada de erro que se assemelha ao seguinte:
(Sex Feb 13 08:13:13 2004.69289) : a entrada do Registro está indicando que uma configuração está em execução
(Sex Feb 13 08:14:13 2004.129856) : construção CFactory
(sex feb 13 08:14:13 2004.129886) : destruição CFactory
(Sex Feb 13 08:14:13 2004.129896) : Criado WINMGMT_ACTIVE mutex
(Sex Feb 13 08:14:13 2004.129946) : Leitura de informações de configuração do registro
(Sex Feb 13 08:14:16 2004.132800) : Preparando uma solicitação de namespace init para namespace ativo //./ROOT/ccm/policy
(Sex Feb 13 08:14:16 2004.132901) : Preparando uma solicitação de namespace init para namespace ativo //./root/CIMV2
(Sex Feb 13 08:14:16 2004.132961) : Preparando uma solicitação de namespace init para namespace ativo //./root/subscription
(Sex Feb 13 08:14:16 2004.133021) : Inicializando namespace //./ROOT/ccm/policy
(Sex Feb 13 08:14:16 2004.133041) : Inicializando namespace //./root

Motivo

Esse problema ocorre quando uma ou ambas as seguintes condições são verdadeiras:

  • A variável de caminho %SystemRoot%\System32\Wbem não está listada no caminho do sistema no computador cliente.
  • O tipo da entrada do Registro de Caminho está incorreto no computador cliente SMS.

O problema também pode ocorrer quando o serviço WMI (Instrumentação de Gerenciamento do Windows) não é iniciado em tempo hábil.

Resolução

Para resolver esse problema, use um dos métodos a seguir.

Método 1: verifique se a variável %SystemRoot%\System32\Wbem está listada no caminho do sistema no computador cliente

  1. Clique em Iniciar, clique em Executar, digite sysdm.cpl e clique em OK.

  2. Clique na guia Avançado e clique em Variáveis de Ambiente.

  3. Em Variáveis de sistema, clique em Caminho e clique em Editar.

  4. Verifique se %SystemRoot%\System32\Wbem está listado na caixa Valor variável . Se esse valor não estiver listado, você deverá adicioná-lo. Para fazer isso, siga estas etapas:

    1. Na caixa de diálogo Editar Variável do Sistema , clique após o fim do texto na caixa Valor variável e digite:
      ;%SystemRoot%\System32\Wbem

    2. Clique em OK três vezes para salvar as alterações.

Método 2: defina o tipo da entrada do Registro de Caminho como REG_EXPAND_SZ

Aviso

Poderão ocorrer sérios problemas se você modificar o Registro incorretamente com o Editor do Registro ou outro método. Esses problemas podem exigir a reinstalação do sistema operacional. A Microsoft não pode garantir que esses problemas possam ser resolvidos. Modifique o Registro a seu próprio risco.

  1. Clique em Iniciar e em Executar, digite regedit e clique em OK.

  2. No Registro Editor, localize e clique na subchave do registro a seguir:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

  3. Verifique se o tipo da entrada Path está REG_EXPAND_SZ e não REG_SZ. Se o tipo dessa entrada for REG_SZ, você deverá copiar as informações do caminho, excluir a entrada do Caminho existente e criar uma nova entrada do tipo REG_EXPAND_SZ. Para fazer isso, siga estas etapas:

    1. No Registro Editor, clique duas vezes no valor Caminho.
    2. Clique com o botão direito do mouse no texto na caixa de dados Valor , clique em Copiar e clique em Cancelar.
    3. Cole o texto em um documento do Bloco de Notas.
    4. No Registro Editor, clique com o botão direito do mouse em Caminho e clique em Excluir.
    5. Na barra de menus, clique em Editar, aponte para Novo e clique em Valor de Cadeia de Caracteres Expansível.
    6. Digite Caminho e pressione ENTER.
    7. Clique duas vezes em Caminho.
    8. Clique com o botão direito do mouse na caixa de dados Valor , clique em Colar e clique em OK.
    9. Saia do Editor do Registro.

Mais informações

Para obter mais informações sobre como solucionar problemas de instalações avançadas de push do cliente, confira o seguinte artigo na Base de Dados de Conhecimento da Microsoft:

928282 Como solucionar problemas avançados de instalação por push do cliente no Servidor de Gerenciamento de Sistemas 2003 e no System Center Configuration Manager 2007