Il programma di installazione di Office Suite 2010 non verrà riavviato dopo l'interruzione di un'installazione iniziale

Sintomi

Considerate il seguente scenario: Quando si installa una famiglia di prodotti Microsoft Office o un programma di Office, il processo di installazione viene interrotto. Inoltre, il programma di installazione non può eseguire il rollback dell'installazione di Office. In questo scenario, quando si tenta di installare di nuovo la stessa famiglia di prodotti Office o il programma di Office, viene visualizzato il messaggio di errore seguente: Microsoft Office suite_name rilevato un errore durante l'installazione.

Causa

Questo problema può verificarsi se il file Rgstrtn.lck non viene rimosso dal computer. Se questo file è presente quando si tenta di installare la stessa famiglia di prodotti Office o il programma di Office che si è tentato di installare in precedenza, il programma di installazione rileva il file. Il programma di installazione arresta quindi l'installazione.

Soluzione alternativa

Per risolvere questo problema, eliminare il file Rgstrtn.lck. A tale scopo, seguire i passaggi appropriati per il sistema operativo in uso.

Avviso

Se si installa un altro programma Microsoft dopo aver ricevuto il messaggio di errore indicato nella sezione "Sintomi", è possibile che si verifichino problemi con il sistema della Guida del programma se si esegue questa procedura. Se è stato installato un altro programma Microsoft dopo aver ricevuto il messaggio di errore indicato nella sezione "Sintomi", disinstallare il programma prima di seguire questa procedura.

Per risolvere questo problema, eliminare il file Rgstrtn.lck. A tale scopo, seguire i passaggi appropriati per il sistema operativo in uso.

In Windows XP

  1. Fare clic su Start, selezionare Esegui, digitare cmd e fare clic su OK.

  2. Digitare cd "%allusersprofile%\Application Data\Microsoft Help" e quindi premere INVIO.

  3. Digitare attrib -h rgstrtn.lck e quindi premere INVIO.

  4. Digitare del rgstrtn.lck e quindi premere INVIO.

  5. Digitare dir /b /od /ad e quindi premere INVIO.

  6. Digitare rd /q /s "<nomi> di cartella", quindi premere INVIO.

    Nota I <nomi> delle cartelle sono i nomi di cartella elencati dopo l'esecuzione del comando nel passaggio 5. Deve essere presente uno spazio tra ogni nome di cartella. Ad esempio: rd /q /s "nomecartella1" "nomecartella2" "nomecartella3".

  7. Digitare exit e quindi premere INVIO.

In Windows Vista e Windows 7

  1. Fare clic su Start, quindi digitare cmd nella casella Avvia ricerca e quindi fare clic su OK.

  2. Digitare cd "%allusersprofile%\Microsoft Help", quindi premere INVIO,

  3. Digitare attrib -h rgstrtn.lck e quindi premere INVIO.

  4. Digitare del rgstrtn.lck e quindi premere INVIO.

  5. Digitare dir /b /od /ad e quindi premere INVIO.

  6. Digitare rd /q /s "<nomi> di cartella", quindi premere INVIO.

    Nota I <nomi> delle cartelle sono i nomi di cartella elencati dopo l'esecuzione del comando nel passaggio 5. Deve essere presente uno spazio tra ogni nome di cartella. Ad esempio: rd /q /s "nomecartella1" "nomecartella2" "nomecartella3"

  7. Digitare exit e quindi premere INVIO.

Dopo aver eseguito questi passaggi, è possibile provare a installare la famiglia di prodotti Office o l'applicazione di Office che si è tentato di installare in precedenza.

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".